Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Projekt nietypowej przetwornicy stabilizowanej

aj123 08 Lut 2012 14:37 2759 20
  • #1 08 Lut 2012 14:37
    aj123
    Poziom 25  

    Witam.
    Po ostatnich testach z modułem przetwornicy posiadającej stabilizację na transoptorze odbiłem się od ściany przy próbie ustabilizowania spadków napięcia. Po wielu testach nie znalazłem rozwiązania problemu więc postanowiłem zaprojektować nową, zupełnie inną przetwornicę także ze stabilizacją.

    Głównym założeniem nowego projektu jest wywalenie sterownika na stronę wtórną. Takie rozwiązanie znacznie komplikuje układ, no ale cóż... Poniżej przedstawiam schemat blokowy zgrubnie ukazujący ideę działania:

    Projekt nietypowej przetwornicy stabilizowanej

    Po stronie pierwotnej zostają zabezpieczenia (napięciowe, zwarciowe), które wyłączą sterownik za pomocą transoptora. Kluczami będę sterował poprzez trafo sterujące. Problem pojawia się przy zasilaniu sterownika. Muszę jakoś przenieść te 12V na stronę wtórną. Postanowiłem użyć wzmacniacza operacyjnego do generowania przebiegu np 20kHz. Taki generator miałby sterować trafem w topologii flyback. Teraz pytania:

    1. Czy mógłbym użyć jako transoptora PC817 ? (mam kilka sztuk)
    2. Do sterowania trafem separacyjnym chciałbym użyć jednego z 4 wzmacniaczy operacyjnych (4 w 1 obudowie). Tutaj liczę na jakiegoś "gotowca" i wzór jak policzyć częstotliwość :) (niby szukałem, ale powiem szczerze że wcześniej nie budowałem generatorów na wzmakach operacyjnych i nawet nie wiem czy to pójdzie na 20kHz).

    Schemat zabezpieczeń z czasem także wrzucę.

  • #2 08 Lut 2012 17:16
    -RoMan-
    Poziom 42  

    Odnoszę wrażenie, że nie znając podstaw elektroniki usiłujesz wyważyć otwarte drzwi.

    Zacznij od podania parametrów we/wy przetwornicy, która masz zamiar zrobić i pokazania schematu dotychczasowego, nieudanego rozwiązania.

  • #3 08 Lut 2012 17:37
    aj123
    Poziom 25  

    Oczywiście, zapomniałem podać parametry :)
    Napięcie wejściowe = 10-15V
    Napięcie wyjściowe (stabilne) = +/-30V
    Moc wyjściowa = 150W
    Częstotliwość = 30kHz

    Schemat w załączniku. Wykaz elementów:

    1k - R12, R17, R18, R19, R21, R25
    10k - R3, R7, R8, R11
    160R - R24, R26, R27
    36k - R4, R23
    22k - R2, R5
    12k - R1
    100k - R6
    6,2k - R20
    2,2k - R9
    2,4k - R22
    33R - R13, R16
    22R/1W - R14, R15
    POT. 22k - R10

    1,5nF - C1, C2
    82pF - C9
    330pF - C8
    47uF - C5
    4,7uF - C3
    10nF - C6, C7
    100nF - R12, R13, R15
    1000uF - C14
    2200uF - C10, C11

    Reszta to wiadomo :) (LM358, TL494, TL431, 6N135, BC556, BC327, trafo, diody, dławiki, mosfet'y). Dławiki na wyjściu to 65uH na każdą gałąź.

  • #4 08 Lut 2012 20:18
    -RoMan-
    Poziom 42  

    A jaki był problem?

  • #5 08 Lut 2012 21:19
    aj123
    Poziom 25  

    Problem polegał na tym że przetwornica nie trzymała stałego napięcia pod obciążeniem. Znaczy trzymała (ja tam miałem wtedy ustawione +/-40V) i po obciążeniu jej żarówką wszystko było ok. Dopiero jak podłączyłem wzmacniacz to przy dość głośnym graniu z każdym basem napięcie przysiadało coraz bardziej (wzmacniacz AVT2762), aż w końcu wbudowane zabezpieczenie podnapięciowe wyłączało wzmacniacz.

    Próbowałem innego układu stabilizacji (także ze sprzężeniem zwrotnym) i dalej to samo. Zasilam układ z aku. Filtracja na wejściu 4700uF, na wyjściu 2200uF na każdą gałąź. Dławiki 65uH na każdą gałąź. Próbowałem bez dławików - to samo. Większa filtracja na wyjściu - dalej to samo. Nawinąłem od nowa trafo - bez zmian (na pewno dobrze nawinięte, nie pierwszy raz nawijałem). W skrócie - na pierwotnym 6 zwoi drutem 4x0,8mm na każdą stronę. Pierwotne 29 zwoi drutem 1x0,8mm na każdą gałąź. (przekładnia 4,8x).

    Jak widać ze schematu stabilizacja jest podłączona bezpiśrednio do komparatora TL494. Masz jakiś pomysł co z tym zrobić ?

  • #6 08 Lut 2012 22:01
    -RoMan-
    Poziom 42  

    Wyciąganie z Ciebie informacji, to ciężka praca... Na jakim rdzeniu był nawinięty transformator?

    Mam wrażenie, że po prostu przeciążałeś przetwornicę i stąd problem.

    Wywal TL431, wstaw diodę Zenera 27V. Równolegle do diody transoptora wstaw rezystor 1k, żeby wymusić minimalny prąd. Wymień transoptor na taki bez tranzystora wzmacniającego - byle 817.

    Ale przede wszystkim - na czas testów - poodłączaj te wszystkie zabezpieczenia - będziesz wiedział, czy mieszają Ci zabezpieczenia czy tez coś innego.

    Sprawa ostatnia ale nie najmniej ważna - mierz napięcie zasilające układ - może źródło nie wyrabia po prostu?

  • #7 08 Lut 2012 22:23
    aj123
    Poziom 25  

    Rdzeń to EI-33 (taki z atx'a, nie popękany i bez szczeliny)

    Akumulator 45Ah :) Świeżo ładowany, utrzymuje ~13V.

    Co do samego układu - masz coś takiego na myśli ?
    Projekt nietypowej przetwornicy stabilizowanej

    Nie wydaje mi się abym przeciążał przetworkę... Była ona projektowana pod moc 150W i tyle powinna wytrzymać, a oddaje może z 60W. Zabezpieczenia były odpięte.

    Dodano po 2 [minuty]:

    Widzę że masz dużą wiedze w tym zakresie więc na pewno projektowałeś kiedyś przetwornice ze stabilizacją. Jaki układ do stabilizacji stosujesz najczęściej ? (z separacją galwaniczną)

  • #8 08 Lut 2012 22:35
    -RoMan-
    Poziom 42  

    Brakuje rezystora ograniczającego prąd diody Zenera - szeregowo 680 omów powinno wystarczyć.

    To, że akumulator jest świeżo naładowany w niczym nie zmieni faktu, że w miarę testów napięcie na nim nie będzie spadać. A przełożenie spadku napięcia o 1V po stronie pierwotnej da prawie 5V mniej po wtórnej. Dlatego podczas testów należy stale monitorować napięcie zasilania.

    Zabezpieczenie przeciążeniowe jest w tym układzie wprost zależne od temperatury tranzystorów kluczujących. Ich Rdson rośnie w miarę wzrostu temperatury.

    Co do rdzenia - budowanie przetwornic na podstawie wymiotków z szuflady to zły pomysł. Powinieneś użyć rdzenia toroidalnego - taki transformator jest mniej wrażliwy na niestaranność nawinięcia.

  • #9 08 Lut 2012 23:30
    aj123
    Poziom 25  

    Nie narzekam na jakość nawijania :) Budowałem przetwornice bez stabilizacji i jakoś udawało mi się dobrze trafo nawinąć. Ten model to oczywiście prototyp, wersja finalna dostanie nowe trafo (np ETD34). Nie nawijam toroidów bo to ciężki kawał chleba :)

    Napięcie na wejściu stale monitoruje i nie spada poniżej 12,7V.

    Tak, wiem. To jest wada tego typu pomiaru prądu. Przy tak małych mocach wytracanych na kluczach (~5W/klucz) te zmiany rezystancji kanału nie powinny być aż tak straszne ?

  • #10 08 Lut 2012 23:56
    -RoMan-
    Poziom 42  

    Nawijanie toroidów dla tak małej mocy to banalna zabawa. Nie widzę sensu wstawiania ETD34 dla tak mikroskopijnej mocy.

    Co do zmian rezystancji - ja przyjmuję rezystancję podczas pracy 1.6 raza wyższą niż podawana dla 25stopni. Przetwornica 150W przy napięciu 12V pobiera średnio ponad 12A. A to oznacza w szczytach prąd rzędu 20A. W miarę rozgrzewania się tranzystorów np. IRFZ44 spadek napięcia rośnie z 0.56V do 0.9V - ale tylko pod warunkiem dobrze dobranych dławików wyjściowych. Bo jeśli dławiki się nasycają, to prądy po stronie pierwotnej rosną bardzo mocno i rośnie też spadek napięcia...

  • #11 09 Lut 2012 00:10
    aj123
    Poziom 25  

    Co do samych dławików... Wypowiesz się nt ich indukcyjności ? Ja zastosowałem dwa osobne dławiki, każdy po 65uH.

    Teraz będę budował przetworkę z Twoim układem transoptora (jak odpali na prototypie). Tam będzie napięcie wyjściowe +/-30V, jeden kanał wzmacniacza, minimalna rezystancja głośnika równa 4R. Dławik licze stronką :

    http://schmidt-walter.eit.h-da.de/smps_e/hgw_smps_e.html

    Vin 10-14.4V
    Vout 30V
    Iout tutaj mam wstawić prąd szczytowy ? (V/R) - wstawiam 7,5A
    f 30kHz

    Wychodzi 60uH. Dobrze ?

    Dodano po 1 [minuty]:

    Co w przypadku, kiedy na wyjście chcę podłączyć dwa wzmacniacze ?

  • #12 09 Lut 2012 00:27
    -RoMan-
    Poziom 42  

    Jak mam się wypowiadać o dławikach, skoro nie wiem, jak zostały zrobione? Znów mi każesz zgadywać?

  • #13 09 Lut 2012 11:50
    aj123
    Poziom 25  

    No tak, współpraca ze mną jest ciężka ;)

    Dławiki to dwa osobne rdzenie, każdy na inną szynę zasilania. Każdy dławik ma po 65uH. Nie wiem ile jest zwoi - nawijałem metodą prób i błędów - nawinąłem 10zw, zmierzyłem indukcyjność i potem znowu coś dowinąłem i tak aż małem 65uH. Rdzenie to małe toroidy z atx'a (tak, znowu robie coś ze starych bebechów z szuflady). Średnica zewnętrzna rdzenia wynosi ~20mm. Nawijane drutem 0,8mm.

    Czy jeśli obliczam dławiki dla przetwornicy, która będzie współpracować z dwoma wzmacniaczami to muszę przyjąć 2x większy prąd ?

    Dodano po 1 [godziny] 36 [minuty]:

    Edit:
    Właśnie poskładałem ten Twój układ na PC817. Dalej to samo :(

  • #14 09 Lut 2012 11:52
    -RoMan-
    Poziom 42  

    Czyli problem nie tkwi w sprzężeniu zwrotnym ale albo w zasilaniu albo w zabezpieczeniach albo w nawinięciu transformatora. Albo we wszystkim na raz. Bez oscyloskopu nie ruszysz.

  • #15 09 Lut 2012 12:00
    aj123
    Poziom 25  

    No oscyloskopu nie posiadam, niestety...

    Jak znajdę chwilę czasu to zrobię próbę "na krótko". Tzw połącze masy weścia i wyjścia, zapnę sprzężenie zwrotne do wzmacniacza błędu i poprzez dzielnik podam napięcie na wzmacniacz błędu. To pozwoli całkowicie wyeliminować albo potwierdzić problem z transoptorem.

  • #16 09 Lut 2012 19:49
    aj123
    Poziom 25  

    Jestem po próbie... Dalej nic :( Poddaje się, nie mam już żadnego pomysłu co się z tym dzieje...

  • #17 09 Lut 2012 21:36
    -RoMan-
    Poziom 42  

    Ale już wcześniej Ci napisałem, że to nie problem sprzężenia zwrotnego.

  • #18 09 Lut 2012 22:02
    aj123
    Poziom 25  

    Ok, czyli na razie będę się przymierzał do układu z pierwszego postu. Jak myślisz, ma to szanse działać ?

  • #19 09 Lut 2012 22:23
    -RoMan-
    Poziom 42  

    Nie potrafisz poprawnie wykonać i uruchomić banalnej przetwornicy sterowanej TL494 a chcesz tworzyć wynalazek? Bez oscyloskopu?
    Może trochę więcej pokory?

  • #20 09 Lut 2012 23:02
    aj123
    Poziom 25  

    Zacznijmy od tego że nie jest to pierwsza przetworka którą wykonuje, ale pierwsza, która ma stabilizacje na transoptorze i właściwie pierwsza, z którą nie umiem sobie poradzić...

    Może dla kontrastu podrzuć coś swojego ? Jakiś układ, który spełniałby moje wymagania ?

  • #21 09 Lut 2012 23:37
    -RoMan-
    Poziom 42  

    Sam przed chwilą pisałeś, że nie masz stabilizacji również bez transoptora. Czyli jednak nie potrafisz uruchomić przetwornicy. I zaczynasz teraz pogrywać ze mną ambicjonalnie. Poszperaj trochę, sprawdź czym się zajmuję a potem dopiera próbuj cokolwiek.

    Zacznij od kupna oscyloskopu. Na Allegro można kupić taniutki nowy oscyloskop cyfrowy z pasmem 1MHz - 299PLN. Oczywiście bardzo szybko stwierdzisz, że to za mało, ale na pierwsze kroki w uruchamianiu przetwornic wystarczy. Jak Cię stać - kup coś lepszego. Albo wypożycz. Pooglądaj przebiegi i znajdź przyczynę spadku napięcia. Jak uruchomisz i doprowadzisz do poprawnego działania prostą przetwornicę, to wtedy zajmij się wynalazkami.

TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo