Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Atmega 8A-PU, błąd AVRDude przy próbie odczytania fusebitów

ZBIQ 10 Lut 2012 18:26 1999 3
  • #1 10 Lut 2012 18:26
    ZBIQ
    Poziom 17  

    Witam.
    Posiadam zestaw evb4.3 (układ FT232RL). Chciałem zaprogramować uC poza płytką jednak od 6 godzin walczę i cały czas jestem na przegranej pozycji.Mianowicie :
    Moja atmega to dokładnie atmega8A-PU. Wszystkie połączenia z isp są dobrze (vcc,avcc,gnd,reset przez opornik do vcc).
    Używam avr-dude dostarczonego od producenta , programator : FT232R Synchronous BitBang (EvB).
    Przy próbie odczytania fusebitów otrzymuję komunikat :

    avrdude.exe: BitBang OK
    avrdude.exe: pin assign miso 3 sck 5 mosi 6 reset 7
    avrdude.exe: drain OK

    ft245r: bitclk 4800 -> ft baud 2400
    avrdude.exe: ft245r_program_enable: failed
    avrdude.exe: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check.


    avrdude.exe done. Thank you.

    Dodam, że próba odczytania z atmegi32 umieszczonej na płytce kończy się pomyślnie (sterowniki w takim razie odpadają).

    Nie mam już pomysłów co może być nie tak. Jestem bliski wyrzucenia tej atmegi8 za okno.

    Prosiłbym o podpowiedzi/uwagi.
    Pozdrawiam

    0 3
  • #2 11 Lut 2012 00:04
    435758
    Użytkownik usunął konto  
  • Pomocny post
    #4 11 Lut 2012 06:10
    435758
    Użytkownik usunął konto