Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Bascom AVR i programator USBasp

elektro-pol 13 Lut 2012 17:12 2276 4
  • #1 13 Lut 2012 17:12
    elektro-pol
    Poziom 12  

    Witam
    mam mały problem i proszę o w miarę możliwości szybką odpowiedz
    Dzisiaj kupiłem ten probramator Linki zostały usunięte - zgodnie z regulaminem pkt.3.1.18 [dzimi]
    Chcę w bascomie 1.11.9.5 zaprogramować układ ATmega8 do sterowania diodami mają się zapalać po kolei
    Program prosty :

    Portc = Output
    Portb = Output
    Portd = Output

    Do
    Portb = &00000000
    Portc = &00000000
    Portd = &00000000

    Portc = &00100000
    Waitms 30
    Portc = &00110000
    Waitms 30
    Portc = &00111000
    Waitms 30
    Portc = &00111100
    Waitms 30
    Portc = &00111110
    Waitms 30
    Portc = &00111111
    Waitms 30
    Portb = &00100000
    Waitms 30
    Portb = &00110000
    Waitms 30
    Portb = &00111000
    Waitms 30
    Portb = &00111100
    Waitms 30
    Portd = &00100000
    Waitms 30
    Portb = &10111110
    Waitms 30
    Portb = &11111110
    Waitms 30
    Portd = &00010000
    Waitms 30
    Portd = &00011000
    Waitms 30
    Portd = &00011100
    Waitms 30
    Portd = &00011110
    Waitms 30
    Portd = &00011111
    Waitms 30
    Jednakże wyskakuje mi błąd:
    Bascom AVR i programator USBasp
    nie wiem co jest grane.
    Po za tym czeba komunikacje ustawić a ja nie wiem jak.

    0 4
  • #2 13 Lut 2012 17:30
    tronics
    Poziom 36  

    Config Portb = Output?

    0
  • #3 13 Lut 2012 19:03
    elektro-pol
    Poziom 12  

    konfiguracja aby port B w układnie był wyjściem. zle?

    0
  • #4 13 Lut 2012 19:38
    tronics
    Poziom 36  

    Kolego, masz Bascom AVR? Zajrzyj no do folderu instalacyjnego, znajdziesz tam taki katalog jak EXAMPLES, a w środku całe mnóstwo przykładów jak określone rzeczy robić. Jest też całkiem przydatna lista instrukcji z opisami w internecie. W tym przypadku nawet nie zadałeś sobie trudu by zobaczyć jak wyglądają prawidłowo zadeklarowane wejścia/wyjścia, a ten przykład masz w EXAMPLES/PORT/port.bas
    Zamiast pytać "co mam źle" radzę zacząć się uczyć podstaw, a dopiero w razie kolejnych niepowodzeń wrócić na forum i szukać pomocy.

    0
  • #5 14 Lut 2012 20:40
    elektro-pol
    Poziom 12  

    ok

    0