Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Konfiguracja Eclipse + plugin AVR. Warning: could not find /tmp

nifelheim 15 Lut 2012 22:08 1538 2
  • #1 15 Lut 2012 22:08
    nifelheim
    Poziom 9  

    Witam,
    Chciałbym do programowania uC wykorzystać środowisko Eclipse.
    1. Ściągnąłem sobie Eclipse Classic 4.1,
    2. Zainstalowałem plugin AVR (przeszedłem ścieżkę konfiguracji z ich strony),
    3. Utworzyłem projekt (C project -> AVR Cross Target Application),
    4. W main.c jest tylko pusta funkcja main()

    Gdy chcę to skompilować otrzymuję taki oto komunikat:

    **** Build of configuration Release for project First AVR ****

    make all
    Building target: First AVR.elf
    Invoking: AVR C Linker
    avr-gcc -Wl,-Map,First AVR.map -mmcu=atmega8 -o "First AVR.elf" ./main.o
    bash.exe: warning: could not find /tmp, please create!
    avr-gcc.exe: AVR.map: No such file or directory
    make: *** [First AVR.elf] Error 1

    **** Build Finished ****

    Najpierw pomyślałem, że to po prostu z powodu brakującego katalogu /tmp (wytłuszczone).
    Utworzyłem go więc w głównym na c:\ dodałem do zmiennych środowiskowych systemu oraz eclipse (zalecenie z faqów na stronie AVR plugin).
    Niestety nic to nie daje.

    Googlałem czy może nie było już tego problemu, poza powyższym nic.

    Czy spotkał się ktoś z Was z takim problemem? Czy możecie pomóc?

    0 2
  • #2 16 Lut 2012 07:16
    435758
    Użytkownik usunął konto  
  • #3 16 Lut 2012 09:19
    nifelheim
    Poziom 9  

    To jest właśnie ten problem.
    Nie zwracałem na to uwagi ponieważ moją czujność uśpiły cudzysłowy.

    Ale teraz już wszystko pięknie działa.

    Dzięki!

    0