Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Willem - problem z zasilaniem

sieger 29 Gru 2004 21:37 1925 12
  • #1 29 Gru 2004 21:37
    sieger
    Poziom 24  

    Witam

    Wersja programatora: płytka v3 jednostronna podpisana www.progs.glt.pl,, montaż własnoręczny

    Po podłączeniu programatora do zasilacza o regulowanym napięciu, napięcie na nim siada (mała wydajność prądowa) i regulator 7805 strasznie się grzeje. Problemu tego nie ma gdy się wyjmie kość przetwornicy MC, a jest gdy wyjmie się wszystkie pozostałe kości i wsadzi spowrotem kość MC 063A. Wg schematu zacząłem analizować połączenia na płytce idąc od gniazdka wejściwego. Pierwszy problem jaki napotkałem, to wartość napięcia na stabilizatorze 7805, niezależnie czy jest zwarta jedna, dwie czy żadna dioda podłączona do nóżki stabilizatora, na wyjściu stabilizatora zawsze jest napięcie 5.16V. Ten kawałek obwodu ma dobrze poprowadzone ścieżki, zależnie od położenia zworki zmienia się spadek napięcia na tych dwóch diodach (0.0V - zwarta, 0.7V - przewodzi)(wszystkie układy scalone wyjęte z podstawek). Wydawało mi się, że wprowadzenie tych dwóch diod do pętli sprzężenia stabilizatora spowoduje podniesienie napięcia wyjściowego stabilizatora o wartość spadku na diodzie.

    Posługuje się schematem: http://members.lycos.co.uk/zsuedat/upload2/dokumentacje/willem_SCH3Bx.pdf

    0 12
  • Pomocny post
    #2 29 Gru 2004 22:55
    mcz1
    Poziom 19  

    Jest tak jak piszesz. Nie włączenie żadnej zwory powinno podnieśc napięcie na układzie o 0.6 V dlatego że obie diody podnosza napięcie na wjściu masy LM 7805 o 1,2 V a następnie te napięcie jest obniżane o 0.6 - 0.7 V na diodzie D 12 i jeśi obie diody - D10 i D11 są sprawne i stabilizator też to tak musi być. Przy pomiarach napięcia wyjściowego należy brać pod uwagę że masa LM7805 jest na poziomie 1.2 V a zazwyczaj napięcia mierzy się na zaciskach stabilizatora, a tutaj nalezy
    mierzyć na zaciskach C4. Ja zsilam swojego Willema z napięcia 12V i też stabilizator się grzeje niestety, ale wytrzymuje pracę.

    0
  • Pomocny post
    #3 30 Gru 2004 10:02
    cyruss
    Poziom 30  

    grzanie mozna zmniejszyć:
    1. dając zasilanie 9V (jeśli przed 7805 jest mostek to 10-11V) - 7805 do dobrej pracy potrzebuje 3V spadku na nim.
    2. zakładając na 7805 radiatorek (ja tak zrobiłem) - bez radiatorka dop. moc strat jest rzędu 1W. Im zimniejsza obudowa tym dłużej pożyje 7805. W fabrycznych urządzeniach często ma ok. 80 stopni C, "gorący" to pojęcie względne.
    W tym konkretnym przypadku może jest walnięta kość przetwornicy, moze też być zgrzana (mniejsza niż znamionowa indukcyjność) cewka w przetwornicy. To się często zdarza, cewka która dobrze się mieści na płytce ma często za cienki drut i się grzeje. To najczęstszy feler w Willemie.

    0
  • #4 30 Gru 2004 11:56
    sieger
    Poziom 24  

    Kolega mcz1 dał dobrą wskazówkę, mierzyłem na nóżce stabilizatora, zmaist na masie układu, na usprawiedliwienie podam, że o tej godzinie co to robiłem i post wysyłałem, to zazwyczaj na drugi dzień się dziwie co ciekawego wychodzi spod mojej ręki wieczorami.

    0
  • Pomocny post
    #5 31 Gru 2004 00:17
    mcz1
    Poziom 19  

    Kolega Cyrrus ma rację co do tego radiatorka, muszę go sobie założyć, po co smażyć stabilizator, a co do pomiarów to popełniłem ten sam błąd bo masy w Wilemie są mało czytelne i jeśli coś robi się szybko to zawsze według sztampy. Pozdrawiam

    0
  • #6 31 Gru 2004 00:29
    sieger
    Poziom 24  

    Może koledzy podpowiedzą jak sprawdzić co się dzieje za stabilizzatorem? Żeby oddzielić układ przetwornicy od reszty układu musiałbym wylutować Q3, Q4, R7, R10, czy może jest jakiś lepszy sposób?
    Tyle psrzecznych informacji na temat willema krąży po sieci, jak kupowałem swoją płytkę gdzieś na wiosnę, to wszędzie pisało, że jednostronna jest ok, a dwustronna z metalizacją ma błędy, teraz wchodze na forum Fachmana i czytam coś całkiem odwrotnego - jednostronna jest do bani. W momencie zakupu jedyne co wiedziałem, to to do czego służy willem, może bym wtedy wybrał płytkę innego producenta, gdybym poczytał, ale w tą włożyłem już troche pracy (kto lutował mostki to wie).

    0
  • Pomocny post
    #7 31 Gru 2004 02:52
    mcz1
    Poziom 19  

    Ten niepozorny scalaczek moze operowa dość dużymi prądami bez zewnętzrnych elementów http://www.fairchildsemi.com/pf/MC/MC34063A.html#GeneralDescription gdzie dławik użyty zamiast porządnej cewki pewnie powoduje kiepską sprawność. Mozna by pokusic sie o wyłączenie przetwornicy a zamiast niej podac zewnętzrne napięcie ze stabilizowanego zasilacza to wówczas bylo by wiadomo jaki jest rzeczywisty pobor prądu na Vpp. Q2 i Q4 pewnie sluża jako klucze więc trzeba by je zostawić, Q3 zaświeca diodą to też nie przeszkadza. żeby wyłączyć przetwornice to przeciąłbym ścieżkę od C7 do kolektora Q4 i odlączył zasilanie U11 końc. 6. Zewnętrzne napięcie Vpp podałbym na kolektor Q4 w miejscu przerwanej ściezki.
    ps. o lutowaniu Willema nic mi nie musisz mówic, kupiłem płytke co prawda polutowaną, ale okazalo się że scalaki były nie na swoich miejscach, a U12 musiałem dobierać inny typ zeby zadziałało. Pozdrawiam

    0
  • #8 31 Gru 2004 10:13
    sieger
    Poziom 24  

    Na razie spróbuje uruchomić willema na przetwornicy, a o wylutowaniu tych tranzystorów pisałem w sensie odcięcia reszty układu od przetwornicy tylko do testów, żeby sprawdzić, gdzie powstaje problem.
    Byłbym wdzięczny, gdyby koledzy podali szacunkowy prąd jałowy pobierany przez przetwornice w willemie.

    0
  • Pomocny post
    #9 31 Gru 2004 13:20
    ko_rex
    Poziom 19  

    Problem z dużym poborem prądu przez przetwornice może tkwić w zbyt kiepskim dławiku. Powinien mieć dość spory rdzeń, aby zbyt szybko się, nie nasycał (jeśli to sie stanie, dławik staje się kawałkiem druta i mamy zwarcie). Dławik o rozmiarze rezystora 1,4 W się nie nadaje absolutnie. Lepiej zainwestować i wsadzić porządną cewkę na toroidzie (taką na 0,2 - 0,5 A) albo przynajmniej większy dławik. To jest dośc częsta przyczyna niesprawności i uszkodzeń Willema.

    0
  • #10 31 Gru 2004 13:36
    sieger
    Poziom 24  

    O, właśńie taką mam, w obudowie jak rezystor. mam pare porządnych dławików wylutowanych z atx'ów i paru innych konstrukcji, tylko nie mam pomierzonych ich wartości - będe jakoś musiał pokombinować z generatorem i oscyloskopem, bo watomierza nie posiadam.
    Jeśli by dać w szereg rezystor o dużej wartości i badać rozkład napięć, to przy wyższych częstotliwościach rezystancja drutu dławika (pare zwojów drutu ok 1mm) będzie pomijalna.

    0
  • Pomocny post
    #11 31 Gru 2004 17:47
    fachman
    VIP Zasłużony dla elektroda

    Cały problem z przetwornicą wynika ze słabej znajomości elektroniki autora projektu. Po pierwsze primo kondensatorek przy MC ma mieć pojemność 1nF a nie 120pF. Na nocie producenta podane jest 102 co daje 1nF a Willem odczytał to jako 120pF. Cóż dobry programista nie musi być dobrym elektronikiem :(
    Drugi rażący błąd to dioda 1N4148, jest do bani, powinna tam być albo Shottky albo inna szybka np z zasilacza impulsowego.
    Poza tym rezystor 0,51R powinien być zastąpiony rezystorem 0,39R, to tylko ograniczenie prądowe ale jakże przykre przy kościach 27Cxx a już nie wspomnę o starszych 27xx.
    Na temat Willema można znaleźc całe kompendium na moim forum, są tam wszystkie poprawki jakich dokonał Willem, opisy są oczywiście po polsku. Największy problem z nim jest przy stosowaniu adapterów, ale to już za daleko wykracza poza temat zasilania.

    0
  • #12 13 Sty 2005 02:39
    wrzaskun
    Poziom 14  

    ja mam dokładnie to samo, sam lutowałem, a robienie mostków to porażka wielogodzinna. 7805 grzeje sie jak diabli, dławik wielkości rezystora, na płytce napis gotronik.prv.pl kupiony na cyfronice.

    Jednak nie wiem jaki dławik zastosować i co pozmieniać, moze kolega co pisze ze na jego forum sa poprawki poda adres do tego, to bym to zaczol naprawiać, a właśnie chce programować układy 27C512 ;(

    0