Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

PT100 z ATmega, na LM358 prośba o sprawdzenie schematu.

grzegorzreszel 10 Mar 2012 21:01 8406 13
  • #1 10 Mar 2012 21:01
    grzegorzreszel
    Poziom 8  

    Proszę o opinie czy ten układ ma prawo działać?

    PT100 z ATmega, na LM358 prośba o sprawdzenie schematu.

    0 13
  • #3 11 Mar 2012 00:33
    grzegorzreszel
    Poziom 8  

    Nie wyciąłem go z datasheet, znalazłem w sieci. Szczerze mówiąc przejrzałem wszystkie datasheet LM358 i nie wiedzę tego.

    Złożyłem ale chyba mam błędne założenie jedno, układ pracuje na 12V LM7805 jest użyty jako stabilizator tak? z góry dzięki za podpowiedź

    0
  • #5 11 Mar 2012 13:58
    grzegorzreszel
    Poziom 8  

    Wykonałem układ na nieprecyzyjnych rezystorach i widzę że nie ma szans działać. Wartości na wyjściu oscylują od 0-5V pod wpływem podgrzewania pt100. Jest to normalne czy raczej źle złożyłem? Jaka jest funkcja układu lm7805 w tym układzie? Ile wynosić będzie Vcc?
    A i ostatnie pytanie jeżeli mam zasilacz stabilizowany 12V to chyba nie musze mieć lm7805?? mam 12V/100mA

    0
  • #6 11 Mar 2012 14:44
    Bruce^666
    Poziom 14  

    Witaj!
    lm7805 stabilizuje napięcie na poziomie 5V wiec go potrzebujesz bo o ile wzmacniacze operacyjne sa zasilane z 12V to mostek z 5V

    0
  • #7 11 Mar 2012 14:51
    grzegorzreszel
    Poziom 8  

    k, rozumiem. czyli to był błąd z mojej strony. Przetestuje i zobaczymy. Jeżeli mam dwa zasilacze stabilizowane 12V i 5V i chciałbym wykorzystać je zamiast używać lm7805 (po prostu nie mam go w tej chwili). Czy muszę zrobić wspólną masę??

    0
  • #8 11 Mar 2012 15:40
    Bruce^666
    Poziom 14  

    Wspólna masa TAK.

    0
  • #9 11 Mar 2012 17:35
    grzegorzreszel
    Poziom 8  

    No dobrze, wszystko "ładnie" polutowałem bo na tych białych płytkach (bread board) to raz działało raz nie. I w sumie działa, pozostaje problem nieliniowości czujnika jeżeli będzie miał znaczenie w tym zakresie. Podłącze układ do ADC atmegi, zaprogramowany mam regulator PI ktory ma wlaczyc grzałkę i utrzymać temperature 200stopni +/- 5 stopni. Czy jest więc konieczna linearyzacja czujnika??

    k = ok (głupi odruch)

    1
  • #10 11 Mar 2012 18:02
    ljmp
    Poziom 14  

    Nie do końca rozumiem co tam kolega chce linearyzować. Czujniki PT100 i inne RTD (pomijam termistory) są liniowe same w sobie, nie tak jak termopary.

    0
  • Pomocny post
    #11 11 Mar 2012 19:54
    Bruce^666
    Poziom 14  

    Nie są tak idealnie 100% linearne, ale kolega ljmp ma racje nie ma potrzeby.Ten błąd jest bardzo mały i dla kolegi pomijalny.

    0
  • #12 12 Mar 2012 15:34
    grzegorzreszel
    Poziom 8  

    Pracuje nad programem teraz ale mam pytanie jak najlepiej połączyć nóżki pt100? lutować je? Przy temp 200 stopni nie rozłączy się? posiadam czujnik o wymiarach około 2,5 na 1,5 mm o cieniutkich nóżkach.

    0
  • #13 12 Mar 2012 16:18
    Bruce^666
    Poziom 14  

    A dokumentacji do czujnika nie masz ? Tam czasem pisze jak lutować jaka temperatura itd. Możesz sobie kupić cynę bezołowiowa on ma temperaturę topnienia ponad 220 stopni. Wiec spokojnie wytrzyma te twoje eksperymenty :)

    pozdro

    0
  • #14 13 Mar 2012 03:37
    grzegorzreszel
    Poziom 8  

    Dobrze kupię taką cynę bo niestety nie mam dokumentacji czujnika. Dziękuje Ci za pomoc wiele wniosłeś do tematu. Układ działa całkiem ładnie przetestuje teraz jak będzie działał gdy rozgrzeje czujnik do około 150 stopni. Przy niskich wartościach napięcia (temperaturze pokojowej) widać błąd pomiaru rzędu 3-4 stopnie. Podpinając rezystancje 180 omów i porównując pomiar z tabelą PT100 różnica też około 4 stopnie. Jest jakiś prosty sposób na zmniejszenie tego błędu? Przychodzi mi do głowy zmiana napięcia REF (teraz mam 5V z zasilania mikro kontrolera przeniesione na rejestrach)

    0