Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

HC11EA9 2d47j XPROG-M "device is silent"

t0mal 21 Mar 2012 22:13 6180 10
  • #1
    t0mal
    Level 14  
    Witam, od dłuższego czasu użeram się z xprogiem-m - nie mogę odczytać wsadu.
    Zrobiłem pająka zgodnie z instrukcją i nic, więc pomyślałem, może jakieś zakłucenia, więc wylutowałem kontroler z układu i umieściłem w adapterze do EA9 - dalej device is silent.

    Pacjent to sterownik pompy VW nr 166 1.9td AAZ, układ jest identyczny jak w temacie: https://www.elektroda.pl/rtvforum/topic1196793-30.html


    Dodam, że wcześniej (w ramach nauki) katowałem sterownik silnia IAW6F z mikrokontrolerem MC68HC11F1 i za nic nie mogłem się połączyć, tak samo jak w przypadku powyżej mignęła dioda zielona i następnie zapalały się dwie czerwone, oraz wyskakuje "device is silent"
    Próbowałem łączyć się przez USB i COM - bez rezultatu.
  • #2
    drozd56
    Level 15  
    Mod A i Mod B masz do masy ? Powinno dać się czytać w układzie, zasil cały układ, a od programatora podłącz tylko masę.
  • #3
    t0mal
    Level 14  
    drozd56 wrote:
    Mod A i Mod B masz do masy

    Tak jest
    drozd56 wrote:
    a od programatora podłącz tylko masę

    To znaczy podnieść pierwszy pin? Czy może pozostać podłączony?
  • #4
    drozd56
    Level 15  
    A sprawdzałeś czy czasem któryś z pinów MOD nie jest podłaczany do +5V ? Tak jest np. w sensorze AIRBAG VW3. Pin może zostać podłączony, masę "złapiesz" gdzie kolwiek .


    HC11EA9 2d47j XPROG-M "device is silent"
  • #5
    t0mal
    Level 14  
    drozd56 wrote:
    A sprawdzałeś czy czasem któryś z pinów MOD nie jest podłączany do +5V

    Chyba jest, jeszcze sprawdzę.
    Ciekawi mnie dlaczego w po wylutowaniu i umieszczeniu w adapterze nie działa.
  • Helpful post
    #6
    drozd56
    Level 15  
    Jeśli któryś z MOD jest podciągnięte do +5V to w układzie nie odczytasz. Kwarc w adapterze masz ?
  • #7
    t0mal
    Level 14  
    No właśnie nie ma, podpiąć mu kwarc na 7 i 8 pin? 16mhz bedzie dobry?

    Już wiem, nie będzie dobry, nie działa.
  • #8
    kubas10
    Level 25  
    Podpinam się do tematu, jak poprawnie podłączyć się do MC68HC11F1(E87J) xprogiem-m aby odczytać w układzie ?? Adapterem HC(S)12 BDM ??
  • #9
    serwiscar
    Level 13  
    Co do odczytu HC11EA9 to Xprogiem-m idzie bez kwarcu, wkladajac tylko w podstawke - dziwne ale tak jest. Co do HC11F1 np z ECU fiata punto, to idzie w ukladzie ale potrzebna jest do tego odpowiednia wiedza - meczylem sie z tym tematem 1 dzien.
  • #10
    kubas10
    Level 25  
    Odpowiednia wiedza pozyskana, poszło i pozdrawiam.
  • #11
    jacekelektro123
    Level 11  
    pytanko małe jaka wiedza i gdzie pozyskana?