Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sinusoidalne źródło prądowe

Atik 04 Sty 2005 15:36 5746 21
  • #1 04 Sty 2005 15:36
    Atik
    Poziom 10  

    Witam !!!

    Mam problem z zaprojektowaniem dwóch sinusoidalnych źródeł prądowych przesuniętych w fazie o 90° i o regulowanej wartości amplitudy prądu od 0 do 1A Regulacja ma odbywać się na drodze cyfrowej co 1mA z jednoczesnym odczytem dokonywanych nastaw. Częstotliwość sygnałow to 50Hz a obciążenie będzie się zmieniać max do 5 Ω. Może wykorzystać do tego wzmacniacz audio np TDA2030A i do tego jakiś potencjometr cyfrowy sterowany z klawiatury. Naciśnięcia klawiszy były by zliczane przez licznik i konwertowane na kod BCD a następnie wyświetlane na wyświetlaczu 7 segmentowym.
    Jeżeli ktoś ma jakiś konkretny i ciekawy pomysł prosiłbym o pomoc.

    Z góry dziękuję. :)

    0 21
  • #2 05 Sty 2005 01:22
    darkfenriz
    Poziom 21  

    Cześć

    sygnał wygeneruj z jakiegoś scalka, np.NE555 i przefiltruj
    dalej daj przesywnik fazowy i dwa przetworniki napięcie-prąd

    nie jestem pewny czy to zadziała?
    może opinie kolegów zweryfikują

    wmacniacz audio sam w sobie jest wzmacniaczem napięcia więc raczej się nie przyda

    pozdrawiam

    0
  • #3 05 Sty 2005 14:04
    darkfenriz
    Poziom 21  

    P.S. mam nadzieję, że prąd stały ci tu nie zawadza, inaczej trzebaby pójść w klasę B

    0
  • #4 05 Sty 2005 14:17
    _jta_
    Specjalista elektronik

    NE555 daje na wyjściu prostokąt, a nie sinusoidę - żeby uzyskać sinusoidę trzeba by użyć jakiegoś mostka Viena.

    0
  • #5 05 Sty 2005 14:39
    jarek_krakow
    Poziom 16  

    potrzebny Ci generator kwadraturowy - daje sinus i cosinus. pewnie będzie w większości książek do elektroniki . np "wzmacniacze operacyjne" Nadachowski
    potem regulacja wzmocnienia cyfrowa (wymyśl coś)
    wzmacniacz mocy i sprzężenie bierz z opornika o jakiejś małej wartości .opornik z jednej strony do masy. z drugiej do obciążenia i do wejścia odwracającego wzmacniacza - w ten sposób zamienisz sygnął napięciowy na prądowy

    0
  • Pomocny post
    #6 05 Sty 2005 14:43
    tomeeh
    Poziom 23  

    Jeśli chodzi o generatory sinusa, to ze sprawdzonych przeze mnie mogę podrzucić XR2206, oraz MAX038 (mniejsze zniekształcenia).

    A propos wzmacniacza audio - wg mnie to nie najgorszy pomysł. Mianowicie możesz go wykorzystać jako stopień wyjściowy źródła prądowego pracującego w układzie Howlanda.
    Jeśli jednak z jakichś powodów rasowy wzmaniacz audio okaże się nieodpowiedni, zaciągnąłbym OPA 548 itp. (sprawdziłem jego działanie w układzie źródła prądowego Howlanda -> pracuje poprawnie).

    0
  • #7 06 Sty 2005 01:24
    Atik
    Poziom 10  

    Właśnie lutowałem te źródło prądowe Howlanda na tda2030a ale zabardzo nie chce to działać Myślałem też o zastosowaniu czegoś w rodzaju opa 544 lub jak Tomeeh pisałeś opa548 lecz cenowo tda był tańczy. Jeżeli jednak tomeeh Tobie to chodzi na opa548 to zaopatrze sie w ten scalak. I się nad tym pobawie.

    Jeżeli chodzi o gen sin to nie jest konieczny. Sygnał napięcia wejściowego o amplitudzie 1V i częstotliwości 50Hz będzie podawany z zewnątrz. Mimo to dzięki za pomysły.

    Mam jeszcze pytanko co do tych rezystorów użytych w układzie Howlanda - mioanowicie wyczytałem w książce, że duże znaczenie ma ich dokładność. Chodzi o to czy wystarczą np rezystorki o tolerancji 5% czy trzeba zastosować dokładniejsze zważywszy na to że mam regulować tym prądem co 1mA ??

    Mam jeszcze małą prośbe do Tomeeh'a. Czy mógłbyś mi podesłac jakiś kawałek projektu płytki drukowanej z tym układem Howlanda ?? Bo ciągle sie bawie z tym wszystkim na płytce uniwersalnej a to nie jest czasami zbyt wygodne.

    ps. dzięki serdeczne wszystkim za zainteresowanie tematem ... :)

    0
  • #8 06 Sty 2005 15:22
    tomeeh
    Poziom 23  

    Na prośbę Atika przesyłam schemat, oraz płytkę drukowaną uniwersalnego bipolarnego źrodła prądowego pracującego w układzie Howlanda. Dodam, że przedstawiony fragment był modułem wykonawczym układu stabilizacji tempratury lasera (chłodzenie modułem Pelitere'a).

    Jako download zamieszczam dla osób pragnących wykonać płytkę plik i_u converter.rar w skład którego wchodzą: i_u converter.brd (najlepiej bezpośrednio z tego pliku drukować wzór płytki) oraz i_u converter.sch. Płytkę wykonałem w programie Eagle 4.01.

    Zainteresowanym wyjaśniam, że układ IC2 jest montowany poza płytką, na radiatorze. Dzięki temu, w zależności od wymagań (maksymalny prąd wyjściowy) można dobrać sobie odpowiednią końcówkę, zamocować ją na radiatorze, a wyprowadzenia podłączyć przewodami (możliwie krótkimi, i o grubości adekwatnej do przewodzonego prądu) z płytką. Jak się można domyślic ze schematu, układ IC2 pracuje jako wtórnik, tak więc przy wyborze tego układu należy sprawdzić, czy będzie on pracował stabilnie ze wzmocnieniem równym +1. Ja osobiście jako IC2 używałem OPA 548. Zalecam przylutowanie kondensatorów 100nF na każdą gałąź zasilania na nożkach IC2.
    Układ IC1 do pojedynczy wzmacniacz operacyjny, wykorzystałem OPA 277, bo miałem go pod ręką, ale myślę, że jakis tańszy (wolniejszy) też się sprawdzi, gdyż pracuje on ze wzmocnieniem równym jedności przy częstotliwości 50Hz. Uczulam również na to, że wejście przedstawionego układu ma impedancję tylko 1kohm, tak więc w razie potrzeby należy dodać wtórnik.
    Jeśli chodzi o rezystory, to propnuję jednak zastosowanie 1% (w sumie tylko 4 sztuki, więc i tak koszty poniżej 1zł). W zależności od wymaganej transkonduktancji, należy dobrać wartość rezystora R3. W egzemplarzu modelowym był to rezystor 1 ohm, zatem napiecie wejściowe 1V powodowało zgodnie z prawem Ohma przepływ prądu 1A. Zwracam również uwagę na obliczenie maksymalnej mocy mogącej się wydzielić w rezystorze R3 przy doborze mocy tegoż rezystora.

    -> Atik. Trochę mnie zaskakuje, że obecny stopień wyjściowy nie działa. Sprawdź poprawność montażu. Możesz też wytrawić sobie moją płytkę i podłączyc do niej swój wzmacniacz audio (TDA). Jeśli to się nie sprawdzi, to rzeczywiście należy wykorzystać cos innego, choćby rzeczone OPA 548. Co do uruchamiania - proponuję bezpośrednio do wyjścia układu (CURRENT_OUT) podłączyć amperomierz (zakres min. 1A), jako R3 wstawić 1 ohm, a następnie podłączyć napięcie stałe z przedziału -1...1V na wejście i obserwować wskazania amperomierza.

    0
  • #9 07 Sty 2005 11:41
    Atik
    Poziom 10  

    Mam pytanko !!

    Mianowicie czy można by było ten ostatni schemat nieco ułatwić - zamiast IC1 (opa277) wpiąć od razu wzmacniacz mocy a układ IC2 zastąpić zworą ??

    No i jeszcze jedno - w jakim celu jest tam wpięty ten kondzior 100nF ??

    ps. dzięki Tomeeh za materiały... :)

    0
  • #10 07 Sty 2005 12:16
    tomeeh
    Poziom 23  

    Hmm, możliwe, że układ pracowałby również wtedy poprawnie, lecz zaznaczam, że nigdy takiej opcji nie wypróbowałem na własnej skórze (natomiast opcja z IC1 i IC2 była sprawdzona w praktyce). Ponadto koszt wzmacniacza operacyjnego o niewygórowanych parametrach nie jest duży, więc wg mnie warto zainwestować w sprawdzone rozwiązanie. Naturalnie wybór pozostawiam Tobie.

    Kondensator C2 ma za zadanie ograniczyć pasmo w przypadku niepożądanych oscylacji na wyższych częstotliwościach. Przy samym uruchamianiu nie polecam jego stosowania. Dopiero, gdy na oscyloskopie okaże się, że układ się wzbudza, warto go tam wsadzić. Z tego, co pamiętam, w moim układzie kondensator ten był zbędny (lecz na etapie projektowania trudno było przewidzieć taką możliwość, toteż zawsze warto sobie zostawic trochę miejsca na kondensatory).

    0
  • #11 10 Sty 2005 20:32
    Atik
    Poziom 10  

    Witam ponownie !!!

    Niestety nie zdążyłem jeszcze zmajstrować tego źródełka prądu według schematu przesłanego przez Ciebie Tomeeh ale mam nadzieje że sytuacja ta się zmieni w przeciągu paru najbliższych dni.

    Mam jezcze małe pytanko czy miałbyś jakiś pomysł (lub inni też ma sie rozumieć) na sterowanie cyfrowe tym napięciem wejściowyn co 1mV (aby uzyskac na wy źródła prąd co 1mA) ??

    Sam mam na to 2 pomysły.
    Jeden to zastosowanie na wejścu dzielnika napięcia wykorzystując jakiś potencjometr cyfrowy o 512 krokach i wtedy na samym żródle można by zmieniać zakres powiedzmy od 0 do 500mA i od 500mA do 1000mA.

    Drugim z kolei pomysłem jest opprostu zastosowanie licznika min 10 bitowego liczącego w prząd i w tył, który sterował by przetwornikiem cyfrowo analogowym (10 bit) dając na swoim wyjściu napięcia od 0 do 1000mV.

    Czy wogóle jakiś z tych pomysłów ma szanse realizacji, a jeżeli nie to prośiłbym o pomoc i jakieś podpowiedzi.

    Z góry dziękuję ....

    0
  • #12 02 Lut 2005 17:37
    tomeeh
    Poziom 23  

    tomeeh napisał:
    Hmm, możliwe, że układ pracowałby również wtedy poprawnie, lecz zaznaczam, że nigdy takiej opcji nie wypróbowałem na własnej skórze (natomiast opcja z IC1 i IC2 była sprawdzona w praktyce).


    Śpieszę tylko donieść, że właśnie wypróbowałem źródło howlanda na OPA548 bez dodatkowego wzmacniacza "sterujacego". Działa dobrze, tak więc można ten poprzedni wzmacniacz wyrzucić (naturalnie trzeba zmienić połączenia w OPA548).

    0
  • #13 07 Mar 2007 11:17
    Chotu
    Poziom 13  

    witam.
    zbudowalem zrodlo wg. schematu tomeeh'a ale w wariancie 2 gdy opa548 jest glownym wzmacniaczem operacyjnym zrodla zas opa277 pelni role wtornika na wejsciu (wzmocnienie = 1), oba uklady zasilane symetrycznie napieciem stalym 9V.

    opor R3 ma wartosc 10omow wiec na kazdy 1V napiecia wejsciowego otrzymamy 100mA pradu na wyjsciu z zrodla, taka teoria a w praktyce ma sie to tak - tak mi wyszlo i chyba cos nie jest ok.
    na schemacie sa 4 oporniki R3_1 do R3_4 w rzeczywistosci jest ich 4xszeregowo po 4xrownolegle i dodany jeszcze jeden rownolegle by skompensowac wartosc oprou doprowadzen - w ten sposob mam max. moc rozproszona na nich wynoszaca 2,4W (oporniki 1%).

    oporniki R1,R2,R4 oraz R6 sa o tolerancji 0,1% - takie akurat mialem (brat mial)

    obciazenie w postaci diody led na prad 700mA:
    - napiecie stale podane na wejscie zrodla - +5V - prad na wyjsciu 460mA (prawie 500mA)
    - napiecie stale podane na wejscie zrodla - -5V - prad na wyjsciu 360mA (dioda podlaczona odwrotnie wiec swieci i w tym momencie)

    W tym wypadku roznica rzedu 100mA raczej nie powinna wystepowac no nie ????

    Gdy za obciazenie mam opor 1oma to podajac napiecia na wejscie zrodla mam:
    +5V --> 510mA
    -5V --> 520mA
    -9V --> 600mA
    +9V --> 700mA

    2 ostatnie wyniki to ciut maja zbyt duza roznice no i wyjsciowy prad powinien byc wiekszy.

    Gdy daje na wejscie zrodla +5V to widze na mierniku dziwny pobor pradu z galezi +9V (18,3mA) zas z drugiej -> -9V (480-490mA) - czy to normalne ze mamy mimo zasilania wzmacniaczy symetrycznie taki niesymetryczny pobor pradu zasilania ????

    to narazie tyle jesli chodzi o zasilanie (sterowanie zrodlem) pradem stalym - akurat ono ma byc sterowane napieciem z generatora a wczorajsze pomiary wskazaly ze malejaca amplituda sygnalu - nie wazne czy to sinus, pila, prostokat nie powoduje spadku wartosci pradu na wyjsciu zrodla a teoretycznie powinno.

    pozdrawiam
    Piotr

    EDIT:
    pod POT narazie wstawiona jest zwora.

    0
  • #14 07 Mar 2007 21:21
    tomeeh
    Poziom 23  

    No cóż, zachowanie dość osobliwe.
    Zęby zjadłem na tych źródłach, narobiłem ich sporo i z takim przypadkiem się nie spotkałem.
    Spróbuj wymienić wszystkie 4 rezystory 1kΩ na 10kΩ (1% lub 0,1%). Możliwe, że 1kΩ to zbyt duże obciążenie dla OPA277.
    Ile wynoszą napięcia zasilania PO obciążeniu układu; powiedzmy 500mA?

    Cytat:

    Gdy daje na wejscie zrodla +5V to widze na mierniku dziwny pobor pradu z galezi +9V (18,3mA) zas z drugiej -> -9V (480-490mA) - czy to normalne ze mamy mimo zasilania wzmacniaczy symetrycznie taki niesymetryczny pobor pradu zasilania ????

    To jest akurat pożądane zachowanie. Z uwagi, że źródło Howlanda odwraca fazę (wystarczy popatrzeć na sposób podłączenia wzmacniacza) sterowanie stałym napięciem dodatnim +5V powoduje pobór prądu 500mA z ujemnej gałęzi. Jeśli będziesz sterował sygnałem przemiennym o składowej stałej zero, wówczas prądy pobierane z obu gałęzi będą jednakowe.

    0
  • #15 07 Mar 2007 22:31
    Chotu
    Poziom 13  

    Mialem wlasnie pomierzyc napiecia zasilania pod obciazeniem zrodla i okazalo sie ze mam wyniki jakies dziwne co do wartosci pradu na wyjsciu zrodla - odlaczyla sie dodatnia galaz zasilania i opa277 chyba sie uszkodzil - wymienilem na inna sztuke (na szczescie probki a nie kupione) i na szczescie dziala.

    Napiecia zasilania po obciazeniu:
    -dla +5V sterujacego --> +9,02V oraz -9,22V
    -dla -5V sterujacego --> +9,01 oraz -9,21V

    Co do

    Cytat:
    To jest akurat pożądane zachowanie. Z uwagi, że źródło Howlanda odwraca fazę (wystarczy popatrzeć na sposób podłączenia wzmacniacza) sterowanie stałym napięciem dodatnim +5V powoduje pobór prądu 500mA z ujemnej gałęzi. Jeśli będziesz sterował sygnałem przemiennym o składowej stałej zero, wówczas prądy pobierane z obu gałęzi będą jednakowe.

    to sobie przypomnialem dopiero teraz ze sterujac napieciem dodatnim - stabilizator od napiecia ujemnego sie nagrzewa (ma radiator) a w momencie gdy sterujemy ujemnym to stabilizator od dodatniego napiecia ulegal nagrzewaniu (takze ma radiator).

    Oczy juz mi wysiadaja wiec z rana poszukam tych 10k rezystorow i sprawdze jak na nich dziala zrodelko.

    Dziekuje za wskazowki.


    EDIT:

    WYNIKI PO WYMIANIE REZYSTOROW 1k na 10k
    a)obciazenie opornikiem
    NAPIECIE STERUJACE|PRAD NA WYJSCIU
    -------------------------------------------------
    +5V | 520mA
    -5V | 510mA
    +9V | 710mA
    -9V | 590mA

    b)obciazenie dioda led

    +5V | 470mA
    -5V | 360mA
    +9V | 480mA
    -9V | 360mA

    Napiecia zasilajace zrodlo (+-9V) po obciazeniu opornikiem wyjscia zrodla wynosza - dla +5V sterujacego --> -9,22 oraz 9,03V zas dla -5V sterujacego --> -9,21 oraz 9,02V.

    Po podlaczeniu generatora nadal jest sytuacja ze dioda swieci swiatlem ciaglym - ok - 100Hz mrygania nie zauwaze, ale swieci max. gdy mam skrecona amplitude do minimum zas jak odkrecam to spada prad na wyjsciu i dioda swieci slabiej - tylko dlaczego to jest odwrotnie niz powinno byc bo wydaje mi sie ze skoro jak podaje wyzsze napiecie stale to mam wyzszy prad to w przypadku pradu zmiennego z generatora powinno byc podobnie ?

    EDIT2:

    Moze zmienic wartosc napiecia zasilania zrodla z +-9V na +-12V lub +-15V ??

    0
  • #16 09 Mar 2007 21:36
    Chotu
    Poziom 13  

    a moze zmienic opa277 na opa2111 ?? nie wiem juz co by tu wykombinowac by w koncu zadzialalo poprawnie.

    0
  • #17 09 Mar 2007 22:35
    tomeeh
    Poziom 23  

    No tak. Jasne, że zmienić napięcie zasilania. Zawsze dbaj o to, by napięcie zasilania było przynajmniej o 3V większe od sygnału sterującego. Tak więc jeśli sterujesz +9V, musisz zasilić minimum +12V. Przy niższych napięciach zasilania układ nie będzie działał, gdyż żaden ze zastosowanych wzmacniaczy nie jest typu rail-to-rail. Możesz sprawdzić, co masz na wyjsciu OPA277. Jeśli napięcie na jej wyjściu będzie takie samo, jak na wejściu (na 99% tak będzie) to nie ma jej sensu wymieniać.

    0
  • #18 10 Mar 2007 16:20
    Chotu
    Poziom 13  

    Zmienilem napiecie zasilania zrodla z symetrycznego 9V na symetryczne 15 (dokladnie to +14,62V i -14,93V) i widac od razu roznice w dzialaniu:
    a)obciazenie opornikiem 1R:
    Nap.sterujace|Iwy
    +5V |520mA
    -5V |510mA
    +9V |940mA
    -9V |910mA
    Prawdopodobnie w tym momencie - dla nap. sterujacego +9V uszkodzil sie stabilizator dla napiecia -15V (-21,6V) lecz o dziwo nadal wszystko dzialalo ok

    b)jako obciazenie dioda
    +5V |520mA
    -5V |510mA

    W pon. jak dostane nowe stabilizatory to przetestuje z sterowaniem z generatora.

    0
  • #19 10 Mar 2007 19:27
    tomeeh
    Poziom 23  

    Chotu napisał:

    Prawdopodobnie w tym momencie - dla nap. sterujacego +9V uszkodzil sie stabilizator dla napiecia -15V (-21,6V) lecz o dziwo nadal wszystko dzialalo ok


    To akurat wcale nie jest dziwne. Pomijając kwestię OPA277 która przyjmuje na siebie chyba max +/- 18V; OPA549 możesz zasilać do +/- 30V, i układ musi działać poprawnie (niezlaeznie od tego, czy napięcie wynosi +/- 12V, 20V czy 30V). Jednak wiadomo, że nie daje się tak wysokiego napięcia zasilania, gdyż wówczas rosną straty na końcówce mocy (większe grzanie).

    Co do stabilizatorów - oblicz na nich straty mocy i dobierz odpowiedni radiator by już ich nie palić.

    0
  • #20 12 Mar 2007 17:40
    Chotu
    Poziom 13  

    Co do sterowania to mam chyba pecha poniewaz jakims cudem stabilizatory sie uszkodzily-nie byly gorace i maja spore radiatory. Podlaczylem zasilanie symetryczne +-12V wiec nie ma calkowitej liniowosci lecz nadal jest tak ze majac skrecona amplitude na minimum - jest max. prad zas gdy ustawie amplitude na max. to mam prad wyjsciowy = 0.

    Czy mozliwe jest by sygnal z generatora mial w sobie jakas skladowa stala i dlatego tak sie zachowuje ???? mam niestety w domu oscyloskop w ktorym nie ma pomiaru skladowej stalej - oscyloskop MINI4.


    Poniezej wykres z wynikow pomiaru (dla napiecia stałego) przy zasilaniu +-15V nim sie stabilizatory nie uszkodzily - wyglada na to ze zrodlo dziala dobrze.

    0
  • #21 13 Mar 2007 23:10
    tomeeh
    Poziom 23  

    Ciężko zrozumieć. Co to znaczy, że max amplituda daje prąd 0 i vice versa? Raz piszesz że źródło działa dobrze, zamieszczasz wykres, teraz piszesz o amplitudach - tobie chodzi o źródło prądowe, czy o jakiś generator? Źródło jak widać na wykresie działa dobrze, widzę pewne nieliniowości w zakresie małych prądów, lecz jestem pewien, że to błąd pomiarowy. Zrób przede wszystkim porządnie ten zasilacz, bo jeśli stabilizatory ci się palą, to jest coś nie tak i nie ma co dalej iść.

    0
  • #22 14 Mar 2007 00:48
    Chotu
    Poziom 13  

    spokojnie - moze wszystko jest ok tylko ja cos zle rozumiem.
    zrodlo dziala tak jak na wykresie dla pradu stalego i to jest ok.
    teraz gdy jako sygnal sterujacy zrodlem dam generator to czy wielkosc pradu na wyjsciu powinna zalezec liniowo od Vpp badz amplitydy sygnalu z generatora ???? w tym wypadku z zasilacza powinny byc pobierane znaczne wartosci pradu z obu stabilizatorow a ja zauwazam ze nawet jak jest podlaczony generator to czuc dlonia ktory radiator sie nagrzewa - akurat zawsze od napiecia ujemnego. bycmoze cos mam nie tak z generatorem - jak go testowalem to wygladalo ze jest wszystko ok.

    co do tej max. amplitudy to chodzilo o max. amplitude z generatora sygnalowego ktory niejako ma sterowac zrodlem.

    0