Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Tagan model: TG580-U15 naprawa...

LightOfWinter 01 Kwi 2012 10:51 3865 11
  • #1 01 Kwi 2012 10:51
    LightOfWinter
    Poziom 29  

    Tagan model: TG580-U15 naprawa...
    Witam

    Jakiś czas temu zacząłem naprawę zasilacza marki Tagan o mocy 580W.
    Zasilacz trafił do mnie "bez oznak życia" i nie znam historii jego uszkodzenia.

    Co zostało zrobione:
    - wymieniony spuchnięty kondensator elektrolityczny w układzie PFC.
    - wymienione spuchnięte kondensatory elektrolityczne wyjściowe na poszczególnych liniach.
    - wymieniony termistor na wejściu, po stronie wysokiego napięcia, który rozleciał się na kawałki.
    - prawdopodobnie wymieniałem też któryś tranzystor.
    Potem zasilacz z baku czasu leżał na półce, a teraz postanowiłem dokończyć rozpoczętą naprawę.
    W tej chwili zasilacz uruchamiany przez żarówkę 200W i obciążony żarówką 20W/12V wstaje. Niestety pod czas startu żarówka 200W świeci przez ok 2-3s.

    Sądzę, że nie jest to poprawny objaw, a poprzednie wszystkie inne sprawne zasilacze nie powodowały u mnie zaświecenia żarówki. Zastanawiam się czy układ scalony PFC nie ucierpiał podczas tej awarii, a w szczególności sterownik. Niestety nie mam "w szufladzie" drugiego na podmianę.

    Proszę o sugestie na co powinienem jeszcze zwrócić uwagę i co jeszcze pomierzyć?
    Poprawiłem TONI_2003.

    0 11
  • #2 01 Kwi 2012 12:43
    TONI_2003
    Moderator

    LightOfWinter napisał:
    W tej chwili zasilacz uruchamiany przez żarówkę 200W i obciążony żarówką 20W/12V wstaje. Niestety pod czas startu żarówka 200W świeci przez ok 2-3s.

    Ile razy będzie koniecznie napisanie jeszcze raz tak prostej zasady, że gdy obciążasz zasilacz na wyjściach napięć to nie robisz to przy podłączonej żarówce po stronie pierwotnej zasilacza....
    Potem doszukujesz się jakiś teorii spiskowych, a tak naprawdę nie podajesz zmierzonych napięć przed i po odpaleniu zasilacza. Pomijając już sam fakt braku potrzeby zakładania tego tematu!

    0
  • #3 01 Kwi 2012 13:30
    LightOfWinter
    Poziom 29  

    TONI_2003 napisał:
    LightOfWinter napisał:
    W tej chwili zasilacz uruchamiany przez żarówkę 200W i obciążony żarówką 20W/12V wstaje. Niestety pod czas startu żarówka 200W świeci przez ok 2-3s.

    Ile razy będzie koniecznie napisanie jeszcze raz tak prostej zasady, że gdy obciążasz zasilacz na wyjściach napięć to nie robisz to przy podłączonej żarówce po stronie pierwotnej zasilacza....
    Potem doszukujesz się jakiś teorii spiskowych, a tak naprawdę nie podajesz zmierzonych napięć przed i po odpaleniu zasilacza. Pomijając już sam fakt braku potrzeby zakładania tego tematu!


    Dzięki TONI_2003,

    Oczywiście masz rację co do nie obciążania zasilacza przy podłączonej żarówce na stronie pierwotnej. Moja nie uwaga.

    Zmobilizowałeś mnie do zrobienie pomiarów bez obciążenia.
    Wyniki bez obciążenia:
    +5V -> 5.307V
    +12V -> 11,99V
    3.3V -> 3,449V
    -12V -> -11.06V
    -5V -> -5.109V
    5V SB-> 5.162V

    "Przy okazji" zrobiłem pomiar napięć na kondensatorach wejściowych za układem PFC. Są to dwa kondensatory 100uF@200V.
    Martwi mnie że mają nie-równomierny rozkład napięcia. Uważam że powinny mieć takie samo napięcie.

    Na jednym jest ok 130V i rośnie.
    Na drugim stabilne 250V czyli powyżej napięcia nominalnego.
    Rozumiem że elektrolity wytrzymują "trochę większe" napięcie, ale nie podczas pracy ciągłej.

    0
  • #4 01 Kwi 2012 16:48
    TONI_2003
    Moderator

    Chyba sam rozumiesz, że o ile Masz sprawny miernik (baterię) to pomiar na nich musi być mniej więcej jednakowy, a skoro twierdzisz iż tak nie jest to należy je bezwzględnie wymienić na nowe.

    Jednocześnie o ile te, które wcześniej wymieniałeś (nie wiem czy wszystkie) po stronie wtórnej zasilacza oraz w przetwornicy stand-by (również) to można by było zasilacz postawić do testów obciążeniowych, a po ich prawidłowym przebiegu zasilacz można użytkować...

    Oczywiście to tak w skrócie, ale reszta opisane była wielokrotnie przy naprawach zasilaczy firmy Tagan. :D

    0
  • #5 01 Kwi 2012 19:01
    darpajdp
    Poziom 22  

    W tych zasilaczach dużo usterek jest spowodowane utratą pojemności przez "duże" kondensatory elektrolityczne, oznaką tego jest spuchnięty kondensator (w zależności od modelu jest to 10, 22 lub 33µF/400V) w APFC.

    Kolejną przyczyną awarii to usterki przetwornicy stand-by spowodowane wyschnięciem kondensatora elektrolitycznego 47µF/35V przy układzie TL3842 co powoduje uszkodzenia kondensatorów elektrolitycznych po stronie wtórnej.
    Wymień oba "duże" kondensatory (zwróć uwagę na rozmiar bo ani szersze ani wyższe nie wejdą, ja wkładałem 820µF zamiast 1000µF) i tego 47µF/35V najlepiej na LOW ESR.

    0
  • #6 01 Kwi 2012 21:24
    LightOfWinter
    Poziom 29  

    Dziękuję TONI_2003 i darpajdp.

    Kondensatory elektrolityczne 1000µF/200V wymieniłem oba na dwa kondensatory elektrolityczne 470µF/200V. Takie miałem w zapasie, a sadze że pomijając trochę większe tętnienia napięcia, jest to bez znaczenia. Spotkałem się wiele razy w zasilaczach 500W właśnie z para 470µF/200V.

    Po wymianie kondensatorów elektrolitycznych napięcie rozkłada się równomiernie, a wyschnięty kondensator miał tylko około 0.5µF.

    Kondensator elektrolityczny przy układzie scalonym TL3842 sprawdziłem, zmierzyłem, a nawet podmieniłem. Jednak był sprawny i jego wymiana nie wpływa w żaden sposób na prace zasilacza.

    Natomiast pojawiła się nowa "ciekawostka" i teraz żarówka 200W włączona w szereg z zasilaczem mruga ok 1Hz. Mruganie po "chwili" nie ustaje choć czekałem ok minuty.

    Dla mnie podejrzany jest układ PFC bo któż inny mógł by robić zwarcie na wejściu.
    Sądzę że na początek wyjmę tranzystory kluczujące z PFC i zobaczę jak zasilacz się zachowa. Zastanawiam się czy warto zamawiać ten układ sterownika PFC - L6562N w TME jest dostępny?
    Poprawiłem TONI_2003.

    0
  • #7 01 Kwi 2012 22:37
    darpajdp
    Poziom 22  

    Zostaw to APFC w spokoju, taka jest zasada jego działania. Dołącz do tej żarówki 200W jeszcze 100W równolegle a przestanie mrugać. Jakby klucz w APFC zrobił zwarcie to na pewno było by ono dalej. Jeśli nie było uszkodzonego klucza w przetwornicy głównej to warystory w niesprzyjających warunkach mogły zrobić zwarcie. Natomiast te 2x470µF to troszkę mało jak na zasilacz 580W, będzie bardziej wrażliwszy na chwilowe przysiady napięcia.

    0
  • #8 02 Kwi 2012 08:05
    LightOfWinter
    Poziom 29  

    darpajdp napisał:
    Zostaw to APFC w spokoju, taka jest zasada jego działania. Dołącz do tej żarówki 200W jeszcze 100W równolegle a przestanie mrugać. Jakby klucz w APFC zrobił zwarcie to na pewno było by ono dalej.

    Czytałem takie opinie że to PFC "tak ma". Uczciwie przyznaję że nie jestem przekonany. Przecież to zwykła przetwornica.

    Poprawiłem tez mój błąd w opisie mruganie żarówki.
    Częstotliwość oszacowana ok 1 Hz. Raz na sekundę do Raz na 2 sekundy.
    Żarówka mocno się rozjaśnia, potem gaśnie.

    Chyba że nie ma odpowiedniego zgrania czasowego między blokiem przetwornicy głównej i PFC. Wtedy rzeczywiście może powodować duże szpile prądowe.

    Oczywiście dołączenie drugiej żarówki równolegle wypróbuję. Nie ma problemu.
    Tym niemniej sądzę że 200W jest wystarczająca dla nieobciążonej przetwornicy.
    Po za tym to nie najlepszy układ PFC. Skoro generuje takie szpile do sieci.
    Wszystkie PFC które do tej pory naprawiałem zachowywały się normalnie. Bez takich pików poboru prądu.



    darpajdp napisał:
    Natomiast te 2x470µF to troszkę mało jak na zasilacz 580W, będzie bardziej wrażliwszy na chwilowe przysiady napięcia.

    A od czego jest wspomniane aktywne PFC ?
    Przecież ono ponosi napięcie.
    Co najwyżej będzie miał mniejszą rezerwę energii do kompensacji zaników napięcia sieciowego. I "trochę" większe tętnienia.

    0
  • #9 02 Kwi 2012 09:11
    darpajdp
    Poziom 22  

    LightOfWinter napisał:
    Chyba że nie ma odpowiedniego zgrania czasowego między blokiem przetwornicy głównej i PFC. Wtedy rzeczywiście może powodować duże szpile prądowe.
    No właśnie nie ma zgrania bo jest na osobnej płytce z osobnym kontrolerem. Naprawiałem kilka zasilaczy opartych na tej konstrukcji (produkcja Topower) i we wszystkich był problem z mrugającą żarówką, nawet przy żarówce 250W.
    Ja podaje napięcie bez uruchamiania przetwornicy głównej, żarówka naście razy mrugnie i zgaśnie. Następnie uruchamiam przetwornicę główną (bez obciążenia), żarówka znów naście razy mignie i zgaśnie. Obciążam żarówką 21W/12V linię +5V i zasilacz pracuje tak parę godzin. Jak nic się nie dzieje podłączam zasilanie bezpośrednio i testuje pod obciążeniem.

    0
  • #10 03 Kwi 2012 22:01
    LightOfWinter
    Poziom 29  

    Witam
    Zaobserwowałem że:

    1.) Jeśli jest zwarte PS_ON do masy, popularną zworką żarówka 200W włączona w szereg mruga co ok 1s.

    Natomiast jeśli nie ma żadnych zworek, żarówka 200W świeci światłem ciągły, jasno.

    2.) Dodatkowej żarówki, nie dokupiłem, wyleciało mi z głowy, więc nie mogłem sprawdzić jak się zachowa przy wpięciu w szereg połączanych równolegle 200W i 100W.

    3.) Na próbę usunąłem 2 tranzystory z PFC, problem z świeceniem żarówki ustał.

    Poszukam tranzystorów do PFC na podmianę, jeśli nie pomoże to spróbuję zamówić lub kupić nowy regulator PFC.

    darpajdp napisał:
    Obciążam żarówką 21W/12V linię +5V i zasilacz pracuje tak parę godzin. Jak nic się nie dzieje podłączał zasilanie bezpośrednio i testuje pod obciążeniem.

    Pytanie, czego używasz jako obciążenie - starych komponentów komputerowych, czy masz może sztuczne obciążenie zrobione na rezystorach? Ja przymierzałem się do zrobienia takiego na rezystorach o przełączanej mocy obciążenia 100W i 200W.

    0
  • #11 03 Kwi 2012 23:14
    darpajdp
    Poziom 22  

    LightOfWinter napisał:
    Pytanie, czego używasz jako obciążenie - starych komponentów komputerowych,
    czy masz może sztuczne obciążenie zrobione na rezystorach?
    Mam zrobione źródła prądowe (około 6A) na tranzystorach KD502 (2N3055). Prosty układ, kolektor tranzystora do + zasilania, od kolektora rezystor 22Ω/0,5W dla 5V (68Ω/2W dla 12V) do bazy i od bazy dwie diody krzemowe 1A (np. 1N4002) połączone szeregowo w stronę przewodzenia do GND. Emiter przez dwa rezystory 0,22R/5W połączone równolegle do GND. Mam zamiar zrobić więcej takich układów ale nie mam odpowiednich radiatorów. Jak potrzebuje większego prądu używam dodatkowo starych żarówek samochodowych 40/45W/12V z połączonymi równolegle włóknami ( 7A na 12V i około 4A na 5V)

    0
  • #12 19 Kwi 2012 08:05
    LightOfWinter
    Poziom 29  

    Ja sztuczne obciążenie będę wykonywał na rezystorach mocy. Znalazłem schemat rekomendowany na rosyjskim forum o naprawie zasilaczy.

    Zasilacz naprawiłem, a po wymianie układu sterownika PFC, pracuje bez problemu i napięcia są w porządku. Teraz tylko testy obciążeniowe i pozbywam się zasilacza.

    0