Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[WC1602A0] i jeszcze raz kontrast..

ulumulu 12 Kwi 2012 22:20 1171 1
  • #1 12 Kwi 2012 22:20
    ulumulu
    Poziom 8  

    Witam.
    Wstyd trochę pisać(już tyle razy to było wałkowane), ale po przeczytaniu kilku tematów, książki i datesheet nie mogę ustawić dobrego kontrastu na wyświetlaczy lcd 16*2.
    Kupiłem wyświetlacz WC1602A0-SFYLYNC06, podłączyłem wszystko zgodnie z schematem przedstawionym na stronie:

    http://radzio.dxp.pl/hd44780/hd44780_avr_4-bit_norw_c.htm

    z potencjometrem 10k. Program napisałem i wszystko jest ok. Na ekranie pojawia się napis tylko widać go pod odpowiednim kontem. Przy ustawieniu potencjometru w stronę GND obraz jest bardzo rozjaśniony, a zwiększając napięcie na V0 litery znikają. Czy możliwe jest że potrzeba wartość ujemną na kontraście? W książce "Język C dla mikrokontrolerów AVR" T. Francuz jest mała informacja ze dla modułów o rozszerzonym zakresie temp. jest w przedziale 0-7V. Po przeczytaniu datesheet:

    http://www.image.micros.com.pl/_dane_techniczne_auto/o%20lcs162-1zs.pdf

    wygląda że wszystko jest dobrze zrobione Power suply (V0) 0-4.9V. Znalazłem też podobny temat:

    https://www.elektroda.pl/rtvforum/viewtopic.ph...ghlight=&sid=81d384de3d023fd8f4b0c2133a404bb0

    ale nie mam do sprawdzenia drugiego ekranu. Jutro pewnie kupie.
    Co można z tym zrobić? Po prostu ten typ tak ma? Czy faktycznie zastosować lekkie napięcie ujemne..

    0 1
  • #2 12 Kwi 2012 22:45
    mirekk36
    Poziom 42  

    Obejrzyj sobie może i poczytaj to Link - to może się coś rozjaśni.

    0