Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Invalid boot.ini brak rozruchu

SWR13 15 Kwi 2012 15:57 2927 16
  • #1 15 Kwi 2012 15:57
    SWR13
    Poziom 9  

    Witam

    Na jednej z partycji, na której mam win xp eset wykrył EXPLORER.EXE i jeszcze jednego wirusa nazwy nie pamiętam. Po restarcie po wpisaniu hasła do konta systemu bardzo długo sie wczytywał a po wczytaniu pulpit był pusty więc uruchomiłem menedzera w procesach byl włączony własciwy explorer.exe. Po próbie naprawy systemu z poziomu instalacji win xp nie włacza sie w ogóle w miejscu gdy zwykle wybiera się jaka wersja win ma byc odpalona pisz invalid boot.ini rozruch z c:windows i po chwili restart. Próbowałem juz naprawiac boot.ini wpisując w konsoli /rebuild ale to nic nie daje mimo ze boot.ini sie zmienia i jest takie jak wpisałem w konsoli, wiem to bo sprawdzałem na linux live cd. Pliki startowe z win7 tez wydają sie być w porządku. Dodam jeszcze ze mam 3 windowsy
    c:win7
    d:win xp x64
    e:win xp pro
    Za wszelką pomoc z góry dziękuje.

    0 16
  • #2 15 Kwi 2012 18:07
    Pwk
    Poziom 22  

    Windows xp nie naprawi rozruchu z Windowsem 7 na dysku.

    Spróbuj naprawić rozruch z płyty Windows 7

    0
  • #3 15 Kwi 2012 18:13
    SWR13
    Poziom 9  

    Każdy win mam na innej partycji. Jak daje napraw z płyty win7 to wyskakuje mi że wersja zainstalowana różni sie od tej którą mam na płycie a była na 101% instalowana własnie z niej,

    0
  • #4 15 Kwi 2012 18:34
    Pwk
    Poziom 22  

    Spróbuj jakiegoś zewnętrznego loadera np. Acronis OS Selector
    Ewidentnie szkód narobił wirus, co poza bootblock'iem zepsuł i czy da się jeszcze te systemy reanimować nie wiadomo

    0
  • #5 15 Kwi 2012 19:39
    WojtasJD
    VIP Zasłużony dla elektroda

    Nośnik instalacyjny do napędu, z niego wystartuj i uruchom wiersz polecenia:

    diskpart [enter]
    DISKPART> list vol [enter]

    z powyższego polecenia dowiesz się m.in. jaką literkę dostał napęd DVD/CD

    DISKPART> exit
    G:\boot\bootsect /nt60 ALL [enter]

    ( zakładając, że napęd DVD/CD dostał G: )

    0
  • #6 15 Kwi 2012 22:30
    SWR13
    Poziom 9  

    jak wpisuje diskpart wyswietla mi sie okienko takie jak gdy wybieramy na jakim dysku ma być zainstalowany win, pisze że klawisz "d" formatuje "c" tworzy nową partycje, "esc" wychodzimy do wiersza poleceń.
    Wpisując diskpart >list vol wtedy nic sie nie dzieje tylko przechodzi do nowej linijki i zamiast napisu d:\> jest c:\> wpisując x:\boot\bootsect /nt60 ALL za x dałem wszystkie możliwe litery i za każdym razem wyskakuje że nie ma takiego polecenia. Wiersz poleceń uruchamiałem oczywiście z płyty win xp.

    0
  • #7 15 Kwi 2012 22:35
    WojtasJD
    VIP Zasłużony dla elektroda

    Nie napisałem, że chodzi o nośnik instalacyjny Windows 7 a NIE XP (myślałem, że to oczywiste)

    0
  • #8 15 Kwi 2012 22:41
    SWR13
    Poziom 9  

    Ale jak mam właczyć konsole skoro jak daje napraw to mi pisze że wersja z cd/dvd rózni sie od tej zainstalowanej (pisałem to wcześniej) a na 101% instalowałem z tej właśnie płyty. Chyba że konsole w win7 włącza sie w jakiś inny sposób nie wiem bo nigdy tego nie robiłem.

    0
  • #10 15 Kwi 2012 23:09
    SWR13
    Poziom 9  

    Jakims cudem udalo mi sie wejsc do tej konsoli odzyskiwania i jest win7 i xp x64 ale nie ma przy wyborze xp pro na ktorym najbardziej mi zalezalo i na ktorym byl wirus i teraz moje ostatnie pytanie czy dac sobie spokoj z tym win i nic nie kombinowac, probowac dodawac do boot.ini tego win albo sprobowac jeszcze raz naprawic z konsoli czy zostawic to juz w spokoju?

    0
  • #11 15 Kwi 2012 23:19
    WojtasJD
    VIP Zasłużony dla elektroda

    Jak już masz działający Windows 7 to spod niego zrób skanowanie partycji na obecność wirusów itd.

    Napisz jak było przed awarią - czy w menu Windows Boot Managera (Windows 7) miałeś trzy Windowsy do wyboru czy jakoś inaczej.

    W polu wyszukiwania menu start wpisz diskmgmt.msc [enter] i załącz widok okna zarządzania dyskami ( wg: https://www.elektroda.pl/rtvforum/topic2053101.html )

    0
  • #12 15 Kwi 2012 23:39
    SWR13
    Poziom 9  

    Mialem 2win do wyboru 7 i xp ale jak dalem xp to wtedy przechodzilo do nastepnego okna i mozna bylo wybrac xp pro i x64. Sory za brak pl znakow ale pisze z x64 eng.
    Juz zmieniam na 7 i dodam to o co prosiles.

    Dodano po 8 [minuty]:

    Invalid boot.ini brak rozruchu

    0
  • #13 16 Kwi 2012 00:10
    WojtasJD
    VIP Zasłużony dla elektroda

    Ok, jak chcesz aby było jak wcześniej trzeba dodać do C:\boot.ini wpis uruchamiający WinXP albo/i dodać wpis do menu bootmanagera Windows 7.
    Wrzuć zawartość \boot.ini

    0
  • #14 16 Kwi 2012 16:29
    SWR13
    Poziom 9  

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /FASTDETECT

    0
  • #15 16 Kwi 2012 19:11
    WojtasJD
    VIP Zasłużony dla elektroda

    Dodaj na końcu linijkę (zakładając, że folder systemowy to \Windows):
    multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP x64 Edition" /FASTDETECT

    i powinno być jak dawniej.
    Można też dodać do menu BCD + skopiowanie paru plików i edycja \boot.ini

    0
  • #16 17 Kwi 2012 16:53
    SWR13
    Poziom 9  

    Teraz nie przeskakuje do następnego okna tylko włącza się ekran ładowania Windowsa znaczy powinien bo zamiast logo windowsa jest czarny ekran i nic sie nie dzieje.

    0
  • #17 17 Kwi 2012 17:19
    Pwk
    Poziom 22  

    Spróbuj tak:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /FASTDETECT
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP x64 Edition" /FASTDETECT

    0