Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Excel] Wyświetlanie wartości wybranego filtru

Majek89 22 Kwi 2012 12:46 1830 4
  • #1 22 Kwi 2012 12:46
    Majek89
    Poziom 9  

    Witam!
    Tworzę zestawienie usterek maszyn w Excelu 2010 i mam następujący problem. Na kolumnę C (Nr maszyny) utworzyłem sobie standardowy filtr i wszystko jest OK, z tym że chciałbym, żeby wybrany przeze mnie numer maszyny wyświetlał się również w komórce poniżej (B14). I tu pojawia się problem. Czy można w jakiś sposób odwołać się do wybranej wartości filtru bez wprowadzania jakichś skomplikowanych makr?
    Na początku próbowałem odwoływać się bezpośrednio do adresu danej komórki, ale w związku z tym, że filtr ukrywa po prostu wybrane wiersze to nie mam pojęcia jak mógłbym to zrealizować.
    Będę wdzięczny za wszelkie sugestie. Dołączam arkusz o którym mówię. Pozdrawiam serdecznie :)

    0 4
  • Pomocny post
    #2 22 Kwi 2012 12:57
    adamas_nt
    Moderator Programowanie

    Np

    Code:
    =JEŻELI(SUMY.CZĘŚCIOWE(2;C3:C11)>1;"";(SUMY.CZĘŚCIOWE(9;C3:C11)))
    W tłumaczeniu: wyświetli Nr maszyny, jeśli odfiltrujesz wszystkie poza jedną.

    0
  • #3 22 Kwi 2012 13:08
    Majek89
    Poziom 9  

    Wielkie dzięki! Nie działa to do końca tak, jakbym chciał, bo niektóre maszyny mają więcej niż jeden wpis, ale dalej już sobie poradzę ;) Brakowało mi właśnie funkcji, która ignoruje ukryte w wyniki filtrowania wiersze :) Pozdrawiam.

    0
  • Pomocny post
    #4 22 Kwi 2012 13:15
    adamas_nt
    Moderator Programowanie

    Nie przyuważyłem. Można zsumować i jeśli suma/ile liczb=max...

    Code:
    =JEŻELI(SUMY.CZĘŚCIOWE(9;C3:C11)/SUMY.CZĘŚCIOWE(4;C3:C11)=SUMY.CZĘŚCIOWE(2;C3:C11);SUMY.CZĘŚCIOWE(4;C3:C11);"")

    0
  • #5 22 Kwi 2012 13:27
    Majek89
    Poziom 9  

    Myślałem o porównywaniu wartości max i min, ale ten sposób też ok ;) Pozdrawiam.

    0