Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Atmega8 ustawienia w bascom

delgo 01 Maj 2012 00:02 2483 3
  • #1 01 Maj 2012 00:02
    delgo
    Poziom 13  

    Witam, mam atmege8 zaprogramowaną działa lcd widać zmiany z przełączników i enkodera ale brak sterowania scalakiem syntezy. kwarc to 7,2MHz przy syntezie a do procka podłączenie z xtal1. Jakie prawidłowe fuse bit-y ,mam ustawione - " zewnętrzny kwarc z kondensatorami 6-8MHz " i miałem " częstotliwość z zewnętrznego " i nic. Z Bascom-avr korzystam.

    0 3
  • #2 01 Maj 2012 08:27
    piotrva
    Moderator Mikrokontrolery

    Cytat:
    Mam atmegę8, podłączony LCD i drukarkę termiczną - lcd działa a drukarka nie - pomóżcie

    Co z tego typu wiadomości Kolega wie o moim wyimaginowanym problemie? Raczej niewiele i tyle samo wiemy my o Twoim problemie, więc jeśli nie chcesz żeby ktoś Ci pomógł to przeczytaj artykuł i popraw swoje pytanie:
    http://mikrokontrolery.blogspot.com/2011/04/fora-dyskusyjne-sa-bardzo-pomocne.html

    0
  • #3 01 Maj 2012 11:31
    delgo
    Poziom 13  

    Wykonałem syntezę do radia ze strony http://sq1ftb.prothost.pl/articles.php?article_id=8..

    Atmega8 ustawienia w bascom

    Generator i separator działa, scalak syntezy LM7001 pracuje z kwarcem 7,2MHz, po wyjęciu jego Atmega prawidłowo "milczy" tzn. brak wtedy wyświetlania częstotliwości zmian na enkoderze itd. Ta część programu działa ale nie steruje LM7001 synteza nie "łapie". Sprawdzałem Atmega po podłączeniu zewnętrznych kwarców (2,4,8 MHZ +kondensatory )zachowuje się poprawnie oczywiście nie steruje LM i aby prawidłowo zadziałała synteza musi pracować z kwarcem 7,2 MHz. W programie jest wpisana f. kwarca ale jak ustawić fuse bit Podczas programowania


    Kod: basic4gl
    Zaloguj się, aby zobaczyć kod

    1