Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Linux - trudnosci z instalacja i uzytkowaniem

08 Maj 2012 09:58 7176 53
  • Poziom 39  
    Witam,
    Celowo w tytule nie podalem dokladnie o jak dystrybucje mi chodzi poniewaz probowalem kilku, debiana, fedore, slax, ubuntu, dream i kilka pomniejszych.
    Problem polega w tym ze zadnego z nich nie udalo mi sie zainstalowac na tyle sprawnie aby dalo sie go uzywac.
    Jedynie slax dziala w miare akceptowalnie ale nie dokonca radze sobie z modulami - ale to osobny temat do dyskusji.
    Na komputerach znam sie stosunkowo nie najgorzej. Linuxy znam slabo.
    Testy robilem na kilku komputerach:
    Laptop dell inspiron 8500, P4 2.2
    Stacjonarne: P4 2.6GHz plyta intela zintegrowana - poprzednio XP dziala bez zastrzezen,
    2xAMD MP+2.6GHz plyta serwerowa AMD - poprzednio jakis debian dzialal idealnie, teraz XP bez problemu.
    AMD sempron 3500 na plytce (nie pamietam symbolu) MSI, zintegrowane prawie wszystko - XP bez problemu.
    AMD 5800(2x2.9G) MSI plyta z serii platinum, XP, Win7 zadnych problemow.
    Kozystalem glownie z wersji Live - test czy to sie wogole uruchomi, no i wiekszosc systemow pokazuje bledy, uruchamia sie w jakichs dziwnych trybach graficznych mimo wymuszania trybu standardowego. Jezeli sie uruchomi to dziala jak XP na PII-333 albo gorzej. Pamiec w komputerach to 512MB laptop, pozostale 1GB a dwurdzeniowe i dwuprocesorowe 2GB i 4GB.

    Prosze o informacje jak zainstalowc linuxa, jezeli nadal jeszcze chce mi sie w to bawic, co tydzien do tego wracam i co tydzien jest gorzej.
    Raczej nie prosze o informacje typu - a moze ta wersja czy ta dystrybucja ... .
    Obrazy plyt sprawdzone, nagrywane powtornie nowe itp. Komponenty sprawdzone, wymieniane itp.
    Debian zainstalowal sie stosunkowo sprawnie ale jego szybkosc to pomylka (na AMD 2x2.6 MP+, 2GB RAM)
    Ubuntu - nigdy nie zainstalowal sie poprawnie (wersje od 8 do nojnowszej) czesto zglasza blad napedu z ktorego sie botuje ze nie moze go odczytac mimo ze wlasnie to robi. Instalacja dochodzi do konca po 2-3 godzinach, szybkosc to porazka.
    W wiekszosci przypadkow po zciagnieciu obrazu plyty (glownie DVD sugerowane jako zawierajace prawie wszystkie sterowniki itp.) instalacja z plyty na standardowych ustawieniach. Ponowne proby z obrazem CD.
    Gdzie popelniam bledy, chyba jeszcze chce potestowac linuxa ale nie mam mozliwosci i powoli cierpliwosci.
    Pozdrawiam
  • Użytkownik usunął konto  
  • Poziom 39  
    Dziekuje bardzo za uwagi,
    W moim przypadku w wiekszosci sytuacji nawet nie ma trybu tekstowego, czasami jest tryb tekstowy i pokazuje co i jak laduje ale jak sie przelaczy do trybu graficznego to trace kontrole i nic nie widac - pewnie niekompatybilnosc karty - ale nawet wymuszenie trybu vga przy starcie nic nie daje "odpala" w maksymalnej rozpoznanej rozdzielczosci i nie dziala.
    W sumie wymagam aby system po instalacji odpalil i pozwolil na dalsza konfiguracje recznie jak to ma w zwyczaju "ulubiony system". Niestety nic takiego poza slaxem nie uzyskalem. Komputery mialy rozne karty graficzne, zintegrowane intela/nvidia i AGP Ati oraz matroxy (takie byly pod reka).
    Dlaczego w przypadku braku sterownika nie uruchami sie w trybie domyslnym i pozwala dalej na aktualizacje.
    Komputery nigdy nie byly podlaczone do internetu na czas instalacji, dopoki system nie zadzialal poprawnie - a wiec nigdy.
    Narazie mnie to silnie zniecheca, osobiscie nie moge potwiedzic zalet kozystania z linuxa jako ze do tej pory nie uruchomilem zadnego poprawnie.
    Blad napedu DVD - Ubuntu, tylko on zglaszal problemy, obrazy byly nagrywane wiele razy i pobierane powtornie plyta RW i ta sama plyta byla uzywana np. do debiana ktory odpali odrazu tyle ze dziala zle i wolno i slaxa ktory dziala.
    Moze za jakis czas powalcze z innymi dystrybucjami ale poczatki zniechecaja silnie.
    Nie mniej dziekuje za zainteresowanie.
    Pozdrawiam
  • Poziom 28  
    Początki zawsze są trudne. Najnowsze distra najlepiej działają z nowszymi grafikami nvidia *gf 6xxx) i ati sria HD, na zintegrowanym intelu g31 już nie startuje tryb graficzny i pozamiatane. Na początek proponuje debiana 6, mint albo sabayon8. Druga sprawa to laptopy, tutaj zazwyczaj przy starcie trzeba podać jakieś noapic nolapic vga=791 itp, dla początkującego dramat :]
    Najlepiej jak byś uruchamiał linuxa z pendrajwa, wygodne i odpada problem z nagrywaniem płyt. Bez problemu działa tak archlinux, slitaz, pmagic. W twoim przypadku możesz mieć słabą nagrywarkę dvd albo słaby napęd dlatego tak się ślimaczy przy wczytywaniu. A z płytami RW jest najgorzej.
    Ciężko doradzić komuś jakie distro wybrać, debian/ubuntu jest idiotoodporny i ma sporo użytkowników więc sporo rozwiązań znajdziesz na forach. Sabayon8 moim zdaniem jest przyjaźniejszy od ubuntu i na wielu laptopach działa wszystko łącznie z kamerką na starcie, ale ja używam linuxa od lat. Co do trybu graficznego to z wypróbuj e17 i lxde, bo kde czy gnome to straszne ślimaki mimo wszystko.
    Jeśli masz jakiś konkretny problem to pisz.
  • Poziom 16  
    A np. ubuntu w wersji live działa bez problemu?
    Może by spróbować jakieś wersji z pendrive'a?
    Może najpierw spróbować na jakimś wirtualu ?
  • Poziom 28  
    Dokładnie, virtualbox - tworzysz virtualną maszynę, przydzielasz jej dysk z 10 GB i rozrabiasz do woli :] , problem z nagrywaniem znika bo wszystko zainstalujesz z obrazów iso. Do komfortowej zabawy wystarczy 1 GB ramu.
  • Poziom 8  
    A korzystając z okazji co do Ubuntu ( które też anwiasem mówiąc u mnie trochę wariuje ) Czy ktoś zna jakiś sposób aby prędkość wiatraka od GPU ustawić na max na stałe. Ubuntu 11.04 niebiańska nimfa.
  • Poziom 35  
    viayner napisał:
    ... powtornie plyta RW i ta sama plyta byla uzywana np. do ...

    Niektóre urządzenia i programy "nie lubią" płyt RW. Spróbuj zwykłe CD/DVD-R (bez W na końcu).

    viayner napisał:
    W moim przypadku w wiekszosci sytuacji nawet nie ma trybu tekstowego, czasami jest tryb tekstowy i pokazuje co i jak laduje ale jak sie przelaczy do trybu graficznego to trace kontrole i nic nie widac

    Po automatycznym przełączeniu się do trybu graficznego używaj kombinacji klawiszy Ctrl+Alt+F1, Ctrl+Alt+F2, Ctrl+Alt+F3, Ctrl+Alt+F4 do przełączania się pomiędzy konsolami tekstowymi. Na pierwszej konsoli będzie podgląd procesu ładowania systemu. Kombinacje klawiszy od Ctrl+Alt+F5 do Ctrl+Alt+F12 służą do przełączania się na ekrany graficzne i ekrany diagnostyczne (jeśli system został odpowiednio skonfigurowany). W niektórych systemach ilość konsol tekstowych może być inna niż 4 (na przykład 6 lub 1), wtedy ekrany graficzne będą zaczynać się od pozycji innej niż F5.
  • Poziom 39  
    Witam,
    dziekuje za odpowiedzi,
    Zapomnialem wspomniec ze testowalem tes pendrive, efekty sa identyczne.
    Przy starcie gdzy system nie uruchamial sie w trybie graficznym wymuszalem tryb vga przy starcie ale nic to nie dawalo, testowalem rozne tryby ale zawsze upieral sie przy graficznym w max rozdzielczosci.
    Jedyne co mi sie udalo to USB na laptopie dela P4 2.2GHz gdzie w niepelnym trybie graficzny jakos to dzialalo na zdanym stacjonarnym nie odpalil system w trybie pozwalajacym na jego uzytkowanie.
    Potestuje virtual box - co polecacie ?
    Pozdrawiam
  • Poziom 16  
    ja używam Oracle VM virtual box w necie jak i na youtube jest mnóstwo poradników jak krok po kroku zainstalować system i odpalić, nie czytałem całego tematu ale jeśli masz win 7 to odradzam instalacje "wirtualnej maszyny microsoftu" przez pol dnia nawet nie udało mi się odpalić instalacji linuxa.
  • Poziom 10  
    Witam, ja miałem podobny problem, przyczyna była taka, że miałem dwie różne pamięci, czyli były 2 kości po 250 MB, ale były innych producetów, a na ubuntu to się gryzło takimi objawami jak podałeś, od tamtej pory jak kupuję ram to od tego samego producenta.
  • Poziom 39  
    Witam,
    na Oracle pod winXP wszystko chodzi dobrze i kazda dystrybucja z tej nieszczesnej plyty DVD-RW jak i USB zainstalowala sie poprawnie i dziala mimo symulacji duzo szybciej niz zainstalowana na golym komputerze. Debian przy ustawieniach 1 procesor AMD 768MB RAM/8GBdysk chodzi o wiele szybciej niz instalacja na tym samym komputerze bez virtualnej maszyny i XP (2xAMD 2GB RAM i 80GBdysk). Podobnie ubuntu instaluje sie szybko i pewnie.
    Niby wszystko dobrze ale nie rozwiazyje to problemu instalacji systemu na komputerze jako jedynego.
    Virualna maszyna symuluje srodowisko i komunikuje sie poprzez drivery XP (prosze mnie poprawic jak sie myle) oraz nie udostepnia wszystkich zasobow - jak sadze tu jest przyczyna, sam linux ma problemy z obsluga niektorych urzadzen (czytaj: u mnie wiekszosci). Przykladowo testowalem ubuntustudio10 ktore idelanie instaluje sie na VM ale nie instaluje sie na tym samym komputerze jako jedyny system.
    Tu jest "pies pogrzebany" jak dla mnie.
    Pozdrawiam
  • Poziom 10  
    mam pytanie w sumie dwa
    1 jak chcesz instalować ubuntu obok XP czy wykorzystasz cały dysk pod Limux
    2 jaki masz monitor
    a teraz dziś koledze instalowałem ubuntu 10.04 i przy instalacji wszystko poszło bez problemu ma pamięć tylko 500 Mb dysk 80 Gb a komp ma stary bo 5 letni ja bym ci poradził sprawdź pamięci czy masz takie same czyli tego samego producenta ja miałem każdą kość innego producenta i na XP działało normalnie ale na linux się sypało a odkryłem to bo miałem drugi komputer z parą pamięci jednego producenta i działało bez problemu
  • Poziom 39  
    Witam,
    Jak wspomnialem proby byly wykonywane na kilku roznych komputerach, ten na ktroym terach chodzi VM pod XP a na ktorym to zaden linux nie odpalil jako jedyny system to AMD MP+2600 x 2, 2GB RAMu, Plyta AMD nie pamietam symbolu, kontroler IDE i SCSI, karta ATI jakas z ostatnich AGP 64MB seria 9000. Pamieci identyczne tego samego producenta 4x512MB, instalacja ma byc jedyna, na tym komputerze chodzl debian jakas starsza wersja gdy byl serwerem.
    Co do pamieci to moge sie zgodzic ale nie potwierdza to problemu z innymi komputerami.
    Pozdrawiam
  • Poziom 36  
    Czy aby dana dystrybucja, nie była tworzona pod konkretny sprzęt? W biosie spróbuj wyłączyć, wszelakie opcje dotyczące oszczędzania energii, w szczególności video i ewentualnie ACPI. Na moim Mint9, było bardzo podobnie, i właśnie ustawienia biosu odnośnie wykorzystania energii, były kluczem do rozwiązania kłopotu.
  • Poziom 35  
    Jakieś stare te dystrybucje próbujesz, choć i sprzęt stary.
    Spróbuj coś mega stabilnego, np. Debian Stable, Scientific Linux, Centos i oczywiście pochwal się komunikatami, może masz coś niesprawne.
    Jeśli możesz to instalacje odpalaj bez opcji quiet i splash w grubie. Będzie więcej komunikatów.

    Przewineły mi się setki komputerów/płyt głównych przez ręce i tylko RAZ trafiłem na płytę (najprawdopodobniej była w specyficzny sposób uszkodzoną) na której nie dało się w końcu zainstalować jakiejś dystrubycji linuxa (chodzi o typowy sprzęt) a xp chodził.

    PS. Z tego co widzę ten konkretny sprzęt ma płytę serwerową i jest czasem problematyczny z linuksami (2 x Athlon MP), chodzi konkretnie o jądro z obsługą SMP. Spróbuj debiana stable x86, jak się zainstaluje to zrobisz upgrade do testing np. to 1 cd. Slax jest stary i może nie mieć włączonego SMP (obsługa więcej niż jednego procesora), dlatego chodzi.

    PS2. Możesz też spróbować dodać do parametrów jądra maxcpus=1 żeby wyłączyć jeden procesor i wtedy spróbować.
  • Poziom 39  
    Witam,
    jak wspominalem testowalem kilka linuxow pod virtual boxem i wzystkie dzialaja ale poprzez VB linux nie widzi "pelnego komputera".
    Wybor padl na Mandrive 2011, zainstalowala sie nawet sprawnie (40min). Wybralem aktualizacje systemu i pakietow i tu przy instalowaniu pakietu 53-55/151 dostaje komunikat o braku pakietu lub braku jakiegos z komponentow po czym system nie nadaje sie do uzytku. Z menu znika wiele opcji, system nie uruchamia sie ponownie nawet w trybie awaryjnym itp. Aktualizacje przeprowadzone przez wewnetrzne narzedzie mandrivy do tego przeiwdziane, system dopiero zainstalowany, zadnych zmian w opcjach.
    Ponowna instalacja i ponowny problem z aktualizacja na innym serwerze.
    Moze wymagam czegos dziwnego ale linux u mnie nie dziala i zniechecam sie do niego juz w 99%.
    Pozdrawiam
  • Użytkownik usunął konto  
  • Poziom 39  
    Witam,
    panie kolego jak wspomnialem walcze juz dluzszy czas i rezultaty sa bardzo negatywne.
    Nie udalo mi sie "odpalic" zadnego linuxa w stopniu pozwalajacym na normalna prace - wymagam aby wygladalo to tak jak po instalacji "jedynie slusznego systemu". Komputer sie uruchamia, aktualizuje i dziala.
    Wszystkie systemy dzialaja pod wlasnie tym VB pod XP ale nie dzialaja na tym samym komputerze jako jedyny system.
    Pozdrawiam
  • Użytkownik usunął konto  
  • Poziom 39  
    Witam,
    nie bardzo widze celowsci twoich uwag, pod VB u mnie tez wszystko dziala, jako jedny system nie, to ze dziala to u ciebie to bardzo dobrze ale w zaden sposob mnie to nie pomaga.
    Swoja droga ostatnie wpisy dotyczyly mandriva a nie ubuntu.
    Pozdrawiam
  • Użytkownik usunął konto  
  • Poziom 35  
    Viayner czy skorzystałeś z moich wskazówek i podpowiedzi?
  • Poziom 39  
    Witam,
    Jarosx9 - dziekuje, testowalem nie bylo zasadniczej roznicy, sadze ze ja cos nie tak robie. Co prawda ta Mandriva odpalila tyle ze dalej ..., Podczas ladowania w trybie tekstowym nie ma nic dziwnego czy jakichs niezgodnosci, nawet wykrywa bez problemy 2 kontrolery scsi z przyleglosciami.
    Potestuje inne dystrybucje ale nie bardzo mi sie chce wypalac kilkanascie plyt i moze jedna ruszy.
    Kolego slawek_ko, nadal nie widze sensu twoich uwag, chyba ze chcesz sie pochwalic kolejna swoja instalacja, nie to jest celem moich pytan czy i co udali sie tobie zainstalowac.
    Pozdrawiam
  • Użytkownik usunął konto  
  • Użytkownik usunął konto  
  • Poziom 1  
  • Poziom 39  
    Dziekuje bardzo,
    potestuje Minta, zgadzam sie z uwaga ze potrzebuje raczej prostego i samokonfigurujacego sie systemu ze wzgledu na moje bardzo niewielkie doswiadczenie na tym polu.
    Do Christophorus, Mandriva dzialala dobrze bez niespodzianek do chwili aktualizacji. Sprzet moze i nietypowy tyle ze byl na nim starszy debian, musze poszukac co to bylo dokladniej, i dzialalo jako serwer, Mandriva i slax odpalily w trybie graficznym jako jedyne, sprawdzalem na kartach ATI 9xxx, kilka Nvidii i jakis matrox.
    Pozdrawiam
  • Poziom 35  
    Jeśli system ci nie działa to jak to się objawia? Czarny ekran czy może jakieś komunikaty o błędach? Jeśli są jakieś komunikaty to jaka jest ich treść?
  • Użytkownik usunął konto