Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ZL11AVR - nie działa program. Problem z kondensatorem C1?

bujak10 19 Maj 2012 17:06 1725 13
  • #1 19 Maj 2012 17:06
    bujak10
    Poziom 7  

    Witam. mam pytanie do ludzi którzy bawili się na owej płytce. zamontowałem uklad i problem mam z kondensatorem C1. W pierwszym programie probnym z ksiazki mikrokontrolery dla początkujacych powinien byc efekt na wyswietlaczu led pokolei zapalane tzw. efekt plyniecia ekranu. Owy program nie zadzialal, wzialem na chybil trafil poruszalem kondensatorem c1 i nie mialon styku przy poruszaniu program zadzialal i chcialem go dolutowac i cos popsulem najwidoczniej, nie wiem czy nie sciezke plytki, czy ktos wie za co ten kondensator odpowiada, teraz z odlaczonym kondensatorem c1, napisalem z ciekawosci cwiczenie 1 czyli zaswiecanie kropek na owym wyswietlaczu za pomoca przyciskow, i ku mojemu zdzwieniu... zadzialal, czy ktos moze mi powiedziec jakie znaczenie ma ten kondensator i cokolwiek podpowiedziec czy da sie cos zrobic jesli okazalo sieze to wejscie na kondensator c1 jest zepsute. Licze na odpowiedz osob ktore uzywaly i bawily sie tym ukladem.

    0 13
  • #2 19 Maj 2012 17:33
    dondu
    Moderator Mikrokontrolery Projektowanie

    Może dorzuciłbyś chociaż link do schematu: http://www.btc.pl/pdf/zl11avr.pdf
    i zdjęcia uszkodzonych ścieżek przy C1?

    O ile dobrze sprawdziłem, C1 odpowiada za magazyn energii dla wyświetlaczy LCD.

    Nie jest to krytyczny element gdy cała płytka wraz z LEDami nie zużywa jakichś granicznych wielkości prądu. Innymi słowy ma prawo działać bez niego gdy nie zapalasz zbyt dużo LEDów wyświetlacza.

    Jednakże gdy wzrośnie pobór prądu (np. większość LEDów będzie świecić) to mogą wystąpić zakłócenia na zasilanie, co może skończyć się niekontrolowanym działaniem. Zadbaj by ten kondensator prawidłowo podłączyć.

    Swoją drogą jest on na schemacie dość niefortunnie umieszczony. Dopiero wgląd w płytkę PCB upewnia do czego on służy.

    0
  • #3 19 Maj 2012 17:50
    bujak10
    Poziom 7  

    ZL11AVR - nie działa program. Problem z kondensatorem C1?

    ZL11AVR - nie działa program. Problem z kondensatorem C1?

    zdjecia wejsc pod kondensator C1

    obawiam sie że przegrzałem wejścia i cięzko będzie go teraz przylutować. Szczerze to nie mam pomysłu co zrobić. za cholere cyna sie juz nie trzyma w tym miejscu i nóżki latają, probowałem podłączyć na chwile ruszając nim tak zeby złapał chwilowo styk ale nie łapie wogole, i nie wiem jak można sprawdzić czy ta ścieżka nie jest zepsuta. I ewentualnie co zrobić jeśli jest zepsuta, czy da rade jakoś z tego wybrnąć jeszcze?

    0
  • #4 19 Maj 2012 18:01
    piotrva
    Moderator na urlopie...

    Płytki tej nie miałem nigdy w ręce, ale z rysunków wynika, ze pod soldermaską ścieżki do tego kondensatora powinny być dosyć szerokie, rozwiązanie to delikatne zdrapanie soldermaski obok otworów (tylko z interesujących nas ścieżek oczywiście), następnie pocynowanie odsłoniętych fragmentów z wykorzystaniem kalafonii i cyny lub pasty lutowniczej i przylutowanie do nich odpowiednio wygiętych nóżek kondensatorka.

    0
  • #5 19 Maj 2012 18:06
    bujak10
    Poziom 7  

    Dzieki bardzo za rady, wypróbuje dzis pozno lub jutro bo wychodze. Jak spróbuje to dam znać i ewentualnie poprosze o kolejne rady. Jeszcze raz dzięki i zjawie sie jutro.

    0
  • #6 20 Maj 2012 23:42
    bujak10
    Poziom 7  

    Wracam do pytania w troszke inny sposb. nie wiem czemu chyba to tak na przekor losowi spróbowałem innej metody poleconej przez znajomego ktory bawil sie w elektronike i aby włączyć kondensator C1 powiedział żebym zrobił nastęująco: nożke oznaczoną jako - podpiąc do nóżki - kondensatora C2 natomiast nóżke kondensatora C1 oznaczoną jako + podlączyć do dalej idącego rezystora R12, zrobiłem tak i teraz nawet ten wcześniejszy program nie chce działać co działał wcześniej. Cóż mogłem teraz popsuć? Czy ktokolwiek wie co mogło się stać i jak z tej sytuacji wybrnąc?

    0
  • #7 20 Maj 2012 23:47
    dondu
    Moderator Mikrokontrolery Projektowanie

    bujak10 napisał:
    Wracam do pytania w troszke inny sposb. nie wiem czemu chyba to tak na przekor losowi spróbowałem innej metody poleconej przez znajomego ktory bawil sie w elektronike i aby włączyć kondensator C1 powiedział żebym zrobił nastęująco: nożke oznaczoną jako - podpiąc do nóżki - kondensatora C2 natomiast nóżke kondensatora C1 oznaczoną jako + podlączyć do dalej idącego rezystora R12, ...

    I dobrze Ci doradził.

    bujak10 napisał:
    ..., zrobiłem tak i teraz nawet ten wcześniejszy program nie chce działać co działał wcześniej. Cóż mogłem teraz popsuć? Czy ktokolwiek wie co mogło się stać i jak z tej sytuacji wybrnąc?

    Widocznie coś nie tak zrobiłeś lub masz jeszcze inne problemy na tej płytce.
    Pokaż dokładne ostre zdjęcie tej poprawki.
    W ogóle przydałoby się ostre zdjęcie całości bo te które zamieściłeś są do bańki - znajdź aparat z funkcją MAKRO i oprzyj ręce w czasie robienia zdjęcia.

    0
  • #8 20 Maj 2012 23:50
    bujak10
    Poziom 7  

    No dobrze ale co mogłem źle zrobić skoro zauważcie że program który był wcześniej wgrany działał i nawet mu go pokazywałem, I układ był w stanie bez kondensatora C1, działało sprawnie zapalanie 2 kropek na wyswietlaczu, potem sprobowałem podłączyć na krótko tak jak wspomniałem, zrobiłem to, wgrałem program ten sam i nic tym razem się nie dzieje, Jakiekolwiek może sugestie wam nachodzą co sprawdzić? co mogło być nie tak?
    Niestety nie dysponuje aparatem w tym momencie przy sobie, zdemontowalem już ten kondensator. pokaże jedynie schematycznie na starym rysunku co w jaki sposób to zrobiłem.

    ZL11AVR - nie działa program. Problem z kondensatorem C1?

    0
  • #10 21 Maj 2012 17:32
    bujak10
    Poziom 7  

    Zrobiłem zdjęcia lustrzanką. Nie jestem dobry w robieniu zdjec robilem szybko takze zrobilem duzo i wrzuce wszystkie. Myślałem sporo i nadal kurde nie mam zadnego pomysłu co może być nie tak. Jak można sprawdzić wogóle sprawność podłączenia i co może być nie tak. Bede wdzieczny za wszelką pomoc i wskazówki.

    ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1? ZL11AVR - nie działa program. Problem z kondensatorem C1?
    ZL11AVR - nie działa program. Problem z kondensatorem C1?

    0
  • #11 21 Maj 2012 19:18
    dondu
    Moderator Mikrokontrolery Projektowanie

    Muszę Ciebie zmartwić. Niestety poziom lutowania pozostawia wiele do życzenia, a tutaj może leżeć więcej problemów niż tylko ten kondensator. Spodziewałbym się zimnych przegrzanych lutów, które mogą być tylko dla gołego oka prawidłowe. I to może dot. całej płytki :(

    Szukanie błędu należałoby rozpocząć od modułu zasilania i sprawdzenia wszelkich elementów podłączonych do linii zasilających. Multimetr + lupa. To żmudna robota ale trzeba ją wykonać. Dopiero wtedy będzie można przejść do testowania poszczególnych elementów.

    Dobrze byłoby żebyś przeczyścił ten fragment płytki na którym są białe naloty i resztki po lutowaniu i zrobił jego zbliżenie obu stron płytki.

    Spróbuj zrobić zdjęcia bez lampy błyskowej ale ze statywu i przy oświetleniu dziennym lub sztucznym z korekcją barwy.

    0
  • #12 21 Maj 2012 19:52
    bujak10
    Poziom 7  

    tzn.? bo ja jestem niestety amatorem w tych sprawach dopiero powiedzmy zaczalem nauke, wiec gdybys mógł powiedziec jak to zacząć sprawdzać czym i co sprawdzać wogóle

    0
  • #14 21 Maj 2012 20:00
    bujak10
    Poziom 7  

    zimne luty to wiem co to są i sam sie obawiałem o to czy nie bedzie z tym problemu i zdaje sobie sprawe tylko jak to teraz sprawdzic czy to wszystko działa i jest dobrze podłączone, zasilanie działa sprawnie z obydwu rodzajów zasilania i z usb i z zasilacza 12V, pali sie dioda odpowiedzialna za to.

    0