Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

samochodowa ładowarka USB- włącznik po kablu i zapytanie o led

El_Zdzichu 05 Cze 2012 13:32 3387 0
  • #1
    El_Zdzichu
    Poziom 9  
    Witajcie.
    Mój projekt jest bardzo skromniutki w porównaniu do prezentowanych na forum.
    Jako kompletny amator i laik w elektronice, myśle że warto sie pochwalić że cokolwiek udało mi się zrobić:)
    Jednocześnie mam problem- nie wiem jak podpiąć led sygnalizujący o pracy ładowarki, ale o tym potem.

    Sprawa wygląda tak. Chcę w moim aucie Lancii Lybrze zamontować taką stację dokującą do iphone- która by była na stałe w wysuwanej szufladce przy kierownicy.
    Służyła by do ładowania telefonu oraz jako źródło dźwięku idące przez AUX do radia.
    To drugie to osobny temat- dużo z tym kombinacji też było.

    Do całości przymierzam sie i kompletuje wszystkie drobniutkie graciki już chyba 1.5 roku:)
    Wydaje sie śmieszne, ale zdobycie schematu podłączeń do radia w tym aucie nie jest takie proste, potem dobranie jakiegoś cieńkiego 8żyłowego kabla...stacje dokującą też trzeba było dopasować....już większość zrobiłem ale jeszcze jest dużo do zrobienia zanim skończe.

    No a wracając do tematu- . Ponieważ chcę żeby wszystkie kabelki były pochowane z tyłu. to muszę zrobić włącznik do ładowarki... ale włącznik to dodatkowy kabelek- a ja jestem minimalistą i wziąłem sobie za cel żeby ich było jak najmniej.
    Zacząłem rozkminiać jak by tu zrobić włącznik na tym samym kablu usb który dochodzi do iphone- ale żeby jednocześnie nie przerywał on obwodu już między ładowarką a telefonem- tylko na samym początku- przed ładowarką (żeby nie ciągnęło prądu z akumulatora, skoro nie trzeba).

    No i po długich kombinacjach, okazało się, że w usb idą 4 żyły- ground (-), + 3V, oraz DATA - i Data + (5V).
    Czyli teoretycznie wszystkie zajęte, ale...
    w niemarkowych ładowarkach samochodowych...a może wszystkich? data + i - są ze sobą zwarte. także już można wykorzystać jedną żyłkę.
    Natomiast za drugą posłużył ground. Ponieważ okazało się, że do ładowarki wchodzi zasilanie oczywiście + i -, gdzie + leci sobie tam przez układziki, a - mimo że się rozgałęzia to idzie prosto na wyjście ground w usb.
    Zatem zrobiłem tak, że ground zamiast od ładowarki- idzie do żyły ground w USB- trafia na wyłącznik- jak go przejdzie to idzie rozdzielony na pin w iphone i jednocześnie wraca do samego początku ładowarki- wtedy załącza się ładowarka i jednocześnie zasila telefon:)
    Co myślicie o tym rozwiązaniu? Czy mogą sie pojawić przez to jakieś kłopoty?
    Załączam zdjęcie i prymitywnie narysowany schemat:
    samochodowa ładowarka USB- włącznik po kablu i zapytanie o led samochodowa ładowarka USB- włącznik po kablu i zapytanie o led samochodowa ładowarka USB- włącznik po kablu i zapytanie o led


    Mam nadzieje, że wszystko jest czytelne.

    W związku z tym "projektem" pojawił się mały problem.
    Jak widać na zdjęciu- ładowarka ma takiego LEDa podłączonego do jakiegoś układu- i sygnalizuje czy jest włączona czy nie...ale jak wiadomo, cała ładowarka będzie schowana wiec leda też widać nie będzie- a bez sensu żebym ciągnął dodatkowy kabel tylko dla diodki.

    Teraz pytanie jak podpiąć się pod styki w tym usb żeby diodka mi sygnalizowała włączenie.
    Jednocześnie żeby nie wpływała na napięcie i natężenie. Bo iphone jest ładowany jak np. ma włączony GPS i ciągnie dużo prądu, wiec musi byc tak jak ma być.
    Jak to podpiąć- szeregowo czy równolegle?

    Kupiłem takiego leda do SMD (niby na 3V)...ale była lipa, nie świecił mi na 3V- jak podpinałem do wyższego napięcia na 1s to świecił...ale przy dłuższym trzymaniu już sie palił.

    Próbowałem posprawdzać napięcia tej ładowarki miernikiem, ale raz mi wskazywał napięcie a raz 0.3V. Podpinałem i szeregowo i pomiędzy kolorami.

    Najchętniej podpiął bym tego leda na drodze tam gdzie jest włącznik, czyli na kablu zielonym. ale np. jak podłączyłem miernik szeregowo- to wogóle mi sie ładowarka nie włączyła- bo przez zieloną żyłę płynie prąd zasilający całe urządzenie.
    Pomożecie?
    Pozdrawiam
    Kuba