Elektroda.pl
Elektroda.pl
X
IGE-XAO
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

filtr średnich częstotliwości-odcięcie dolnych

29 Cze 2012 12:59 6406 45
  • Poziom 11  
    Witam !
    mam w domu pewien kolorofon 3 kanałowy z czego filtr wysokich i średnich działa poprawnie a średnie odcinają tylko górną granicę ok. 3,5 kHz a dolne reagują na wszystkie poniżej 20-3,5kHz chociaż powinno odcinać poniżej 1kHz
    jak sprawić aby odcinał te dolne częstotliwości ?

    filtr średnich częstotliwości-odcięcie dolnych

    Dodano po 43 [sekundy]:

    *wysokie i niskie działają poprawnie
  • IGE-XAO
  • Poziom 43  
    Możesz spróbować nieco zwiększyć pojemność C9 albo podmieniając kondensator albo dodając równoległy i zobacz na efekt.
  • Poziom 11  
    Zwiększałem wartość C9 oraz podmieniłem i efektu za dużego niestety nie widać ;/
    jak wartość jest za duża To kanał świeci cały czas a jak za mała to nie świeci w ogóle
  • Poziom 43  
    Podmieniałeś C8 czy C9? Zamiast regulować wartość C9 możesz też zwiększać R12.
  • Poziom 11  
    podmieniałem kondensator C9 a przy zwiększaniu wartości R12 zwiększa się zakres odcięcia górnych częstotliwości w sumie to próbowałem podmieniać wszystko a filtr nie chce odciąć tych dolnych częstotliwości czy może być to wina jakiejś wady w tym schemacie ?
  • Pomocny post
    Poziom 43  
    To jest prosty, pasywny filtr RC więc cudów nie będzie bo wszystkie elementy na siebie wpływają; jak by to był filtr aktywny to inna sprawa. Nie znam reszty układu więc podrzucam charakterystykę Twojego filtru - sam zobacz, że od tak prostych filtrów nie ma co wiele wymagać...

    filtr średnich częstotliwości-odcięcie dolnych
  • Poziom 11  
    dzięki wielkie!
    cóż jak widzę ktoś kto projektował ten kolorofon chyba nie pomyślał jak to poprawnie zrobić... :)
    a jest możliwość stworzenia filtru tak jak na schemacie o nowych całkiem innych wartościach które by trochę podniosły funkcjonalność tego filtru ? albo jakiś prosty aktywny filtr który bym mógł zastosować podmieniając za ten ?
  • Poziom 43  
    Poszukaj w sieci po prostu schematów kolorofonów - google grafika poda kilka odpowiedzi i wszystkie są praktycznie identyczne, różnice mogą być tylko w elementach ale relacje miedzy nimi mogą dać niezwykle zbliżone efekty.
  • IGE-XAO
  • Poziom 11  
    znalazłem kilka ciekawych np.
    https://obrazki.elektroda.pl/46_1198669324.gif

    ale zależało by mi najbardziej na zwykłym filtrze pasywnym żeby odcinał te częstotliwości poniżej 1KHz i powyżej 3-4 Khz...
    czy jest możliwość w ogóle jakoś obliczyć taki filtr ?
  • Poziom 11  
    no tak..
    ale ja efektów nie muszę mieć jakichś super z kosmosu wystarczy żeby chociaż odcinał w małej mierze te najniższe tony bo kanał średnich i niskich częstotliwości się zlewają całkowicie : )
  • Pomocny post
    Poziom 43  
    Możesz dać filtr 2 rzędu i zobaczyć co to da. Wrzucam screen z zabawy z 2 filtrami i ich charakterystykami obrazującymi działanie (lepsze stromości zbocza ale jednak kolejna strata sygnału). Oczywiście możesz to sobie sprawdzić w działaniu.
    filtr średnich częstotliwości-odcięcie dolnych
  • Poziom 11  
    wielkie dzięki jak tylko będę w sklepie elektronicznym i z złożę całość to dam znać jak to wyszło : )

    a mam jeszcze jedno pytanie w tym samym kolorofonie znajduje się coś takiego jak kanał ciszy, czyli jak niema muzyki żarówka się świeci a jak muzyka jest to gaśnie a przynajmniej takie jest teoretyczne działanie ale w praktyce coś nie działa bo się jak niema muzyki nie świeci...
    a tak wygląda to na schemacie :
    filtr średnich częstotliwości-odcięcie dolnych

    w sumie to jest coś takiego (znalezione na elektrodzie) tylko zamiast sumować sygnał ze wszystkich kanałów jest pobrany jeden i przez diodę 1N4148 :
    filtr średnich częstotliwości-odcięcie dolnych

    dioda Led to dioda w optotriaku tego kanału ciszy.

    Dodano po 29 [minuty]:

    mam jeszcze jedno głupie pytanie jak na początkującego elektronika przystało ;)
    co oznacza ten symbol kółko w środku "=" i "~" ?
  • Poziom 43  
    Jeśli nie świeci kanał Ciszy bez muzyki to coś padło. O jakie symbole Ci konkretnie chodzi?
  • Poziom 11  
    sprawdziłem tranzystory i są sprawne więc nie wiem co by mogło paść..
    a chodzi mi o ten symbol :
    filtr średnich częstotliwości-odcięcie dolnych
  • Poziom 11  
    ostatecznie postanowiłem wstawić do tego kolorofonu filtry aktywne (na zdjęciu) znalazłem je na schemacie innego kolorofonu " Jabel j-50" , po kupieniu wszystkich części i zamontowaniu tego wszystkiego na płytce uniwersalnej (nie mam możliwości na dzień dzisiejszy wytrawienia płytki ) z tym że zamiast układu lm324 dałem dwa układy lm358 bo takie plątały mi się po szafkach, historia powtórzyła się ponownie tak samo.. tylko filtr niskich częstotliwości działa normalnie a filtr średnich odcina tylko wysokie częstotliwości a niskich nie odcina w ogóle, natomiast filtr górnych częstotliwości reaguje na pełen zakres częstotliwości 20- 20 Khz , a do tego działa tylko wtedy gdy na potencjometrze najedzie się na pewien punkt czyli odpowiednia rezystancja tak jakby uruchamiała ten filtr czyli niema tu w ogóle żadnej regulacji.
    Całą płytkę sprawdziłem kilka razy i jest na pewno dobrze wszystko przylutowane.
    czy może być to wina zmiany układu scalonego na inny ?
    filtr średnich częstotliwości-odcięcie dolnych

    Dodano po 2 [godziny] 23 [minuty]:

    dodam do tego że zastosowałem potencjometry 50K czy może być to też przyczyną tych usterek ?
  • Specjalista - zasilacze komputerowe
    W podobnej sytuacji próbowałbym uniezależnić się od impedancji wyjściowej źródła sygnału.
    Impedancja wejściowa układu to nieco ponad 5,6K. Impedancja wyjściowa potencjometru (50K) waha się od kilku omów do ok. 12K zależnie od położenia suwaka.
    Może warto wstawić wtórnik pomiędzy ślizgacz potencjometru a wejście filtru.

    Dodano po 3 [minuty]:

    Jak zasilany jest LM358? Czy ma ujemne napięcie?
  • Poziom 11  
    Układ zasilany jest napięciem 18V podłączonym bezpośrednio z transformatora niesymetrycznego więc nie mogę pobrać ujemnego napięcia.
    przeszukałem trochę szafki i znalazłem potencjometry 100K, czy jest sens je wymieniać ?

    Dodano po 13 [minuty]:

    moja przygoda z elektroniką dopiero pomału się rozkręca więc moja niewiedza może być w pewnych momentach zaskakująca ; )
    mam pewien zasilacz symetryczny z tym że jego napięcie po wyprostowaniu to 9V ,0,-9V czy przy filtrach może taki "nagły spadek napięcia" coś zmienić ?
    i czy dla takiego filtru jest bardzo istotne zasilanie ujemnym napięciem ?
  • Pomocny post
    Specjalista - zasilacze komputerowe
    mikrash1 napisał:
    Układ zasilany jest napięciem 18V podłączonym bezpośrednio z transformatora niesymetrycznego
    Jak więc miałoby to działać?
    Jeśli "dolne" zasilanie wzmacniacza jest na potencjale masy oraz wejście (+) też na tym samym poziomie to wzmacniacz posłusznie wypracuje na wyjściu napięcie równe napięciu wejścia nieodwracającego - czyli 0V.
    Ze ślizgacza potencjometru dochodzi napięcie zmienne o częstotliwościach akustycznych.
    Załóżmy, że ma amplitudę 1V. Po przejściu przez dzielnik i kondensator mamy ok. 90 mV bezpośrednio na wejściu odwracającym.
    Kondensator odcina ewentualną składową stałą więc na wejściu mamy raz +90 mV a dla drugiego półokresu -90 mV.
    Tak zasilony wzmacniacz nie będzie w stanie liniowo pracować (nie odpowie na wyjściu napięciem ujemnym).

    Dla poprawnej pracy potrzeba więc albo zasilania niesymetrycznego, albo podniesienia poziomu masy przynajmniej o wartość spodziewanej amplitudy (plus niewielki zapas) napięcia na wyjściu.

    Można do tego wykorzystać czwarty wzmacniacz zamieniając go we wtórnik napięciowy. Do wejścia nieodwracającego 2 rezystory - jeden do (+) zasilania drugi do masy. Wyjście wzmacniacza to potencjał masy dla pozostałych wzmacniaczy filtrów aktywnych.
    Dla "usztywnienia" potencjału w ten sposób wytworzonej masy należy podłączyć kondensator np 100µ pomiędzy (-) zasilania układu a wyjście wzmacniacza (nóżka 1).
  • Poziom 11  
    dziękuję bardzo za te uwagi, mam jak widać jeszcze za mało doświadczenia : )
    więc zaraz chwytam się za przeróbki odpowiednie, wykorzystam zasilacz symetryczny 9V zobaczymy co z tego wszystkiego będzie : )
    a czy przy wzmacniaczu źródła sygnału też trzeba tak samo podłączyć zasilanie żeby odpowiedni sygnał był dla tych filtrów czy to już niema znaczenia (jeżeli tak to to by wyjaśniało dlaczego nie działały odpowiednio filtry pasywne ) ?
  • Specjalista - zasilacze komputerowe
    mikrash1 napisał:
    a czy przy wzmacniaczu źródła sygnału też trzeba tak samo podłączyć zasilanie żeby odpowiedni sygnał był dla tych filtrów czy to już nie ma znaczenia
    Oczywiście :)
    Jeśli zabrałeś się za konstrukcję takiego urządzenia to powinieneś je uruchamiać stopień po stopniu. Najlepszym rozwiązaniem byłoby użycie oscyloskopu do obserwacji poszczególnych stopni. Niestety nie zawsze jest to możliwe - trzeba więc sobie inaczej radzić.
    Dobrym sposobem oceny jakości pracy wzmacniacza akustycznego jest podsłuch sygnału na jego wyjściu.
    Można skonstruować prosty wzmacniacz zasilający słuchawki w oparciu o typowy wzmacniacz m. cz. (rozwiązań pełno w sieci). Byłby to rodzaj sondy akustycznej do subiektywnej oceny pracy badanego stopnia.
  • Poziom 11  
    na razie tego typu sprzęty jak oscyloskop są w dalekich planach u mnie gdyż muszę się jeszcze podszkolić "troszkę" a dostępu także puki co nie mam ; )

    ten kolorofon poskładałem w sumie z kilku schematów (na złączonym obrazku główny) wnioskuję , że jego twórca popełnił kilka błędów bo można wywnioskować że zasilanie pochodzi z transformatora niesymetrycznego więc cały ten schemat nie ma prawa poprawnie działać..?
    filtr średnich częstotliwości-odcięcie dolnych
  • Specjalista - zasilacze komputerowe
    mikrash1 napisał:
    ...więc cały ten schemat nie ma prawa poprawnie działać..?
    Ależ tu jest wszystko w najlepszym porządku.
    Wzmacniacz operacyjny zasilany jest asymetrycznie ale potencjał wejścia (+) jest wyraźnie określony na połowę napięcia zasilania (R2 i R3).
    Skoro na wejściu nieodwracającym jest 6V to wzmacniacz wypracuje na wyjściu takie napięcie by napięcie różnicowe (U+ - U-) było równe 0. Czyli 6V.

    Ten układ jest dobrym punktem wyjścia do zaprojektowania własnego kolorofonu na 2 "kostkach" (np LM324 czy TL074). To w sumie 8 wzmacniaczy operacyjnych.
    Jeden jako wzmacniacz wstępny, 3 jako wtórniki, 1 jako układ wytwarzania napięcia polaryzacji do pozostałych wzmacniaczy oraz 3 jako filtry aktywne. Razem 8 szt.
    Schemat może być w postaci skanu (bądź czytelnego zdjęcia) rysunku odręcznego.
  • Poziom 11  
    tylko szczerze powiedziawszy chciałem doprowadzić ten kolorofon tak jak jest do porządku gdyż znajomy wytrawił mi płytkę a nie będę miał możliwości w najbliższym czasie stworzenia nowej więc puki co spróbuje zrobić coś z tym starym kolorofonem : )
    mam już przygotowany zasilacz więc spróbuję to podłączyć tak jak należy
    bardzo dziękuję za poprawienie mnie z mojego błędnego myślenia w stosunku do tego schematu :D

    Dodano po 1 [godziny] 28 [minuty]:

    cóż podłączyłem wszystko dokładnie tak jak na tym schemacie :
    filtr średnich częstotliwości-odcięcie dolnych

    i niestety wciąż nie działa nic poprawnie...;/
    diody w sumie cały czas świecą z tym że dioda dla najwyższych częstotliwości świeci się dopiero po ustawieniu odpowiedniej rezystancji na potencjometrze.
    patrząc na ten schemat ( namalowany pośpiesznie w paincie ;D) czy nasuwa się jeszcze coś co odpowiadało by za niedziałanie tego układu ?

    Dodano po 24 [minuty]:

    a czy napięcie 9V jest wystarczające do zasilenia tego układu skoro w orginale było 12V ?
    dodam jeszcze na wszelki wypadek schemat zasilacza :
    filtr średnich częstotliwości-odcięcie dolnych

    Dodano po 4 [minuty]:

    trzeba jeszcze dodać do tego że po takim podłączeniu zaczęły się grzać układy lm358
  • Specjalista - zasilacze komputerowe
    Układ jest poprawny. Bez sygnału akustycznego na wyjściach wzmacniaczy powinno być 0V. Na zasilaniu "górnym" +9V. na "dolnym" -9V. Oczywiście masa stopnia końcowego (T2,4,6) powinna zostać odłączona od dawnego punktu bo to teraz jest potencjał -9V.
    Emitery w/w tranzystorów (oraz R9,14,18) powinny być teraz na potencjale masy (nóżka 4 LM358).
    Poza tym zamiast wstawiać tam TL071 można wykorzystać 4-ty (wolny) wzmacniacz.

    A co do płytki... To nie pierwsza, którą spotkał taki los. Po prostu powstała za wcześnie. Układ musi najpierw zadziałać w tzw pająku a potem po uruchomieniu i korektach układowych zabieramy się do projektowania płytki. Oczywiście mając wcześniej przemyślaną wizję końcowej postaci układu (wielkość obudowy, rozmieszczenie w niej elementów, położenie gniazd, potencjometrów etc).
  • Poziom 11  
    a czy dał by radę użytkownik -W.P -wprowadzić te zmiany na tym schemacie najprostszym sposobem w paincie w wolnej chwili?
    bo szczerze powiedziawszy już się pogubiłem. :)

    Dodano po 20 [minuty]:

    +dodam do tego że nie mam za bardzo dostępu do sklepu elektronicznego a kilku części na internecie też się nie opłaca zamawiać i dlatego tak mi zależy żeby zrobić to na tych częściach które leżały mi po szafkach ;)

    Dodano po 1 [godziny] 58 [minuty]:

    a tak jeszcze patrząc na ten pierwotny schemat czy te filtry po prostu zostały źle policzone skoro nie odcinały poprawnie danych częstotliwości ?
    na płytce wszystko było podłączone dobrze zasilanie było asymetryczne bo schemat nie wymaga symetrycznego.
  • Specjalista - zasilacze komputerowe
    Wszystko jest na schematach z 12.07. Jedyne co bym dodał to rezystory w bazach T2, T4, T6 o wartości 1÷4,7K.
  • Poziom 11  
    Podłączyłem to wszystko dokładnie tak ale dalej coś nie działa diody zaczynają podejrzanie mrugać (a mam podłączony do tego również stroboskop led i dioda po takim podłączeniu zasilania zaczyna mrugać w zastraszającym tempie i regulacja na nią nie działa) czyli coś się tu zaczyna dziać. sprawdziłem wszystkie płytki w poszukiwaniu jakiegoś zwarcia ale wszystko wygląda na dobrze zmontowane.
    co może być przyczyną tak dziwnego zachowania tego układu ?
    (sprawdziłem wszystkie tranzystory i nie są spalone)

    Dodano po 29 [minuty]:

    wszystko jest podłączone dokładnie tak :
    filtr średnich częstotliwości-odcięcie dolnych
  • Pomocny post
    Specjalista - zasilacze komputerowe
    mikrash1 napisał:
    wszystko jest podłączone dokładnie tak
    Czy wczytałeś się w to co napisałem rano?
    Skąd pomysł przeniesienia emiterów tranzystorów stopnia końcowego na poziom -9V?
    Na wyjściach wzmacniaczy jest 0V, na emiterach T1,3,5 też 0V zatem stopnie końcowe są teraz wysterowane prądami baz:
    Ib = (9V - Ube) / 4,7K
    Ube≈0,6V
    Prąd bazy będzie na poziomie 2 mA.
    mikrash1 napisał:
    co może być przyczyną tak dziwnego zachowania tego układu ?
    W obwodzie kolektora są 3 diody + rezystor 220Ω. Całość zasilana z 18V czyli:
    (18V - 3 x 1,8V) / 220Ω = 57 mA
    Trochę dużo.

    Przenieś emitery z poziomu -9V na poziom masy. Bez sygnału akustycznego (bez stopnia wstępnego na TL071) diody mają nie świecić.
  • Poziom 11  
    ajj fatalny błąd z mojej strony nie pomyślałem nad tym-dziękuje za poprawę!
    proszę się nie sugerować tymi diodami nie chciałem już przerabiać całości schematu bo chodzi mi tu o filtry ale na wyjściu tranzystorów zamiast diód są optotriaki moc3021 które sterują triakami gdyż cały układ działa na żarówkach 230V.
    zaraz postaram się poprawić błędy i zobaczymy co z tego będzie. :)

    Dodano po 3 [minuty]:

    gdy sprawdzam działanie układu w miejsce diody optotrika podłączam po jednej diodzie przezroczystej -czerwona-niebieska-żółta

    Dodano po 1 [godziny] 6 [minuty]:

    teraz podłączyłem wszystko poprawnie i jedynym efektem zadowalającym jest to że diody wszystkie naraz nie świecą a dioda dla niskich częstotliwości "grzecznie" się zapala przy odpowiednich częstotliwościach ale niestety na tym koniec...;/
    dioda dla średnich częstotliwości odcina tylko górne cz. a dolnych już nie i świeci razem z diodą niskich cz.
    a za to dioda wysokich świeci cały czas i tylko wtedy gdy potek wskaże odp. opór
    (czy mógłby mi ktoś wytłumaczyć to zjawisko dlaczego świeci dopiero po ustawieniu odp rezystancji na potencjometrze co idzie za tym że niema żadnej regulacji ? )

    Dodano po 2 [minuty]:

    irytującym jest fakt że dla filtrów pasywnych efekt był identyczny jak dla całkiem nowo zrobionych filtrów aktywnych : )

    Dodano po 7 [minuty]:

    aa i zapomniał bym dodać- że winą tego że wszystko świeciło naraz był wadliwy kondensator filtrujący napięcie po jego wymianie wszystko wróciło do normy