Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Computer Controls
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Rozdzielenie mas w układzie.

30 Cze 2012 00:24 7419 60
  • Poziom 16  
    Witam,

    Próbuję stworzyć sterownik do bramy dwuskrzydłowej. Układ opiera się o Atmegę 16. Na sucho wszystko działa jednak po podłączeniu silnika Atmega zaczyna działać sobie, tzn zachowuje się tak jakby na zamianę otwierać i zamykać, a więc uruchamia silnik, jak już rozpędzi to go hamuje, zmienia kierunek i w drugą stronę i tak w koło (start i zatrzymanie z wykorzystaniem PWM), przy tym bardzo mocno grzeje się BUZ. Szukałem rozwiązań na zakłócenia ale wszystkie poprawki nie dawały sukcesu. Postanowiłem rozdzielić masy. Mam oddzielne zasilanie Atmegi i silników. No i mam problem. Jak rozdzielić masy, żeby poprawnie działał BUZ? Aktualnie podpiąłem tą masę za bocznikiem do +24, a masę za opornikiem R18 do +12. Efekt jest taki, że po włączeniu układu na wyjściu na silnik idzie 9V, a jak Atmega da sygnał na tranzystor BC547 to napięcie na silnik spada do 6V. Jak to prawidłowo podłączyć?

    Druga sprawa, to z bocznika brałem napięcie i podawałem do Atmegi i dzięki temu zrobiłem sobie zabezpieczenie gdyby pojawiła się przeszkoda. Przy oddzielnych masach chyba to też nie będzie działało?

    Układ:
    Rozdzielenie mas w układzie.

    Na schemacie jest przekaźnik, który zmienia polaryzację, sterowany przez Atmegę z +12.

    Proszę o pomoc.
    pozdrawiam
    Daniel

    Dodano po 3 [minuty]:

    Dodam jeszcze, że przy tych 6 voltach silnik drży, przy 9 zaczyna się kręcić, ale układ nie wariuje. Więc wydaje mi się, że to rozdzielenie mas pomoże ustabilizować pracę układu.
  • Computer Controls
  • Poziom 16  
    A spróbuj masy zapodać przez jakieś diody prostownicze, może 1N4007 - tak z zapasem troche.

    Ja to bym inaczej zrobił, bo żadko widywałem aby BC547 działał pod + i to jeszcze 12V omg xD
    Czyli na emiter dawaj mase przez diode a collector podlacz bezposrednio do BUza

    i jeszcze rezystor 10k między bazą a emiterem

    Dodano po 3 [minuty]:

    takie podłączenie BC547 jest przezemnie używane już od 3 lat i działa na 100%
  • Computer Controls
  • Poziom 16  
    Czy chodziło o coś takiego?:

    Rozdzielenie mas w układzie.

    Bo nie chce mi to działać i nie bardzo widzę, żeby to mogło działać:) chyba Cię nie zrozumiałem.

    Faktycznie chyba trochę namieszałem z tym sterowaniem. Schemat z linku, który podesłałem wyżej działa poprawnie, ale żeby BUZ nie pracował, na BC muszę podawać 5V, a żeby pracował to 0V. Chciałem wzbudzać go stanem wysokim stąd połączyłem jak na schemacie z postu pierwszego.

    Tak czy inaczej sterowanie BUZem jest to jakiś pośredni problem.
    Co zrobić, żeby rozdzielić te masy? Czy jest to możliwe?

    Daniel
  • Specjalista - urządzenia lampowe
    dzielik napisał:
    Próbuję stworzyć sterownik do bramy dwuskrzydłowej. Układ opiera się o Atmegę 16. Na sucho wszystko działa jednak po podłączeniu silnika Atmega zaczyna działać sobie, tzn zachowuje się tak jakby na zamianę otwierać i zamykać, a więc uruchamia silnik, jak już rozpędzi to go hamuje, zmienia kierunek i w drugą stronę i tak w koło (start i zatrzymanie z wykorzystaniem PWM),


    Procesor zaekranować wraz z całością sterowania. Sprawdzić filtrację zasilania procesora.

    dzielik napisał:
    rzy tym bardzo mocno grzeje się BUZ


    Sterowanie bramką MOSFETa woła o pomstę do nieba, jeśli procesor jest zasilany z +5V to nie możesz stosować wtórnika a klucz w układzie wspólnego emitera.

    dzielik napisał:
    Postanowiłem rozdzielić masy. Mam oddzielne zasilanie Atmegi i silników. No i mam problem. Jak rozdzielić masy, żeby poprawnie działał BUZ?


    Optoizolację możesz zastosować.

    dzielik napisał:
    Aktualnie podpiąłem tą masę za bocznikiem


    Ten bocznik to po co tam jest?

    dzielik napisał:
    do +24, a masę za opornikiem R18 do +12. Efekt jest taki, że po włączeniu układu na wyjściu na silnik idzie 9V, a jak Atmega da sygnał na tranzystor BC547 to napięcie na silnik spada do 6V.


    Tak zakręciłeś opis że nie można zrozumieć o co "biega". Schemat wstaw.

    dzielik napisał:
    Druga sprawa, to z bocznika brałem napięcie i podawałem do Atmegi i dzięki temu zrobiłem sobie zabezpieczenie gdyby pojawiła się przeszkoda. Przy oddzielnych masach chyba to też nie będzie działało?


    Zależy jak to jest podłączone - co masz za bocznikiem? Jakiś wzmacniacz operacyjny? To możesz z jego wyjścia sterować diodę transoptora i dalej port wejściowy procesora.

    Jeśli WO tam nie ma i spadek na boczniku sięga kilku woltów to masz błąd konstrukcyjny, bo BUZ się zatyka tym napięciem odkładającym na boczniku (napięcie G-S jest pomniejszone o ten spadek napiecia na boczniku).

    dzielik napisał:
    Czy chodziło o coś takiego?:

    Rozdzielenie mas w układzie.

    Bo nie chce mi to działać i nie bardzo widzę, żeby to mogło działać:) chyba Cię nie zrozumiałem.


    Jak ma działać, jak brak rezystora podciągajacego kolektor do +12V?
    Nadto dioda między emiterem a masą zbędna i brak rezystora miedzy pinem procesora a bazą - katujesz procesor i tranzystor prądem zwarcia.


    dzielik napisał:
    Schemat z linku, który podesłałem wyżej działa poprawnie


    I tego schematu sie trzymaj.

    dzielik napisał:
    ale żeby BUZ nie pracował, na BC muszę podawać 5V, a żeby pracował to 0V.


    No to dorzuć jeszcze jeden stopień na tranzystorze albo przepisz program.

    dzielik napisał:
    Tak czy inaczej sterowanie BUZem jest to jakiś pośredni problem.


    Nie byłbym taki pewien - objawy z cofaniem bramy mogą wskazywać na brak przemyślenia filozofii programu - jak masz obsłużony rozruch w kontekście "sprzężęnia zwrotnego" z napięcia pobieranego z bocznika?

    dzielik napisał:
    Co zrobić, żeby rozdzielić te masy? Czy jest to możliwe?


    Patrz wyżej. Ale jeśli są połączone tylko w jednym punkcie to nie upatrywałbym w tym połączniu problemów.
  • Poziom 33  
    Tutaj nie trzeba rozdzielać masy. Prawdopodobnie masz źle zaprojektowaną płytkę w kwestii prowadzenia masy. Czym większe prądy tym bardziej to się da we znaki. Nie podałeś zbyt wielu szczegółów oprócz kawałka schematu, to wiele powiedzieć nie można. Trzeba by przejrzeć całość.
  • Poziom 16  
    Tak wygląda cały układ:
    Rozdzielenie mas w układzie.

    Dodatkowo dołożyłem diodę Schotkiego 10A między drenem BUZa a +24V, nie ma tego na schemacie.
    Proszę również o inne uwagi, jeśli jest coś z nim nie tak.

    jdubowski napisał:
    dzielik napisał:
    Próbuję stworzyć sterownik do bramy dwuskrzydłowej. Układ opiera się o Atmegę 16. Na sucho wszystko działa jednak po podłączeniu silnika Atmega zaczyna działać sobie, tzn zachowuje się tak jakby na zamianę otwierać i zamykać, a więc uruchamia silnik, jak już rozpędzi to go hamuje, zmienia kierunek i w drugą stronę i tak w koło (start i zatrzymanie z wykorzystaniem PWM),


    Procesor zaekranować wraz z całością sterowania. Sprawdzić filtrację zasilania procesora.


    Możesz rozwinąć temat jak mam to zaekranować? Zrobiłem poligon na płytce i tą masę mam wszędzie...

    jdubowski napisał:
    dzielik napisał:
    rzy tym bardzo mocno grzeje się BUZ


    Sterowanie bramką MOSFETa woła o pomstę do nieba, jeśli procesor jest zasilany z +5V to nie możesz stosować wtórnika a klucz w układzie wspólnego emitera.

    Wracam do poprzedniego sterowania BUZem (widać na dołączonym schemacie, na początku posta)

    jdubowski napisał:
    dzielik napisał:
    Postanowiłem rozdzielić masy. Mam oddzielne zasilanie Atmegi i silników. No i mam problem. Jak rozdzielić masy, żeby poprawnie działał BUZ?


    Optoizolację możesz zastosować.


    No ale w jaki sposób podłączyć BUZ? On mi łączy układy - zasilanie Atmegi i zasilanie silnika. Gdzie wstawić transoptor?

    jdubowski napisał:
    dzielik napisał:
    Aktualnie podpiąłem tą masę za bocznikiem


    Ten bocznik to po co tam jest?


    Bocznik jest po to, żeby sprawdzać spadek napięcia na nim. Atmega porównuje go z wzorcowym i wyłącza układ jeśli jest za duże - takie zabezpieczenie przed przeszkodą.

    jdubowski napisał:
    dzielik napisał:
    do +24, a masę za opornikiem R18 do +12. Efekt jest taki, że po włączeniu układu na wyjściu na silnik idzie 9V, a jak Atmega da sygnał na tranzystor BC547 to napięcie na silnik spada do 6V.


    Tak zakręciłeś opis że nie można zrozumieć o co "biega". Schemat wstaw.

    Chciałem opisać jak rozdzieliłem masy na dwa układy:
    1. +12
    2. +24
    Rozdzielenie mas w układzie.


    jdubowski napisał:
    dzielik napisał:
    Druga sprawa, to z bocznika brałem napięcie i podawałem do Atmegi i dzięki temu zrobiłem sobie zabezpieczenie gdyby pojawiła się przeszkoda. Przy oddzielnych masach chyba to też nie będzie działało?


    Zależy jak to jest podłączone - co masz za bocznikiem? Jakiś wzmacniacz operacyjny? To możesz z jego wyjścia sterować diodę transoptora i dalej port wejściowy procesora.

    Jeśli WO tam nie ma i spadek na boczniku sięga kilku woltów to masz błąd konstrukcyjny, bo BUZ się zatyka tym napięciem odkładającym na boczniku (napięcie G-S jest pomniejszone o ten spadek napiecia na boczniku).

    Jest wzmacniacz, spadek jest rzędu kilkudziesięciu mV.

    jdubowski napisał:

    Dodano po 5 [minuty]:

    dzielik napisał:
    Czy chodziło o coś takiego?:

    Rozdzielenie mas w układzie.

    Bo nie chce mi to działać i nie bardzo widzę, żeby to mogło działać:) chyba Cię nie zrozumiałem.


    Jak ma działać, jak brak rezystora podciągajacego kolektor do +12V?
    Nadto dioda między emiterem a masą zbędna i brak rezystora miedzy pinem procesora a bazą - katujesz procesor i tranzystor prądem zwarcia.


    Czyli chodzi o taki układ (czyli tak jak wstępnie zrobiłem w schemacie):
    Rozdzielenie mas w układzie.
    W tym układzie silnik się kręci jeśli na bazę tranzystora nie daję napięcia czyli 0 z procesora, a silnik stoi w miejscu jeśli daję 1 z procesora. Chciałem, żeby to działało odwrotnie. Stan wysoki - silnik się kręci. Bramę na podwórku stosunkowo rzadko się otwiera, a procesor cały czas będzie musiał trzymać tą jedynkę. Tak z natury wydawało mi się, że lepiej byłoby odwrotnie, czy to bez różnicy z elektronicznego punktu widzenia?
    Oczywiście rezystor jest między bazą a procesorem.
  • Poziom 16  
    Załączam płytkę, zapewne koledzy macie rację i z nią jest problem... Da się to uratować, czy robić od nowa?
    Rozdzielenie mas w układzie.
  • Poziom 33  
    Nie muszą być dwie płytki, ważny jest przebieg masy. Na tej ciężko się zorientować jak to leci, bo masa jest wszędzie.
  • Poziom 16  
    I połączyć masy między płytkami?

    Czy może ktoś mi wyjaśnić czy da się rozdzielić masy między tymi płytkami. Chodzi mi o BUZ, który zawsze mi łączy oba obwody...
  • Specjalista - urządzenia lampowe
    dzielik napisał:
    I połączyć masy między płytkami?

    Czy może ktoś mi wyjaśnić czy da się rozdzielić masy między tymi płytkami. Chodzi mi o BUZ, który zawsze mi łączy oba obwody...


    Masz dwa wyjścia:
    - masy połączone _jednym_przewodem_
    - masy izolowane, wtedy do sterowania BUZ musisz mieć transoptor, podobnie dla przekaźników i sprzężenia zwrotnego.

    Przykład:
    Rozdzielenie mas w układzie.
  • Poziom 16  
    szod napisał:
    Nie muszą być dwie płytki, ważny jest przebieg masy. Na tej ciężko się zorientować jak to leci, bo masa jest wszędzie.


    Jak powinienem poprowadzić masę, żeby było poprawnie? Pytam tak ogólnie, czym się kierować przy tworzeniu płytki od nowa.
  • Poziom 33  
    Masę zasilacza z kondensatora wyjściowego poprowadź do układów sterujących silnikiem. Od tego samego kondensatora wyprowadź drugą ścieżkę do µC. Ścieżki będą się łączyć tylko przy kondensatorze. Szerokość ścieżek możliwie największa, zwłaszcza tych do elementów sterujących silnikiem. Kondensatory na zasilaniu µC tuż przy jego nóżkach obowiązkowe.
  • Poziom 16  
    Zabieram się za ponowne projektowanie płytki. Mam jeszcze pytanie:
    Chcę, żeby silnik się kręcił jeśli na procesorze jest 1, a stał w miejscu jak jest 0. W aktualnym połączeniu działa odwrotnie:

    Rozdzielenie mas w układzie.


    Czy poniższy schemat jest poprawny? (procesor w miejsce 5V z lewej strony)

    Rozdzielenie mas w układzie.
  • Poziom 33  
    Po co chcesz komplikować układ? Po to się programuje µC żeby dopasować go do układów współpracujących, a nie na odwrót. Przerobienie programu żeby silnik załączał się przy stanie logicznym 0 to żaden problem. Nie ma sensu dodatkowa komplikacja.
  • Poziom 16  
    Ok, nie będę kombinował i przepiszę program.

    Proszę jeszcze o spojrzenie na ostateczny schemat całego układu, coś trzeba poprawić?:
    Rozdzielenie mas w układzie.

    Znalazłem jeszcze w sieci taki schemat:
    Rozdzielenie mas w układzie.

    Czy te cztery diody przy silniku są potrzebne? Dołożyć je do schematu?
  • Specjalista - zasilacze komputerowe
    Czy nie przesadziłeś trochę z doborem tranzystorów sterujących cewkami przekaźników?
    Warto wcześniej zmierzyć (obliczyć) prąd cewki i wtedy dobrać odpowiedni, z 2-5 krotnym zapasem tranzystor. Potem wyznaczyć wartość rezystora w obwodzie bazy by włączony tranzystor znalazł się w stanie nasycenia z niewielkim przesterowaniem.

    Diody zabezpieczające tranzystor przed skutkami SEM samoindukcji w momencie wyłączania zwykle dobiera się większe. Tak więc zamiast 1N4841 wstawiłbym np 1N4001.

    Nie wiem jakim przekaźnikiem sterujesz ale przy 5V, 10K w bazie, i tranzystorze dużej mocy należałoby sprawdzić czy nie pracuje w stanie aktywnym.
    BDX33C... (10A, 70W) - to trochę jak armata na zająca. Szukałbym czegoś mniejszego i ok. 10-cio krotnie tańszego.

    Czy do uformowania sygnału RESET nie przydałby się jakiś kondensator? Procesor ma zacząć pracę dopiero po ustaniu wszystkich stanów nieustalonych w układzie.
  • Poziom 16  
    Czy wystarczy darlington BC517?
    To są zwykłe przekaźniki pobierające ~100-200 mA...

    Nie spotkałem się z kondensatorem przy resecie. Wstawić tam 100nF?

    Dzięki za uwagi.
  • Poziom 16  
    Tak oto wygląda schemat nowej płytki.

    Czy teraz jest szansa, że będzie działało? Proszę o uwagi.

    Rozdzielenie mas w układzie.

    i schemat:

    Rozdzielenie mas w układzie.
  • Specjalista - zasilacze komputerowe
    Czy przekaźnik PK230 jest konstrukcyjnie przeznaczony do pracy przy napięciu ok. 250V?
    Powiększyłbym odległość pomiędzy ścieżkami pod napięciem sieci a ścieżkami strony wtórnej. To tak ze względów bezpieczeństwa.
    dzielik napisał:
    To są zwykłe przekaźniki pobierające ~100-200 mA...
    To nie wystarczy np BC337?
    A tak na marginesie... Czy na prawdę nie masz omomierza? Przy projekcie trzeba czasem coś pomierzyć, czasem coś obliczyć, dobrać by móc później spokojnie spać.
  • Poziom 16  
    W.P. napisał:
    Czy przekaźnik PK230 jest konstrukcyjnie przeznaczony do pracy przy napięciu ok. 250V?


    Co to znaczy? Ma on taką specyfikację, więc chyba nie powinno być problemu, żeby poprawnie działał:

    Przekaźnik JQX115F/012-2ZS4
    Cechy:

    dwie pary styków przełącznych
    maksymalny prąd styków 16A
    maksymalne napięcie styków 250Vac/125Vdc
    napięcie cewki 12V
    zakres temperatur pracy -40...+85
    wymiary (mm) 29,0x12,7x15,7
    rodzaj wyprowadzeń - do druku
    odpowiednik RM85Z, ~RM83Z

    W.P. napisał:
    A tak na marginesie... Czy na prawdę nie masz omomierza? Przy projekcie trzeba czasem coś pomierzyć, czasem coś obliczyć, dobrać by móc później spokojnie spać.

    Nie rozumiem skąd ten komentarz? Oczywiście, że mam miernik i używam go...

    Zanim wytrawiłem płytkę, po kolei sprawdzałem jak się zachowują poszczególne elementy w tych moich mniejszych układach, tzn czy atmega odpowiednio załącza przekaźniki, czy odpowiednio działają tranzystory i mosfety i wszystko działało prawidłowo. Mam płytkę która działa, aż nie podepnę silniki. Wtedy nie działa.

    Czy przy tak poprowadzonych ścieżkach, nie będę miał zakłóceń?

    Dodano po 23 [minuty]:

    Rozsunąłem te ścieżki przy 230V, czy tyle wystarczy, więcej nie bardzo jest jak, ewentualnie może je zrobić trochę cieńsze? teraz maja prawie 4mm.

    Rozdzielenie mas w układzie.
  • Specjalista - zasilacze komputerowe
    Kolego dzielik nie bierz proszę moich uwag za przejaw napastliwości. Chcę Ci pomóc.
    Moje pytania brały się z lektury wątku, z której a wynika że masz dość mierne pojęcie o elektronice. Mimo wszystko cenię Twój upór w dążeniu do wykreowania ostatecznej wersji układu.
    Uspokoiłeś mnie co do doboru przekaźnika.
    Jeśli chodzi o odległości ścieżek strony wysokiego i niskiego napięcia to zwykle stosuję większe odległości - przynajmniej z 5 mm. Wiem, że nie wszyscy tak robią i układ działa. Słyszałem też o zasadzie 1 mm/KV ale nie podpisuję się pod nią. Po kilku miesiącach płytka może ulec zakurzeniu, zawilgocić się etc. Wypala się taka mała poprzeczna, czarna ścieżka w laminacie (nb dobrym izolatorze) łącząca zbyt blisko położone ścieżki miedziane.

    Co do ścieżek to moim zdaniem ścieżka masy poprowadzona jest prawidłowo. Gdybym miał dokonać makijażu to przesunąłbym nieco w prawo i trochę w dół F2 by odsunąć ścieżki masy. Tym sposobem odsuwam je od ścieżek styków przekaźnika.
    Ścieżkę (+) "LampkaMig" poprowadziłbym w drugiej (czerwonej) warstwie aż do listwy zaciskowej. Taki zabieg powiększa odległość pomiędzy ścieżką styku przekaźnika a ścieżką kolektora.
    dzielik napisał:
    Rozsunąłem te ścieżki przy 230V, czy tyle wystarczy, więcej nie bardzo jest jak, ewentualnie może je zrobić trochę cieńsze? teraz maja prawie 4mm.
    Nie wiem co tym przekaźnikiem chcesz załączać. Ze względów izolacyjnych możesz je trochę zwęzić a jeśli będzie tego wymagało obciążenie (powyżej 2A) to zawsze można pogrubić warstwą cyny - nie znam obciążenia :(
  • Poziom 16  
    Dzięki za pomoc. Powinienem zapytać na forum o schemat przed trawieniem pierwszej płytki, ale myślałem że zadziała. Pojęcie o elektronice jakieś tam mam, ale bardziej teoretyczne, a co wyszło w praktyce to widać:) . Tak naprawdę jest to mój pierwszy poważniejszy projekt, który wykonuję sam od początku do końca.

    W.P. napisał:
    Nie wiem co tym przekaźnikiem chcesz załączać.

    W układzie mam dwa zasilania. Jedno to zasilacz 12V 1,5A, a drugie to trafo 24V 200VA. Nie chcę, żeby to duże trafo cały czas pracowało i chciałem podłączyć je właśnie pod ten przekaźnik..., którym steruję z Atmegi. A więc przed załączeniem silników włączam trafo. Także większego obciążenia niż tam w układzie nie będzie, stąd zrobiłem najgrubsze ścieżki. Może zmniejszę je na 2.54mm i pokryję cyną po całości?

    Poprawiłem schemat, zgodnie z uwagami kolegi W.P.

    Rozdzielenie mas w układzie.

    Trawić? ;)
  • Specjalista - zasilacze komputerowe
    dzielik napisał:
    Trawić?
    Bałbym się sąsiedztwa na tej samej płytce przekaźnika wyłączającego indukcyjność transformatora i obwodów procesora.
    W momencie wyłączania pomiędzy stykami zapali się łuk elektryczny będący źródłem zakłóceń. 200VA sugeruje dużą indukcyjność uzwojenia.
    Jeśli dysponujesz przekaźnikiem z przezroczystą obudową to przyjrzyj się co dzieje się na stykach przy wyłączaniu.

    Zjawiska. o których piszę nie wystąpią przy przełączaniu pozostałych przekaźników gdyż tam możesz tuż przed przełączeniem wyłączyć Q3 lub Q4.

    Zastanawiam się jeszcze nad połączeniem wyjścia wzmacniacza operacyjnego z wejściem (3) IC1. Tu przyznaję nie mam wiedzy.
    Zastanawia mnie jednak jak poradzi sobie IC1 zasilany z napięcia +5V z analizą sygnału górnego nasycenia bądź ogólnie z napięciami powyżej 5V jakie mogą pojawić się na wyjściu wzmacniacza LM358 (zasilanego z +12V).
    dzielik napisał:
    Trawić?
    Czy ten układ działa w montażu "na pajączka"?

    Dodano po 12 [minuty]:

    Dobrą zasadą jest "zagospodarowanie" niewykorzystanych wzmacniaczy czy bramek pozostających w układzie scalonym. Jakkolwiek przy CMOS-ach to wręcz konieczność (wolne wejścia do masy lub do zasilania zależnie od funkcji) to tu akurat (wzmacniacz w technologii bipolarnej) można z tej zasady zrezygnować. Jednak połączyłbym 6 z 7 (jako jedno połączenie) oraz 5 z np 4 (jako drugie).
  • Poziom 16  
    W.P. napisał:
    Bałbym się sąsiedztwa na tej samej płytce przekaźnika wyłączającego indukcyjność transformatora i obwodów procesora.
    W momencie wyłączania pomiędzy stykami zapali się łuk elektryczny będący źródłem zakłóceń. 200VA sugeruje dużą indukcyjność uzwojenia.
    Jeśli dysponujesz przekaźnikiem z przezroczystą obudową to przyjrzyj się co dzieje się na stykach przy wyłączaniu.

    Nie jest on przeźroczysty ale wierzę Ci na słowo:) Wrzucę ten przekaźnik na drugą płytkę i wyprowadzę tylko złączki ARK do sterowania.

    W.P. napisał:

    Zjawiska. o których piszę nie wystąpią przy przełączaniu pozostałych przekaźników gdyż tam możesz tuż przed przełączeniem wyłączyć Q3 lub Q4.

    Dokładnie tak robię, najpierw odpowiednio załączam przekaźniki a dopiero później puszczam przez nie prąd. I odwrotnie: wyłączam prąd na silniki i dopiero później wyłączam przekaźniki.

    W.P. napisał:
    Zastanawiam się jeszcze nad połączeniem wyjścia wzmacniacza operacyjnego z wejściem (3) IC1. Tu przyznaję nie mam wiedzy.
    Zastanawia mnie jednak jak poradzi sobie IC1 zasilany z napięcia +5V z analizą sygnału górnego nasycenia bądź ogólnie z napięciami powyżej 5V jakie mogą pojawić się na wyjściu wzmacniacza LM358 (zasilanego z +12V).
    Czy ten układ działa w montażu "na pajączka"?

    Ogólnie to znalazłem ten schemat na elektrodzie. Aktualnie nie mam linka, ale załączę wieczorem.
    Wzmacniacz jest zasilany z +5V z tego samego źródła co Atmega. Na wejście wzmacniacza będzie trafiało kilkanaście mV. Nie pamiętam ile już dokładnie otrzymywałem na wyjściu ale to było chyba kilkaset mV. Atmega to wykrywała i reagowała. Testowałem to odwrotnie - zmieniałem napięcie odniesienia. Docelowo napięcie odniesienia będzie stałe, a zmieniać się będzie napięcie na boczniku co jest oczywiste:) Z tego co pamiętam to zabezpieczenie powinno zadziałać gdy na wyjściu wzmacniacza będzie mniej niż 1V. Do ustawienia tego napięcia służy potencjometr R19 podłączony do nóżki procesora AIN1. Po wykryciu przeciążenia nastąpi zatrzymanie silników, a więc i spadek napięcia na wejściu a tym samym wyjściu wzmacniacza. A więc chyba nie ma możliwości, żeby z wzmacniacza poszło więcej na procesor niż napięcie odniesienia? Źle myślę?

    Wspominany link:
    https://www.elektroda.pl/rtvforum/viewtopic.php?t=941772&start=0
  • Poziom 16  
    Poprawiłem schemat, oddzieliłem przekaźnik i trochę zmieniłem masy. Czy teraz jest szansa, że to zadziała?

    Rozdzielenie mas w układzie.
  • Specjalista - zasilacze komputerowe
    dzielik napisał:
    Wzmacniacz jest zasilany z +5V z tego samego źródła co Atmega.
    Przepraszam, nie dopatrzyłem - na schemacie są 3 symbole zasilania. Jest OK.
    Wierzchnie ścieżki (po stronie elementów) wiodące prąd silników (np połączenie źródeł Q3 i Q4) też powinny mieć możliwie dużą szerokość.
  • Poziom 16  
    W.P. napisał:
    Wierzchnie ścieżki (po stronie elementów) wiodące prąd silników (np połączenie źródeł Q3 i Q4) też powinny mieć możliwie dużą szerokość.


    Płytkę robię metodą żelazkową na jednostronnym laminacie. Wierzchnie ścieżki to będą łączenia kablowe o przekroju 1,5mm przy Q3 i Q4 i 1mm przy pozostałych tych niskoprądowych.