Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zasilacz na LM358 napięcie jest zależne od obciążenia

Wikkan 04 Jul 2012 10:28 3322 13
Tespol
  • #1
    Wikkan
    Level 9  
    Witam.

    Od dłuższego czasu męczę się z zasilaczem warsztatowym stabilizowanym wzmacniaczem LM358.
    Zasilacz bardzo dobrze reguluje napięcie i ograniczenie prądowe ale tylko kiedy nie jest obciążony. Podczas nawet niewielkiego obciążenia (0.05 A) napięcie z maksymalnej wartości spada o połowę.
    Przy odłączonym jednym tranzystorze spadek jest mniejszy bo tylko gdzieś koło 6v.

    LM358 wymieniłem na nowy tak samo jak tranzystory TIP142 i źródło prądowe BC557 i nic się nie poprawiło. Przy zwiększaniu wydajności źródła też nie ma większych zmian.

    Schemat zasilacza pochodzi z niemieckiego czasopisma elektronicznego niestety nie posiadam już go (mam tylko schemat zasilacza na PC) i nie pamiętam jego nazwy.

    Bardzo proszę o pomoc bo sam już nie mam pomysłu co jest źle.

    Schemat zasilacza
    Zasilacz na LM358 napięcie jest zależne od obciążenia
    Moduł sterowania
    Zasilacz na LM358 napięcie jest zależne od obciążenia
    Moduł zasilania
    Zasilacz na LM358 napięcie jest zależne od obciążenia
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • Tespol
  • #2
    -RoMan-
    Level 42  
    Obrazek „https://obrazki.elektroda.pl/5507010200_1341390197.jpg” nie może zostać wyświetlony, ponieważ zawiera błędy.
  • #3
    Wikkan
    Level 9  
    Wszystkie zdjęcia otwierają się normalnie bez żadnych problemów.
  • Tespol
  • #4
    Tomasz Gumny
    Level 28  
    Diody D7..9 uniemożliwiają podniesienie potencjału baz tranzystorów Q2,3 powyżej ok. 2V. Zatem jeżeli coś faktycznie pojawia się na wyjściu, to na pewno nie jest to prąd płynący przez te tranzystory.
  • #5
    Wikkan
    Level 9  
    Te diody wyznaczają potencjał o 3 V wyższy niż potencjał masy.
    Co dziwne działanie układu nie zmienia się przy braku tych diod po za zmianą napięcia przy odłączonych tranzystorach.
    Diody są sprawne (sprawdziłem każdą z osobna po wylutowaniu z układu).
    Przez tranzystory płynie prąd.
  • #6
    marekzi
    Level 38  
    Schemat ma chyba błędy.
    nie chce mi się go analizować, bo też i jest narysowany pokrętnie i nieczytelnie, ale zwróćcie uwagę na symbol masy. Jest w trzech miejscach i .... gdzie ona właściwie jest?
    Prawdopodobnie ma być gdzieś jeszcze - ale nie zaznaczono, więc i autor tematu tego nie połączył.
  • #7
    jarek_lnx
    Level 43  
    Quote:
    Diody D7..9 uniemożliwiają podniesienie potencjału baz tranzystorów Q2,3 powyżej ok. 2V.

    To żaden problem. zobacz gdzie jest masa.

    Ja bym zaczął od sprawdzenia czy się nie wzbudza, to bardzo częsta przyczyna problemów "stałoprądowych".

    Coś mi się tu nie podoba - zepsucie sztywności zasilania przy pomocy L3 i L4 - brakuje kondensatorów odsprzęgających przy nóżkach zasilania 358, brak jakiegokolwiek kondensatora na wyjściu? (nietypowe rozwiązanie pogarsza odpowiedź impulsową przy stabilizacji napięcia, może poprawiać przy stabilizacji prądu).

    Z tą masą układów pomocniczych na +wyjścia to wygodne rozwiązanie (sam stosowałem, wiele zasilaczy Meratronika miało) choć przez to tranzystor wyjściowy pracuje w układzie wspólnego emitera, przez co układ może być wolniejszy (odpowiedź impulsowa). A ze stabilnością mogą być problemy typowe dla LDO którym ten układ jest.
  • #8
    Wikkan
    Level 9  
    Tak masy sa w czterech miejscach ale nie jest to moim błędem. Masa w tym układzie jest potencjałem napięcia wyjściowego i punktem odniesienia dla wzmacniacza.
    Układ wzbudzał się przy kondensatorach 100nF filtrujących wyjścia wzmacniacza. Po zmianie na obecne wartości przestał wariować.
  • #9
    jarek_lnx
    Level 43  
    W takim razie sprawdził bym układ wyjściowy, odłączyć stabilizację (wymontować LED'y) powinno się pojawić na wyjściu napięcie maksymalne i pod obciążeniem nie powinno spadać. Jeśli tak będzie to znaczy że wina nie leży po stronie układu wyjściowego.
  • #10
    Wikkan
    Level 9  
    Po odłączeniu U3:A napięcie przyjmuje maksymalną wartość i nie maleje pod obciążeniem.

    Zastanawiam się nad jeszcze jednym.
    Dioda na wyjściu U3:A świeci się non stop. Czyli ograniczenie napięcia działa mimo maksymalnego wychylenia potencjometrów.
  • #11
    jarek_lnx
    Level 43  
    Ten LED powinien świecić dopóki układ nie przejdzie do stabilizacji prądu (zaświeci drugi) albo nie nastawisz wyższego napięcia niż jest na kondensatorze filtru (zgasną oba) - czy masz wystarczający zakres regulacji potencjometrami (do 31,5V) nie wiem (zewrzesz R6 to na pewno wyjdziesz poza zakres) Można by tymczasowo odłączyć organicznie prądowe, przy pozostawionej stabilizacji napięcia, żeby zobaczyć czy nie ma tam jakiejś wady.

    A w sprawie tej stabilności, sprawdzałeś po podłączeniu obciążenia? Czym i gdzie sprawdzałeś czy się nie wzbudza, czy jesteś pewien że nie ma tam żadnych drgań od kHz do MHz, czy sprawdzałeś obydwa wzmacniacze - prądu i napięcia?
  • #12
    Wikkan
    Level 9  
    Odłączenie ograniczenia prądowego nic nie zmienia.

    Aktualnie nie mam przy sobie oscyloskopu więc nie mogę jakoś dokładnie zdiagnozować czy układ się wzbudza. Jak pisałem przy większych pojemnościach C14,15 układ aż piszczał.
    Nie wiem też dlaczego układ posiada pełną regulacje przy obciążeniu jak działa jeden tranzystor TIP142 i dlaczego napięcie przy dwóch tranzystorach stopniowo wzrasta wraz z czasem uruchomienia.
  • #13
    jarek_lnx
    Level 43  
    Zwiększenie C14 i C15 musiało spowodować wzbudzenie, jeśli by się wzbudzał próbował bym zwiększyć C12 i C13.
  • #14
    Wikkan
    Level 9  
    Jeśli mogę prosić moglibyście podać nazwy niemieckich czasopism dla elektroników. Ja nie mogę znaleźć, a teraz bardzo by się przydał oryginalny schemat.
    Z tego co pamiętam te czasopismo było dość grube (jak EP) i do projektów były dołączane klisze do PCB.