Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Relpol
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

BC337 jako przełącznik, obciążenie 12V sygnał 5V

pkordys 14 Lip 2012 17:13 3049 20
  • #1 14 Lip 2012 17:13
    pkordys
    Poziom 12  

    Witam,

    Mam taki kawałek większego układu:
    BC337 jako przełącznik, obciążenie 12V sygnał 5V


    w Yence działa, ale w praktyce jest problem, po odłączeniu zasilania diody słabo ale dalej świecą.

    Może ktoś podrzucić pomysł jak to obejść ?

    Najprościej byłoby użyć przekaźnika 5V i przez niego dać obciążenie ale akurat przekaźnika w tym układzie chciałbym uniknąć.

    0 20
  • Relpol
  • #2 14 Lip 2012 17:18
    1078231
    Użytkownik usunął konto  
  • #3 14 Lip 2012 17:20
    pkordys
    Poziom 12  

    Odejmuję oczywiście 5V, tam gdzie jest przełącznik

    0
  • Relpol
  • #4 14 Lip 2012 17:24
    1078231
    Użytkownik usunął konto  
  • #5 14 Lip 2012 18:29
    pkordys
    Poziom 12  

    Sprawdziłem, dopóki baza wisi w powietrzu a taka sytuację mamy po odłączeniu zasilania NE555, to diody żarzą.

    Dodano po 5 [minuty]:

    Po odłączeniu zasilania na wyjściu NE555 nie ma masy i baza BC337 wisi w powietrzu i tranzystor nie jest zatkany.

    Jakieś pomysły jak zrobić tam masę kiedy nie ma zasilania, żeby tranzystor się zatykał ?

    0
  • #7 14 Lip 2012 19:09
    pkordys
    Poziom 12  

    Dołożyłem drugi rezystor 274Ohm pomiędzy wyjście NE555 a masę, co przy zapalonych diodach zwiększa pobór prądu o 13mA, tak czy inaczej to lepsze rozwiązanie od przekaźnika który weźmie pewnie z 50-60mA.

    Dodano po 7 [minuty]:

    5k nie daje rady "ściągnąć" ale 1k już tak, a to zmienia pobór o 3,5mA, więc nie będę się o nie kopać z układem :-) Problem uznaję za rozwiązany. Jutro zamknę temat ku uciesze moderatorów, jutro, gdyby ktoś chciał jeszcze coś dodać.

    0
  • #8 14 Lip 2012 20:16
    1078231
    Użytkownik usunął konto  
  • #9 14 Lip 2012 20:24
    pkordys
    Poziom 12  

    Próbowałem ale nic nie daje, wstawiałem 274Ohm, 1k, 5k, 10k.

    Dodatkowo to rozwiązanie nie wchodzi w rachubę, całość jest przewidziana do motocykla i jakikolwiek pobór prądu w stanie spoczynku załatwi mi akumulator w noc, tzn tą baterię którą w motocyklu nazywa się akumulatorem :-_

    Pomysł z dodatkowym opornikiem na bazie jest niezły i już myślałem, że tak zostanie ale niestety... okazuje się, że przy zamkniętej krańcówce (i zgaszonych diodach), wyłączenie zasilania układu powoduje chwilowe mrugnięcie diod....

    Tak samo włączenie zasilania na zamkniętej krańcówce również mruga diodami.

    Coś mnie zaraz trafi....

    0
  • #10 14 Lip 2012 20:30
    1078231
    Użytkownik usunął konto  
  • #11 14 Lip 2012 20:32
    pkordys
    Poziom 12  

    Motronic napisał:
    pkordys napisał:
    wstawiałem 274Ohm


    Poważnie?



    Na pół sekundy żeby się nie przegrzał ale próbowałem

    W naturze to jest lampka oparta na diodzie, chyba się takie diody nazywają diodami mocy, może w tym ból...

    0
  • #12 14 Lip 2012 20:34
    1078231
    Użytkownik usunął konto  
  • #13 14 Lip 2012 20:38
    marekzi
    Poziom 38  

    Ten opornik do masy daj z bazy tranzystora, nie z wyjścia 555.
    I wypróbuj różne wartości tego opornika.
    Jeśli to nie pomoże, spróbuj diodę zwykłą krzemową wpiąć szeregowo po oporniku 274, katodą do bazy, za nią ten opornik do masy.

    A w ogóle dlaczego ten opornik 274 ma tak małą wartość? (pomijając to iż jest on z szeregu E48 lub wyższego - po co tu opornik o wąskiej tolerancji?).
    Aby wprowadzić BC337 w nasycenie przy Ic=50mA wystarczy mu podać Ib=3-5mA, co oznacza, że ten opornik może mieć wartość 680ohm-1k, i wtedy łatwiej "ściągnąć" bazę do masy (większym opornikiem).

    0
  • #14 14 Lip 2012 20:40
    pkordys
    Poziom 12  

    z pudełka :-)

    zwykły rezystor

    BC337 jako przełącznik, obciążenie 12V sygnał 5V

    0
  • #15 14 Lip 2012 20:41
    1078231
    Użytkownik usunął konto  
  • #16 14 Lip 2012 20:45
    pkordys
    Poziom 12  

    Motronic napisał:
    O Chrystusie...
    To 270 om o jakiejś tolerancji...


    Z pasków wychodzi 274 om +/- 1%

    0
  • #17 14 Lip 2012 20:45
    1078231
    Użytkownik usunął konto  
  • #18 14 Lip 2012 21:43
    pkordys
    Poziom 12  

    marekzi napisał:
    Ten opornik do masy daj z bazy tranzystora, nie z wyjścia 555.
    I wypróbuj różne wartości tego opornika.
    Jeśli to nie pomoże, spróbuj diodę zwykłą krzemową wpiąć szeregowo po oporniku 274, katodą do bazy, za nią ten opornik do masy.


    zaraz popróbuję i dam znać.


    marekzi napisał:

    A w ogóle dlaczego ten opornik 274 ma tak małą wartość? (pomijając to iż jest on z szeregu E48 lub wyższego - po co tu opornik o wąskiej tolerancji?).
    Aby wprowadzić BC337 w nasycenie przy Ic=50mA wystarczy mu podać Ib=3-5mA, co oznacza, że ten opornik może mieć wartość 680ohm-1k, i wtedy łatwiej "ściągnąć" bazę do masy (większym opornikiem).


    Ano dlatego, że nie mogłem znaleźć ani pół posta o dobieraniu oporników żeby wprowadzić tranzystor w stan nasycenia. Po przewertowaniu elektrody gdzieś ktoś napisał że prąd bazy ma być równy 1/10 prądu kolektora. Więc zakładając nawiększy możliwy prąd kolektora dla BC 337 (w przypadku wymiany lampki) przeliczyłem i wyszło mi 270 om.

    BTW W sklepie gdzie kupuję wszystkie rezystory są 1% towe.

    Dodano po 10 [minuty]:

    marekzi napisał:
    Ten opornik do masy daj z bazy tranzystora, nie z wyjścia 555.
    I wypróbuj różne wartości tego opornika.
    Jeśli to nie pomoże, spróbuj diodę zwykłą krzemową wpiąć szeregowo po oporniku 274, katodą do bazy, za nią ten opornik do masy.


    Efekt taki:
    10k wpięte między bazę a masę - zero efektu, 5k to samo.
    1k wygasza diodę, ale żeby nie było za kolorowo to załączenie zasilania układu, na zamkniętej krańcówce (czyli zgaszonych diodach) powoduje mrugnięcie, co już jest lepiej bo jak był rezystor między wyjściem 555 a masą to wyłączenie zasilania też powodowało mrugnięcie a teraz już nie :-)

    myślę, że problem w tym, że po włączeniu zasilania zanim 555 ustawi masę na wyjściu na ułamek sekundy jest jeszcze +5V

    Dodano po 24 [minuty]:

    konkretnie to +5V pojawia się na wyjściu 555 na 13ms włączeniu zasilania.

    Dodano po 20 [minuty]:

    Próbowałem zmniejszyć kondensator podpięty do 555, licząc, że zniknie mrugnięcie i dam większy opornik żeby uzyskać ten sam czas, ale nic z tego nawet 100nF mimo tego że czas impulsu dodatniego po włącznie zasilania spada o rząd wielkości dioda dalej mruga. Więcej pomysłów nie mam....

    0
  • #19 14 Lip 2012 22:14
    marekzi
    Poziom 38  

    To mrugniecie to efekt stanu nieustalonego.
    Co Ci to przeszkadza? - przecież mrugnie i koniec na tym.
    Nie ma co z tym walczyć, a jeśli koniecznie się zawziąłeś, to próbuj z tą diodą o której pisałem wyżej, ale równolegle do tego opornika z bazy do masy daj elektrolit - próbuj różne pojemności. Taki elektrolit "stłumi" taki pik napięcia, ale też spowoduje opóźnienia przy przełączaniu.
    Można też próbować elektrolit na wyjściu 555 do masy (albo szeregowo z opornikiem). Próbuj - przyczyny tego zjawiska znasz.

    pkordys napisał:

    Ano dlatego, że nie mogłem znaleźć ani pół posta o dobieraniu oporników żeby wprowadzić tranzystor w stan nasycenia. Po przewertowaniu elektrody gdzieś ktoś napisał że prąd bazy ma być równy 1/10 prądu kolektora. Więc zakładając nawiększy możliwy prąd kolektora dla BC 337 (w przypadku wymiany lampki) przeliczyłem i wyszło mi 270 om.

    Nie ma nic na elektrodzie?
    https://www.elektroda.pl/rtvforum/viewtopic.php?t=2331408
    https://www.elektroda.pl/rtvforum/viewtopic.php?t=2252879
    To tylko z ostatniego czasu, i co zapamiętałem.

    0
  • #20 14 Lip 2012 22:28
    pkordys
    Poziom 12  

    Dobre sobie , właśnie o Twój post mi chodziło, znalazłem konkretnie to:

    "Co do sterowania tranzystora...."

    i tym się kierowałem, lampka którą zamierzam wykorzystać w praktyce, (tam gdzie na schemacie są diody) bierze 150mA czyli na bazę muszę dostarczyć 15 mA,
    stąd wynika, że potrzebuję rezystora 330 Om, wziąłem "pierwszy w dół" jaki miałem co oznacza 274 Om

    :-)

    Co do mrugania to właśnie znalazłem rozwiązanie,
    na bazę tranzystora ładującego kondensator dla NE555 dałem 1k co znacznie zmniejszyło czas tego impulsu, a do bazy tranzystopra sterującego ledami dałem 1k do masy, żeby zapenić mu zatkanie przy odłączonym zasilaniu i monolit 470nF też do masy który wytłumia ten "pik"

    0