Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Układ zasilania urządzenia mobilnego z baterii telefonu + ładowarka

Michal_b1 15 Lip 2012 14:49 2687 1
  • #1 15 Lip 2012 14:49
    Michal_b1
    Poziom 18  

    Projektuję urządzenie przenośne składające się m. in. z Atmega8A, karty micro-SD, wyświetlacza z Nokii 3310, DS1820, odbiornika GPS FGPMMOPA6C. Do zasilenia całości potrzebuję napięcia 3,3V a jego źródłem ma być pojedyncza bateria z telefonu Nokia (typ baterii: BL-4C) wraz z odpowiednim układem. Pobór maksymalny prądu będzie wynosił 120mA, średni pobór nie powinien przekroczyć 40mA.

    Zastosowanie regulatora LDO to opcja najtańsza i najprostsza ale słabo wykorzystująca baterię. Zdecydowałem się zastosować przetwornicę typu SEPIC. Zainteresował mnie układ MCP1651 - jest dostępny na tme oraz jego cena jest w miarę normalna.
    1. Czy zastosowanie układu SEPIC zamiast LDO da warte zachodu rezultaty w postaci wydłużenia czasu pracy urządzenia?
    2. Możecie polecić jakieś inne dostępne w Polsce układy tego typu o niewygórowanej cenie?


    W urządzeniu ma być zawarty układ ładowania baterii. Wybór padł na układ MCP73831 - tani, prosty, dostępny na tme.
    3. Możecie polecić jakieś inne dostępne w Polsce układy tego typu w podobnej cenie?
    4. Czy ta bateria posiada zabezpieczenia przed nadmiernym rozładowaniem? Do czego służy 3 styk na tej baterii?

    0 1
  • #2 19 Sie 2012 18:01
    Michal_b1
    Poziom 18  

    Złożyłem układ testowy zawierający oba wspomniane wyżej scalaki. Poniżej schemat i wzór płytki.

    Układ zasilania urządzenia mobilnego z baterii telefonu + ładowarka Układ zasilania urządzenia mobilnego z baterii telefonu + ładowarka

    Układ ładowarki i przetwornicy jest rozdzielony wyjmowaną zworką by można było je testować oddzielnie.

    Ładowarka działa prawidłowo. W czasie pracy układu można było zaobserwować, że MCP73831 najpierw ładuje ogniwo stałym prądem (510mA) a następnie stałym napięciem. MCP73831 poinformował o naładowaniu ogniwa zmianą stanu na nóżce STAT.

    Problem mam z układem przetwornicy. Po podłączeniu napięcia z zasilacza laboratoryjnego uruchamia się w nim zabezpieczenie przeciwzwarciowe a na PCB bardzo grzeją się elementy L1 i Q1. PCB sprawdziłem dwa razy pod względem zwarć pomiędzy ścieżkami lub przerw - nic nie znalazłem. Próbowałem sprawdzić oscyloskopem sygnał na bazie tranzystora i pojawia się tam "coś" o amplitudzie około 50-75mV z czym układ synchronizacji mojego oscyloskopu sobie nie radzi. Proszę o jakieś wskazówki gdzie szukać przyczyn tego, że układ nie działa.

    Kilka słów na temat najważniejszych elementów:
    - kondensatory C5 i C6 to prawdopodobnie ceramiczne x5R lub x7R wylutowane z okolic sekcji zasilania procesora uszkodzonej płyty głównej a następnie sprawdzone miernikiem pojemności,
    - dławiki z TME 3.3uH 2A, nota katalogowa: Link,
    - tranzystor AP9915H również pozyskany z płyty głównej, datasheet: Link,
    - MCP1651 również z TME, datasheet: Link

    EDIT:
    W czasie testów przetwornica była obciążona rezystorem 100 omów.

    0
  Szukaj w 5mln produktów