Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

GSM ZTE 2636 - Moduł GSM ZME2636 - schemat podłączenia

lisek_lichu 19 Jul 2012 23:02 3278 10
IGE-XAO
  • #1
    lisek_lichu
    Level 11  
    Witam,

    projektuję płytkę do sterowania paroma elementami w domu i potrzebuję do tego modułu GSM podpiętego pod mikrokontroler aby sterować wszystkim wiadomościami SMS. Wybrałem moduł ZME2636 dostępny w Maritexie Link

    Czytając notę katalogową zrobiłem schemat ale chciałbym się zapytać o kilka rzeczy:

    1. do czego służy pin [12] BATT_TEMP? Jest to pin analog input a w opisie jest: "Battery ID or battery temperature dettection. Analog input voltage range 0 - 28V" do czego ten pin służy i jak go wykorzystać?

    2. do czego służy pin [2] GATEDRV? w opisie jest: "Battery charge control switch. Valid at low level"

    3 czy pin [31] VDDIO może być wykorzystany do sygnalizacji za pomocą diody czy moduł jest włączony czy nie? W opisie jest:

    "Typical value: 2.85V(MIN:
    2.75V,MAX: 2.95V,MAX
    current: 150mA). There is
    voltage output only as the
    module is powered on. And It
    will be hung out when not
    used."

    4. Moduł będzie miał pracować w dwóch układach:
    1. Moduł GSM i mikrokontroler podłączone do tego samego źródła zasilania (baterii 3.9V)
    2. Moduł GSM będzie zasilany z baterii o napięciu 3.9V natomiast mikrokontroler będzie zasilany bezpośrednio z Zasilacza o napięciu 5V.

    Chodzi mi o to aby umożliwić komunikację UART w tych dwóch sytuacjach. Gdy napięcia sa takie same wystarczy podpiąć pin nadający z pinem odbierającym i na odwrót. Natomiast w przypadku gdy są różne napięcia to gdy mikrokontroler [5V] wysyła jedynkę przez dzielnik napięcia np 1k5 i 4k5 czyli napięcie odbierane przez moduł GSM będzie wynosiło 0.75 * 5V = 3.75V czyli OK natomiast w drugą stronę należałoby podciągnąć jedynkę z GSM o wartości 3.9V do wartości bliskiej napięciu mikrokontrolera [5V] i wykorzystałbym do tego bufor np 74HCT08 (bramka and z drugą nóżką wpiętą do 5V)

    informacje znalazłem na tej stronie:
    Voltage Level Translators

    co o tym sądzicie?

    5. Czy mogę połączyć pin [42] AGND z pinami GND? Czym one się różnią i do czego służy AGND (Analog GND)?

    Załączam mój schemat i prosiłbym osoby obeznane w temacie o ewentualne podpowiedzi co powinienem zmienić lub poprawić.

    Całość jest zasilana ze stabilizowanego zasilacza 5V o wydajności 2A podpiętego do złącza X2 natomiast do złącza X3 podłączona jest bateria od telefonu komórkowego. Przy nóżkach GSM znajdują się dwa kondensatory niskoimpedancyjne o łącznej pojemności 200uF. Złącze X1 służy do komunikacji UART [pin 1 i 2 służą do komunikacji w pracy przy tych samych napięciach natomiast pin 3 obniża napięcie z 5V do 3.75V aby mógł się komunikować z układem zasilanym 3.9V]

    pozdrawiam serdecznie
    lisek
    Kamery 3D Time of Flight - zastosowania w przemyśle. Darmowe szkolenie 16.12.2021r. g. 10.00 Zarejestruj się
  • IGE-XAO
  • #2
    lisek_lichu
    Level 11  
    Witam,

    z tego co wyczytałem to spokojnie mogę podłączyć AGND do GND i wszystko powinno działać poprawnie.

    Czy ktoś mógłby mi pomóc z pozostałymi punktami???

    pozdrawiam
    Szymon
  • IGE-XAO
  • #3
    jacynka84
    Level 26  
    Agnd chyba lepiej lepiej przez kondensator nie wiem jakieś 100n do masy i przez dławik, z 10uH do GND.
    A tak w ogóle to jak się to sprawuje, masz problemy z tym? Chcę kupić i nie wiem jaki wybrać.
    A i jeszcze wyczytałem dziwną rzecz, ten gsm zasilania chce 3.4V min a akceptuje max 3.1V na łączach?? Jak mu dam sygnały na linie np 3.5V to już koniec z nim czy jak?? Idiotyczne by to było.
    Jeszcze podłączanie sima, wprost przez rezystory np 33R starczy czy też trzeba cudować?
    Może te linie kontroli też starczy przez rezystory np 1k? Pozdrawiam.
    Przepraszam za odgrzewanie kotleta.
  • #4
    lisek_lichu
    Level 11  
    Witam,

    zabrałem się ponownie za ten temat. Trochę poczytałem i w końcu stworzyłem płytkę i dałem ją do zrobienia odpowiedniej firmie. Gdy wlutowałem już wszystkie elementy i odpaliłem układ ten cały czas daje sygnał diodą STATUS NET w cyklu 0,9s OFF 0,1s ON co oznacza "no sim card or no PIN entered or searching network". Zastanawiam się co może być nie tak. Sprawdziłem kartę i wszystko jest OK ponieważ na innym module, który robiłem wcześniej śmiga aż miło. Karta jest załadowana, aktywna i nie posiada pinu więc zastanawiam się czemu cały czas mam ten status i nie łączę się z siecią. Dodatkowo wykorzystuję tę samą antenę co w poprzednim układzie.

    w Schemacie opisane jest podłączenie karty SIM z wykorzystaniem kondensatorów 27pF ja użyłem 22pF ponieważ nie miałem 27pF. Mam nadzieję że to nie jest problem.

    Załączam schemat oraz płytkę. Proszę o jakieś rady.
  • #5
    astdar
    Level 10  
    Witaj,

    Czy udało Ci się uruchomić ten moduł?
    Tak naprawdę jest to pytanie, czy warto interesować się tym producentem :D
  • #6
    jacynka84
    Level 26  
    lisek_lichu wrote:
    z wykorzystaniem kondensatorów 27pF ja użyłem 22pF ponieważ nie miałem 27pF. Mam nadzieję że to nie jest problem.

    No właśnie chyba może być, lepiej dać większe niż mniejsze.
    Ponadto wg mnie za mało kondensatorów od baterii, zapewne wiesz że możesz podłączyć bezpośrednio baterię od np nokii, ale dużo filtra, np ze 2000uF łącznie, ale nie chcę cię wprowadzić w błąd, popatrz na wszystko co się da w nocie tego GSM.
    Tak czy tak więcej uF nie zaszkodzi na pewno, a za mało owszem, może ci siadać zasilanie podczas połączenia, taki moduł gsm z tego co wyczytałem doi nawet 0,5A, ale nie wiem czy każdy tak ma.
  • #7
    lisek_lichu
    Level 11  
    Hej,

    moduł odpaliłem i chodzi. Nie wiesza mi się a te dwa kondensatory w zupełności wystarczają przy zasilaniu. Korzystam z baterii jakiejś nokii i wszystko chodzi sprawnie. Jedynym problemem jaki na razie spotkałem to błędny opis sygnalizacji diodami LED ponieważ moduł po podłączeniu daje sygnał LEDami jakby nie miał połączenia z siecią lub błąd z kartą SIM a działa prawidłowo.

    Bardzo słaby a w zasadzie zerowy support ze strony producenta. Zero informacji o tym module, telefony do jakiś krajów które nie wiedzą co to za moduły nikt nic nie wie iu żadnych rzeczowych odpowiedzi.

    pozdrawiam
  • #8
    jacynka84
    Level 26  
    No to ładnie, ale to ZTE, chińszczyzna.
    Jak rozwiązałeś problem?
    Podłączenie jak w ostatnim schemacie działa, czy tak?
    Możesz mierzyć zasięg i jaki prąd pobiera gdy następuje nadawanie?
  • #9
    lisek_lichu
    Level 11  
    Problem rozwiązał się sam. Początkowo jak podałem zasilanie i uruchomiłem moduł to zwóciłem uwagę na diodę LED która mrugała w cyklu sekundowym 10% ON 90% OFF co oznaczało według manuala że moduł ma problem z nawiązaniem połączenia z siecią bądź wystąpił błąd z kartą SIM. Wtedy zacząłem szukać co może być nie tak. Jedna osoba powiedziała mi że to jest ok więc dopiero wtedy podłączyłem RS232 do modułu i zacząłem wysyłac komendy jak się okazało z sukcemem otrzymywałem prawidłowe odpowiedzi.

    Ostatni schemat jest ostateczny. robiłem parę zmian szukając rozwiazania z tą dioda LED ale okazalo się że moduł działa bez żadnych problemów według załaczonego schematu. Nie sprawdzałem jeszcze czy działa podłaczony mikrofon i głośnik ale to raczej bez problemu. Dzowni i wysyła SMS więc jest OK.

    Nie wiem co rozumiesz przezzmierzenie zasięgu? Pomiar poboru prądu mógłbym zmierzyc ale nie mam tak dobrego multimetru żeby mi wskazywał piki prądowe więc raczej lipa.

    pozdrawiam lisek
  • #10
    jacynka84
    Level 26  
    lisek_lichu wrote:
    przezzmierzenie zasięgu?
    Miałem na myśli jaką siłę sygnału masz i czy nie ma z tym modułem problemów dziwnych.
    To miło że działa.
  • #11
    astdar
    Level 10  
    lisek_lichu wrote:
    Hej,
    Bardzo słaby a w zasadzie zerowy support ze strony producenta. Zero informacji o tym module, telefony do jakiś krajów które nie wiedzą co to za moduły nikt nic nie wie iu żadnych rzeczowych odpowiedzi.


    Witaj,
    Dziękuję Ci za info.
    Szkoda że tak to wygląda, bo to oznacza że komercyjne stosowanie tych modułów wiąże się ze sporym ryzykiem.
    Jak rozumiem dystrybutor nie ma wsparcia technicznego?

    Z pozdrowieniami
    md
pcbway logo