Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - porównanie kolumn, dopasowanie wartości

27 Lip 2012 12:22 10651 5
  • Poziom 25  
    Witam,

    Mam pewien problem do rozwiązania i liczę na Waszą pomoc.
    Otóż - mam 4 kolumny (patrz załączony obrazek).
    W kolumnie A mam kod części
    W kolumnie B chciałbym mieć koszt tej części

    Kolumny C i D są jakby wzorem, tzn w kolumnie C jest kod części a w kolumnie D dopasowana cena do tego kodu.

    Wszystko by było proste gdyby kody z kolumny A i C były ułozone w takiej samej kolejnosci...niestety tak nie jest.

    Proszę mi poradzić jak "przepisać" ceny czesci z kolumny D do kolumny B tak zeby przy odpowiednim kodzie czesci byla odpowiednia cena

    Proszę o wskazówki Excel - porównanie kolumn, dopasowanie wartości
  • Poziom 40  
    w B2 wpisz
    =WYSZUKAJ.PIONOWO(A2;C: D;2;0)
    i skopiuj w dół
  • Poziom 25  
    nic z tego
    Pokazuje mi się tylko napis "NAZWA?"
  • Poziom 40  
    Daniel_GSM napisał:
    nic z tego
    Pokazuje mi się tylko napis "NAZWA?"


    Niemożliwe.

    Taki błąd świadczy o literówce w nazwie funkcji.
    Sprawdź albo skopiuj z poniżej i wklej do excela

    Code:
    =WYSZUKAJ.PIONOWO(A2;C:D;2;0)
  • Poziom 13  
    Proponuje takie makro
    odpal Alt+F11
    w oknie VBAProject wybierz arkusz na którym pracujesz i wklej poniższy kod

    Public Sub znajdz()
    Dim i As Integer
    Dim j As Integer

    For i = 2 To Cells(Rows.Count, 1).End(xlUp).Row
    For j = 2 To Cells(Rows.Count, 3).End(xlUp).Row
    If Cells(i, 1) = Cells(j, 3) Then

    Cells(i, 2) = Cells(j, 4)

    End If
    Next j
    Next i
    End Sub


    a następnie stań kursorem w ciele procedury i odpal procedure klawiszem F5