Elektroda.pl
Elektroda.pl
X
Elektroda.pl
e-miernikie-mierniki
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wzmacniacz pod klawisz - zrób to sam

irek81 03 Wrz 2012 16:08 7804 54
  • #31
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • e-miernikie-mierniki
  • #32
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #33
    irek81
    Poziom 13  
    Wzmacniacz uruchomiony. Sprawdziłem go jeszcze raz (połączenia i luty i wartości elementów) i było wszystko ok. Przy pierwszym włączeniu wywaliło mi oba bezpieczniki ale okazało się że to tylko prąd ładowania kondensatorów (bo zamiast 4700uF użyłem 10000uF i trafo mam 2x2,85A) więc większe bezpieczniki załatwiły sprawę. Odpalałem to na głośniczku 8 ohm za 8zł. Po wstępnych oględzinach i sprawdzeniu napięcia na wyjściu podpiąłem sygnał. Wszystko działa poprawnie. Jeszcze nie miałem okazji zagrzać tranzystorów, bo wczoraj już było późno. Dość grzeją się te dwa rezystory w zasilaniu (co o nie pytałem wyżej) do przedwzmacniacza +/-15V (680om) nie wiem czy to prawidłowe ale póki co to nie zajmowałem się tym.Teraz czas na projekt układu przedwzmacniacza.
  • #34
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #35
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • e-miernikie-mierniki
  • #36
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #37
    irek81
    Poziom 13  
    Nie wiem co zrobić z tymi rezystorami - dość mocno się grzeją. Tak po 2 minutach ciężko utrzymać na nim palec przez 3s. Co prawda jeszcze nie obciążyłem tego wszystkiego. Na dodatek napięcia zasilające nie są identyczne. Na plusie jest 16,8 a na minusie 17,2. Nie bardzo się to nadaje do zasilania wzmacniaczy operacyjnych (Diody zenera teoretycznie są 15V a jest 17.
    Mam jeszcze drugą opcję. Udało mi się wybadać na uzwojeniu trafo napięcie 2x19V względem masy tej samej co do zasilania wzmacniacza. W rzeczywistości jest jedno 18,8 drugie 19,7V ale jakby to wyprostować i podać przez LM7815 i LM7915 to myślę że by było lepiej niż przez te dwa rezystory.
    Nie wiem dlaczego tak bardzo grzeją się te dwa rezystory. Wiem, że do stracenia mam dość dużo voltów. W oryginalnym schemacie z trafo po wyprostowaniu i po kondensatorach podają na schemacie napięcie 2x48V. Ja u siebie mam 2x51,5V. Czyli 3,5V więcej. Nie wiem czy w takim wypadku te dwa rezystory mają dobre wartości. Ten układ będzie mi dość rozgrzewał wszystko wokoło (łącznie z płytką i ścieżkami). Co robić? Może jest jeszcze jakaś opcja na zrobienie +/-15V bez dodatkowego trafo i bez przesadnego nagrzewania elementów. Póki co to opcja z wykonaniem dodatkowych odczepów z trafo wydaje mi się najlepsza.
  • #38
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #39
    irek81
    Poziom 13  
    dj-MatyAS napisał:
    Bo tak jest. O ile uda się znaleźć punkt łączący masę, który nie wprowadzałby pętli.

    Masa będzie ta sama co do do wzmacniacza i nie będę ciągnął dodatkowego przewodu od trafo do zasilania przedwzmacniacza, tylko wykorzystam to podłączenie co jest już na wzmacniaczu. Po prostu w tym uzwojeniu co jest dorobię jeszcze dwa odczepy. Udało mi się zlokalizować takie miejsce na uzwojeniu 2x19V. Nie powinny się pojawić pętle masy. Masa będzie jedna, łączona tylko w jednym miejscu.

    dj-MatyAS napisał:
    To może wskazywać na zbyt duży prąd płynący przez diody zenera - nie grzeją się zbyt?

    Grzeją się, a czy bardzo to sprawdzę dzisiaj.

    dj-MatyAS napisał:
    Bo prócz "woltów" jest też i prąd. W tym wypadku należałoby sprawdzić czy nie za duży - ale to ze względu na podwyższone napięcie z zenerek, a nie grzanie się samych rezystorów szeregowych - te właśnie po to są, by się grzać...


    Czyli podwyższone napięcie z zenerek może być efektem zbyt wysokiego napięcia z trafo?
    Dziś sprawdzę prąd jaki płynie przez rezystor. Pytanie: Czy w tym przypadku pomogła by zmiana rezystorów na inną wartość (z racji tego podwyższonego napięcia)?

    Po odłączeniu diod zenera napięcie wynosi +/- 51V. Nie płynie prąd więc nie ma spadku napięcia na rezystorach (dobrze myślę?). Trzymanie stałego napięcia 15V to zadanie dla tych 2 zenerek? Nadmiar napięcia diody zwierają do masy - o to tu chodzi? Jeżeli dobrze myślę to wartość rezystorów ma wpływ na wartość prądu pobieranego z tego źródła? Idąc tym tokiem myślenia to jeżeli podłączę tu kilkanaście wzmacniaczy operacyjnych to nie powinno pogorszyć warunków pracy tych rezystorów?

    Z góry przepraszam za dziwne pytania.
  • #40
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #41
    irek81
    Poziom 13  
    Na rezystorze występuje napięcie 36V. Ze wzoru prąd przy rezystancji 680om i napięciu na rezystorze 36V wychodzi prąd 0,052A. Ze wzoru na moc wychodzi że na rezystorze wydziela się 1,9W mocy strat. Ten rezystor powinien spokojnie wytrzymać drugie tyle. Mierzyłem też prąd płynący przez rezystor i miernik pokazywał 5,2A (to jest niemożliwe). Sprawdzę to dziś jeszcze raz. Na diodzie mierzyłem napięcie i jest 16V. 36+16=napięcie zasilające.
  • #43
    irek81
    Poziom 13  
    adambyw napisał:
    Nieśmiało pozwolę się spytać o nastawę zakresu pomiarowego miernika. Wartość podobna, tylko rząd wielkości nie ten.


    Też to zauważyłem wcześniej ale miernik był nastawiony na zakres 20A. Sprawdzę to dziś jeszcze raz.
  • #44
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #45
    irek81
    Poziom 13  
    przemak napisał:
    Chyba, że amperomierz był podłączony równolegle do opornika a nie szeregowo z nim

    Aż takim lamerem to nie jestem.

    Jako, że będę zabierał się za przedwzmacniacz, jakie powinno być wzmocnienie master volume aby poziom głośności był dobry do tego wzmacniacza. Praktyczny elektronik w mikserze na kanale master podaje wzmocnienie +6 dbl. Czy jest ok?
  • #46
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #47
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #48
    irek81
    Poziom 13  
    Prąd płynący przez rezystor to 53mA. Zmierzyłem to.

    Mam jeszcze inny pomysł. Gdyby z trafo dać te 2x19v (co udało mi się zlokalizować na uzwojeniu) na mostek i kondensatory 6800uF, potem dać na te rezystory 680om (chociaż w tym przypadku nie wiem czy były by potrzebne - te diody zenera dałyby chyba radę bez nich). Po mostku i wyprostowaniu było by ok 25V. Wyszedł by spadek 10V na tych rezystorach i puścić to na te diody zenera. Stabilizacja była by chyba wystarczająca. Przy spadku napięcia 10V moc strat na tym rezystorze wyniosłaby 0,14W - a to już nie jest 1,9W. Tylko czy to prądowo później da radę zasilić 20 wzmacniaczy operacyjnych?
  • #49
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #50
    pinkin
    Poziom 18  
    [...] 2*19V. Te uzwojenia są prawdopodobnie specjalnie do zasilania przedwzmacniacza i podobnych działań operacyjnych.

    Mam pytanie z innej beczki. Jak już uruchomisz końcówkę na 100% jestem ciekaw czy słychać "trzask", czy tam "strzał" przy włączeniu lub wyłączeniu. A właściwie to interesuje mnie to, czy jest przy wyłączeniu.


    Lenistwo, czy nabijanie postów?
    To co piszesz jest szczegółowo wyjaśnione w temacie.
    3.1.11. Publikowanie wpisów nie zawierających merytorycznej treści, zawierających szkodliwe porady, porady nie będące próbą rozwiązania problemu oraz publikowanie identycznych wpisów następujących po sobie lub powtarzających informacje ujęte w toku dyskusji.
    (dj-MatyAS)


    Po pierwsze na pewno to nie zostało szczegółowo wyjaśnione. Zastanawiałem się np jak jest realizowane otwarcie tranzystora T11, skoro do bramki nie trafia dodatni potencjał? (C91 na schemacie ma +zwarty do masy)
    Nieistotne. W takiej jednej mojej końcówce słychać niegroźny strzał przy wyłączaniu, nawet gdy ma wejście zwarte do masy. Stąd moje pytanie do autora.
    Lenistwem jest to że nie chciało mi się samemu wykonać tej końcówki, a zamiast tego zadałem pytanie koledze, który juz to wykonał. Dopisuję w tym samym, żeby nie było, że klikam posty.
  • #51
    irek81
    Poziom 13  
    pinkin napisał:
    [...] 2*19V. Te uzwojenia są prawdopodobnie specjalnie do zasilania przedwzmacniacza i podobnych działań operacyjnych.


    Nie. To trafo ma tylko 2x35V i nie ma innych odczepów. Te 2x19V udało mi się znaleźć przez delikatne obskrobanie izolacji na uzwojeniu. Wystarczy teraz przylutować odczepy i będzie 2x19V ze wspólną masą co we wzmacniaczu.

    pinkin napisał:
    Mam pytanie z innej beczki. Jak już uruchomisz końcówkę na 100% jestem ciekaw czy słychać "trzask", czy tam "strzał" przy włączeniu lub wyłączeniu. A właściwie to interesuje mnie to, czy jest przy wyłączeniu.


    Nie słychać trzasków przy włączaniu i wyłączaniu. Końcówka załącza się bardzo delikatnie. Uruchamiałem ją na głośniczku o mocy 6 W. Kondensatory 2x10000uF. Przy włączaniu nawet nie wiadomo kiedy wzmacniacz zostaje załączony. Przy wyłączaniu (po wyciągnięciu wtyczki z gniazdka) wzmacniacz się wycisza (ale nadal jeszcze gra) potem wycisza się całkiem do zera.

    W obecnej chwili nie odzywam się bo pracuję nad przedwzmacniaczem i torem sumy z zasilaniem do nich. Prace w toku - w eaglu.
  • #52
    irek81
    Poziom 13  
    Panel przedwzmacniacza zrobiony i przetestowany. Działa.
    Schemat zamieszczam poniżej - to jest wycinek schematu z praktycznego elektronika, plik nazywa się: schemat_przedwzmacniacz_panel.jpg

    W torze sumy mam miejsce, żeby zrobić jeszcze jedno wejście - bez regulacji barwy dźwięku, tylko z regulacją głośności (potem sygnał trafia na sumę). Chodzi mi o takie wejście liniowo/mikrofonowe. Nie wiem jak to zrobić.
    Czy mogę zrobić to wg tego schematu co zamieściłem (pomijając układ regulacji barwy), a regulację głośności realizować tylko potencjometrem GAIN? Wtedy nie dawałbym potencjometru level. Schemat który sam zmodyfikowałem zamieszczam poniżej. Plik schemat_kanal_prosty.jpg.

    Czy wartości elementów R40 i za nim 22k (do masy), a po nim znów 1k - czy to ma sens? Z góry dzięki za pomoc.
  • #53
    pinkin
    Poziom 18  
    Pytanie do czego byś potrzebował ten dodatkowy kanał? Jeżeli pozostaje to pod wielkim znakiem zapytania, to faktycznie zostawić gain. Ja bym się pokusił o zrobienie stałego wzmocnienia i zamiast gaina ustawić zwykły dzielnik napięcia, który by szedł na sumę. Tak jak piszesz, że chcesz realizować regulację głośności, a gain realizuje wzmocnienie, które się dostosowuje do różnych urządzeń. Przynajmniej ja to tak leniwie rozumiem i byłoby to dla mnei bardziej komfortowe. Pytanie również co u Ciebie jest sumą. Po prostu potencjometr, czy jest przed lub za jakiś wzmacniacz, jakiej wartości jest potencjometr... itp, wszystko do obliczenia.

    Cytat:
    Czy wartości elemetów R40 i za nim 22k do masy, a po nim znów 1k - czy to ma sens?

    Ja to rozumiem inaczej. Dzielnik złożony z R40 i R17, z którego wychodzi kolejny dzielnik z R41 i R42, a po drodze C27 i preamp.

    W ogóle wywaliłbym cały układ, który jest za R19 i R20. US2B bym przerobił na odpowiedni wzmacniacz(z odpowiadającym Tobie wzmocnieniem), wyjście którego wpadało by przez potencjometr do masy, a regulator z potencjometru do R44 i do sumy. Oczywiście to wszystko pisze opierając się tylko na tym urywku schematu, który podałeś.
  • #54
    irek81
    Poziom 13  
    pinkin napisał:
    Pytanie również co u Ciebie jest sumą. Po prostu potencjometr, czy jest przed lub za jakiś wzmacniacz


    Suma u mnie to kolejny układ wzmacniający. Postaram się zamieścić schemat.

    pinkin napisał:
    W ogóle wywaliłbym cały układ, który jest za R19 i R20. US2B bym przerobił na odpowiedni wzmacniacz(z odpowiadającym Tobie wzmocnieniem), wyjście którego wpadało by przez potencjometr do masy, a regulator z potencjometru do R44 i do sumy. Oczywiście to wszystko pisze opierając się tylko na tym urywku schematu, który podałeś.


    Zamiast potencjometru gain wstawiłbym rezystor (lub PR-ka), którego wartość mógłbym dostosować - w zależności od potrzeby. Regulację głośności zrobiłbym tak jak piszesz - zastanawiałem się nad tym.
    To wejście byłoby wejściem dodatkowym w razie podpięcia np. sygnału z mp-trójki lub innego źródła liniowego (do wejścia line in), a mikrofonu (do wejścia mic in)
  • #55
    pinkin
    Poziom 18  
    irek81 napisał:
    Zamiast potencjometru gain wstawiłbym rezystor (lub PR-ka), którego wartość mógłbym dostosować - w zależności od potrzeby.


    irek81 Miałem na myśli miejsce wcześniej niż PR gain. :arrow: Od wejścia liniowego do miejsca oznaczonego "do sumy" sygnał jest odwracany tylko raz. Dlatego wzmacniacz operacyjny oznaczony US2B przerabiasz na odwracający i z odpowiednim wzmocnieniem. Czyli nóżkę 5 podpinasz do masy, a nóżkę 6 jako wejście(węzeł C9 i R17). Dodatkowo między nóżki 6 i 7 dajesz rezystor lub PR-ka, tak jak piszesz, żeby dostosować wzmocnienie. Reszta zależy od schematu sumy.