Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Odtwarzacz Blu-Ray LG BD550 - nie przyjmuje komend wysyłanych przez RS232

rafalrrrr 31 Lip 2012 16:46 2423 5
  • #1 31 Lip 2012 16:46
    rafalrrrr
    Poziom 12  

    Witam,

    Mam problem, chcę odblokować w odtwarzaczu You Tube, Accu Weather i Picassa [NETCAST]. I tutaj pojawia sie problem - wysyłam polecenia według przepisu ze strony: http://www.lg-hack.info/cgi-bin/sn_forumr.cgi?fid=2679&cid=2675&tid=3705&pg=1&sc=20 ...i nic się nie dzieje. Odtwarzacz nie reaguje na żadne komendy (w terminalu nie pojawiają się żadne odpowiedzi ze strony odtwarzacza na te komendy pojawia się natomiast bootlog). Wypróbowałem wiele terminali (Hercules, PuTTY, Hyper Terminal oraz Access Port) i w każdym jest tak samo, czyli brak odpowiedzi ze strony odtwarzacza. Co do konwertera RS232-TTL to jest on zbudowany na 2 tranzystorach i paru opornikach i jest on w 100% sprawny gdyż testowałem go programem "RS232 Tester" użytkownika "Mirley". Czy to może być wina odtwarzacza, że port RS232 został zablokowany przez soft ? Albo do wysyłania komend odtwarzaczowi potrzebny jest inny typ programu ?

    Proszę o pomoc w nakierowaniu mnie na rozwiązanie tego problemu.

    Pozdrawiam rafalrrrr

    0 5
  • #2 01 Sie 2012 14:14
    rafalrrrr
    Poziom 12  

    Naprawdę nikt nie wie jak to rozwikłać ????

    0
  • #3 17 Wrz 2012 14:53
    toriman
    Poziom 14  

    Witaj!

    Przede wszystkim konwerter powinien być na poziomy 3,3V. Możliwe, że software ma już w tej wersji zablokowaną możliwość dostania się do roota.

    Zamieniałeś linie RxD z TxD?

    pozdrawiam

    0
  • #4 02 Paź 2012 16:37
    rafalrrrr
    Poziom 12  

    Tak zamieniłem i wtedy nic się nie pokazuje ;/

    0
  • #5 03 Paź 2012 08:48
    toriman
    Poziom 14  

    być może downgrade firmware mógłby pomóc - w moim BD560 od wersji 334.C zablokowali dostęp do debug menu. Być może u Ciebie też coś zostało zablokowane choć raczej mi to wygląda na problem z konwerterem.

    gdy połączysz TxD z RxD i piszesz coś w ekranie np. PuTTy pojawia się tekst? W pętli powinien sie pojawiać jako echo.

    pozdrawiam

    P.S. zajdż na stronkę http://hackbd560.000space.com/ i tam znajdziesz [hardware] też schemat solidnego konwertera na max3222 do wykorzystania uwzględniając różnice pomiędzy BD560 a BD550 (bd550 ma prostszy port konsoli)

    0
  • #6 04 Lis 2012 17:12
    rafalrrrr
    Poziom 12  

    toriman napisał:
    być może downgrade firmware mógłby pomóc - w moim BD560 od wersji 334.C zablokowali dostęp do debug menu. Być może u Ciebie też coś zostało zablokowane choć raczej mi to wygląda na problem z konwerterem.

    gdy połączysz TxD z RxD i piszesz coś w ekranie np. PuTTy pojawia się tekst? W pętli powinien sie pojawiać jako echo.

    pozdrawiam

    P.S. zajdż na stronkę http://hackbd560.000space.com/ i tam znajdziesz [hardware] też schemat solidnego konwertera na max3222 do wykorzystania uwzględniając różnice pomiędzy BD560 a BD550 (bd550 ma prostszy port konsoli)


    Jak zewrę TxD i RxD konwertera to w programie tester RS232 jest uznany za sprawny gdyż echo funkcjonuje poprawnie.
    Może faktycznie jest to wina konwertera, muszę się tym kiedyś zająć.

    0