Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Driver + MOSFET kluczujący LED - po wyłączeniu układu napięcie ujemne na LED

06 Sie 2012 01:30 3732 4
  • Poziom 22  
    Witam, zbudowałem niewielki układ z użyciem mikrokontrolera, który sygnałem PWM za pomocą MOSFETa ma sterować diodami LED 12V. Szukałem informacji na ten temat, ale nigdzie nie znalazłem żadnej satysfakcjonującej mnie odpowiedzi.

    Driver + MOSFET kluczujący LED - po wyłączeniu układu napięcie ujemne na LED

    Powyższy schemat przestawia układ jaki wykonałem. Układ działa w sposób następujący (może nie konkretnie sam układ, ale cały sterownik z zasilaczem):
    - w punkcie "+5V" jest cały czas napięcie +5V, nie ważne czy urządzenie jest wyłączone czy włączone (zasilanie standby)
    - w punkcie "+12V" napięcie +12V pojawia się po załączeniu zasilacza przez mikrokontroler, który w tym samym momencie zaczyna "nadawać" sygnał PWM, do tego momentu wszystko jest OK, diody LED ładnie świecą, dostają napięcie +12V, bez problemu można sterować ich jasnością
    - po wyłączeniu zasilacza oczywiście znika napięcie +12V, napięcie +5V, jak wcześniej wspomniałem, zostaje, lecz na wyjściu LED_OUT pojawia się napięcie ujemne -2V lub troszkę "mniej", np. -1,6V itp.

    Nie wiem czym to jest spowodowane i skąd to napięcie się tam bierze, boję się trochę o LEDy. Czy to ma jakiś związek z diodą wewnątrz MOSFETa i czy układ powinien w ogóle tak działać?

    Dodam, że nawet po odłączeniu zasilania +5V układ generuje to napięcie, które w dodatku skacze w granicach około 1V.
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 28  
    Moim zdaniem szukasz dziury w całym...
  • Poziom 42  
    Diody LED działają również jako fotoogniwa, generując SEM...
  • Poziom 22  
    Chciałem się tylko dowiedzieć, czy tak powinno być, czy może układ nie działa poprawnie.
    To nie jest wina diod, ponieważ odłączenie ich od układu nie ma żadnego wpływu na to napięcie.
    Wydaje mi się, że MOSFET "zbiera coś" z otoczenia. Po odłączeniu masy od układu napięcie spada do zera, natomiast gdy dotknę palcem radiatora (malutki, odizolowany od tranzystora) napięcie zwiększa się do ponad -2,5V. Nie wiem czy tak zachowują się tranzystory polowe, może mój jest uszkodzony.
  • Poziom 42  
    W strukturze tranzystora polowego znajduje się dioda pomiędzy S a D spolaryzowana zaporowo. Jak dotykasz palcem, to działasz jako antena a tranzystor jak dioda detekcyjna.