Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - porównywanie zawartości kolumn zawierających tekst i spacje

skubi2004 22 Sie 2012 16:33 9732 2
  • #1 22 Sie 2012 16:33
    skubi2004
    Poziom 15  

    Witam.
    Szukam sposobu na porównanie zawartości dwóch kolumn w excellu 2007
    Mam dwie kolumny w których znajdują się adresy w formacie
    Przykład
    Kolumna A Kolumna B
    ul.Kaliska 2b 2 ul.Kościuszki 1 2
    ul.Kościuszki 1 2 ul.Kowalskiego 2
    I tak kilka tysięcy wierszy

    Szukam sposobu na porównanie zawartości tych kolumn tzn. Szukam powtarzających się adresów czyli jeśli adres z kolumny A istnieje w którymkolwiek wierszu w kolumnie B to w Kolumnie C napisz istnieje duplikat

    Zrobiłem to w ten sposób
    =JEŻELI(LICZ.JEŻELI($A$2:$A$7900;B2)=1;"istnieje duplikat";"")

    Niestety wynik jest niepoprawny tzn nie powtarzalny raz pokazuje że jest duplikat choć go nie ma lub nie pokazuje że istnieje duplikat a w rzeczywistości jest.
    Dla niektórych wierszy pokazuje poprawnie

    Czy znacie jakiś sposób na porównanie dwóch kolumn zawierających tekst i spacje
    Chodzi o to żeby dla każdej komórki A sprawdzał wszystkie komórki B i wpisał w komórkę C czy istnieje duplikat

    0 2
  • Pomocny post
    #2 22 Sie 2012 17:51
    adamas_nt
    Moderator Programowanie

    Najlepiej, gdybyś wrzucił przykład w postaci pliku.

    1. Trzeba założyć, że duplikatów może być więcej niż jeden, dlatego
    =JEŻELI(LICZ.JEŻELI($A$2:$A$7900;B2)>0;"istnieje duplikat";"")

    2. Najczęściej problemy powodują spacje wiodące i -trudniejsze do zauważenia- końcowe. Musiałbyś się ich pozbyć Np przepisując kolumnę A do innej, Np F, funkcją 'USUŃ.ZBĘDNE.ODSTĘPY(A2) skopiowaną w dół. Formuła w postaci:

    Code:
    =JEŻELI(LICZ.JEŻELI($F$2:$F$7900;USUŃ.ZBĘDNE.ODSTĘPY(B2))>0;"istnieje duplikat";"")

    powinna dawać prawidłowe wyniki.

    0
  • #3 23 Sie 2012 14:01
    skubi2004
    Poziom 15  

    Witam.
    Dziękuje bardzo za wskazówki
    zadziałało z funkcją
    =JEŻELI(LICZ.JEŻELI($A$3:$A$7900;B2)>=1;"istnieje duplikat";"")
    ale dopiero po pozbyciu się spacji
    Dziękuję i pozdrawiam

    0