Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Długi kabel od drukarki, zanik sygnału, jak go wzmocnić??

sledzik10 28 Aug 2012 23:57 5112 22
  • #1
    sledzik10
    Level 10  
    Witam, problem jest taki, że kabel do łączący router i drukarkę ma 4,5 metra. Nie może być krótszy. A, że jest podłączony pod usb... to wiadomo opór robi swoje i drukarka często jest niedostępna... albo po prostu nie drukuje bo sygnał jest za słaby. Chciałem się zapytać jak poradzić sobie z tym problemem. Myślałem o tym aby podpiąć na końcu kabla jakiś zasilacz, który wzmocni z powrotem napięcie do 5V. Ale czy takiego coś będzie działać? I jeśli tak to, czy trudno jest zrobić takie urządzenie? A może dostanę coś takiego w sklepie?

    PS. Sorry, że w tym dziale ale nie mam punktów, a to pilne. Bardzo byłbym wdzięczny jeśli ktoś przeniósłby ten temat do właściwego działu.
    Z góry dziękuję.
  • #2
    McMonster
    Level 32  
    W połowie drogi podłączyć hub USB z własnym zasilaniem. Najprostsze rozwiązanie. Ewentualnie zainwestować w drukarkę sieciową.
  • #3
    sledzik10
    Level 10  
    Drukarka sieciowa nie wchodzi w grę. Musi być ta co jest.
    A czy dostanę huba na wejście USB typu B ?
  • #4
    McMonster
    Level 32  
    Dlaczego na B? Podłączasz hub do komputera i drukarkę jej normalnym kablem do huba.
  • #5
    sledzik10
    Level 10  
    Trochę dokładniej przedstawię problem bo widzę, że jest trochę niejasności.
    Z routera wychodzi kabel USB 4,5m... przechodzi przez strop itd. przy jego zakładaniu było sporo problemów dlatego najlepiej jeśli teraz nie będę go ruszać... Na końcu tego kabla jest już zbyt słabe napięcie i właśnie tam chciałem podłączyć go do huba gdzie napięcie zwiększy się z powrotem do 5V ale kabel ma zakończeniu USB typ B. I wtedy do huba podłączyć drugi (krótszy) kabel USB, końcówką A a do drukarki B i by śmigało...
    A gdybym podłączył huba do routera to przecież napięcie z niego i tak by spadło bo musiałoby iść przez cały 4,5 metrowy kabel... (bo powtarzam, nie mogę go ruszyć :/ ).
  • #6
    manekinen
    Level 29  
    Czy jest to oryginalny przewód który był załączony wraz z drukarką, lub przewód dobry jakościowo? Specyfikacja USB 2.0 przewiduje długość do 5m i nie powinno być problemów (raz 10m się podłączało i nie było problemów).

    Jesteś pewien że chodzi o spadek napięcia 5V - mierzyłeś? Jaka jest wydajność prądowa wyjść w routerze? Przecież drukarka ma własne zasilanie i nie powinna ciągnąć aż tyle z USB. Jeśli ten przewód to jakiś chińczyk z allegro to możliwe że daje się we znaki słaba jakość wykonania, kiepskie ekranowanie (lub brak), i jeśli urządzenia ledwie się ze sobą komunikują z powodu błędów, to podejrzewam że hub niewiele pomoże (dostanie sygnał takiej samej jakości).
  • #7
    bestboy21
    Level 39  
    Kupujesz aktywnego huba i po problemie. Za to dojdzie dodatkowy problem doprowadzenia 230V dla zasilacza huba.
    USB-B możesz obciąć i przylutować prosto do huba po obcięciu USB-A.
  • #8
    sledzik10
    Level 10  
    Gdy kupowałem kabel w sklepie koleś mówił, że taki długi kabel może nie działać bo kiedyś niby sam mierzył napięci i było 3V na 5 metrowym... wiec też nie sprawdzałem i myślałem, że to ten problem... ale dla pewności sprawdziłem teraz i muszę wam powiedzieć, że jestem zaskoczony i jeszcze bardziej wkurzony... na wyjściu w routerze jest 5.32V a na końcu kabla 4,5m jest 5.22V... wiec musi być inny problem. Ale jaki? Powiem tyle, że czasami uda się wydrukować coś.. ale jak już to tylko za pomocą Worda i raczej rzadko... Koleś w sklepie mówił że niby kabel jest dobrej jakości.. mam opakowanie i jest napisane na nim tak: GEMBIRD USB cables CCP-USB2-AMBM-15. A czy problemem może być to, że np. kabel jest za mocno zgięty lub przyciśnięty i wtedy sygnał dochodzi do drukarki z błędem?
    A kabel nie jest oryginalny, tamten miał chyba 1,5m albo 1,8m.
  • #9
    bestboy21
    Level 39  
    Koleś pieprzy jak potłuczony a ty go słuchasz, nie chodzi o napięcie (i nie możliwe żeby spadło o 2V na 5m odcinku - SAM SIĘ PRZEKONAŁEŚ że w cale nie spadło) , chodzi o impedancje falową , pojemność własną i szum na żyłach D+ D- . Dodatkowo na żyłach D+ i D- napięcie wynosi mniej jak 1V dlatego tak łatwo zakłócić transmisję.
  • #10
    sledzik10
    Level 10  
    Więc co mogę zrobić aby transmisja nie była zakłócona? aaa.. no i kabel nie idzie samotnie.. obok jest jeszcze UTP kat. 5e. Właściwie to się stykają... czy to może być problemem?
  • #11
    bestboy21
    Level 39  
    sledzik10 wrote:
    Więc co mogę zrobić aby transmisja nie była zakłócona? aaa.. no i kabel nie idzie samotnie.. obok jest jeszcze UTP kat. 5e. Właściwie to się stykają... czy to może być problemem?


    To nie może być problemem bo jest inna częstotliwość, ale jakiś minimalny wpływ zawsze ma.
    Musisz kupić aktywnego huba. Wtyczki to nie problem , możesz sobie polutować a kolory kabli w 95% są standardowe (czerwony , czarny, biały , zielony)
  • #12
    sledzik10
    Level 10  
    Jeśli dam tego huba tak jak pisałem wyżej... na końcu kabla to będzie ok?
  • #13
    bestboy21
    Level 39  
    sledzik10 wrote:
    Jeśli dam tego huba tak jak pisałem wyżej... na końcu kabla to będzie ok?


    Musi. Być może wystarczy podłączenie przy samym routerze bo sygnał z huba będzie "ciut" mocniejszy i obejdzie się bez problemu z zasilaniem i wtyczkami.
  • #14
    sledzik10
    Level 10  
    I odciąć końcówkę B z tego długiego i zastąpić ją A? Przez takie coś nie zwiększę zakłócenia na żyłach D+ D- ???
  • #15
    bestboy21
    Level 39  
    sledzik10 wrote:
    I odciąć końcówkę B z tego długiego i zastąpić ją A? Przez takie coś nie zwiększę zakłócenia na żyłach D+ D- ???


    Na początek podłączył bym hub do routera a kabel do huba, jeśli to nic nie da to na końcu kabla uciąć i polutować, bez zabawy we wtyczki i drukarkę zwykłym 1,5m kablem do huba.
  • #16
    sledzik10
    Level 10  
    No właśnie chciałem potem ten oryginalny wykorzystać... tak jak piszesz dać ten 1,5m. A jakiego huba niedrogiego polecasz, albo z jakiej firmy są w miarę dobre?
  • #17
    bestboy21
    Level 39  
    sledzik10 wrote:
    No właśnie chciałem potem ten oryginalny wykorzystać... tak jak piszesz dać ten 1,5m. A jakiego huba niedrogiego polecasz, albo z jakiej firmy są w miarę dobre?


    Wszystko to jedno i to samo , ważne by był aktywny.
  • #18
    sledzik10
    Level 10  
    Ok, dzięki za pomoc. Za kilka dni napiszę czy wszystko gra.
  • #19
    bestboy21
    Level 39  
    Pozostaje zagadka czy router rozpozna hub chociaż to jest wpisane w specyfikację USB ;)
  • #20
    sledzik10
    Level 10  
    Router jest od TP czyli Livebox 2.0
  • #21
    bestboy21
    Level 39  
    sledzik10 wrote:
    Router jest od TP czyli Livebox 2.0


    Powinno chodzić bo USB jest sprzętowe w LB2.0
  • #22
    manekinen
    Level 29  
    sledzik10 wrote:
    GEMBIRD USB cables CCP-USB2-AMBM-15

    Czy ja dobrze widzę że on kosztuje 7zł? Takie coś strasznie łatwo zakłócić, jak kolega wyżej napisał. Być może jest położony wzdłuż jakiegoś przewodu prądowego... to już kaplica.
  • #23
    sledzik10
    Level 10  
    Żaden prądowy przewód w pobliżu nie idzie.. jedynie skrętka tak jak pisałem.

    //edit

    Podłączyłem aktywnego huba od razu za routerem a do niego kabel 4,5m i wszystko pięknie działa :)
    Dziękuję wszystkim którzy pomogli.

    //edit

    Mam jeszcze jedno pytanko... urządzenie o którym mowa to urządzenie wielofunkcyjne. Chcę wiedzieć czy jest możliwość udostępnienia skanera tak samo jak drukarki? Bo teraz już nie wykrywa skanera. Czy jest to tylko możliwe gdy urządzenie jest bezpośrednio podpięte do komputera?