Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Mikrotik - konfiguracja DHCP

hubert2101 20 Wrz 2012 12:00 5772 4
  • #1 20 Wrz 2012 12:00
    hubert2101
    Poziom 13  

    Witam

    Mama taki problem, mianowicie chcę aby urządzenia(punkty dostępowe) i stacje robocze (komputery np. PC) pracowały na różnych pulach adresowych.
    Jak prawidłowo skonfigurować serwer DHCP? zakładam, że adresy dla urządzeń będą przypisywane na sztywno a dla stacji roboczych za pomocą serwera DHCP. Posiadam RB z serii 500 2x WLAN 3xETHERNET.
    Poniżej konfiguracja jaka na początek zrobiłem

    Code:

    [admin@MikroTik] > export
    # jan/01/2002 01:06:12 by RouterOS 3.30
    # software id = xxxxxxxxxxx
    #
    /interface bridge
    add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes comment="" disabled=no forward-delay=15s l2mtu=2304 max-message-age=20s mtu=1500 name=\
        "Bridge WLAN" priority=0x8000 protocol-mode=none transmit-hold-count=6
    add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes comment="" disabled=no forward-delay=15s l2mtu=1600 max-message-age=20s mtu=1500 name=\
        "Bridge ETHERNET 1 and 2" priority=0x8000 protocol-mode=none transmit-hold-count=6
    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes comment="" disabled=no full-duplex=yes l2mtu=1600 mac-address=00:0C:42:04:AC:F0 mdix-enable=yes mtu=1500 name="ether1 POE" speed=\
        100Mbps
    set 1 arp=enabled auto-negotiation=yes comment="" disabled=no full-duplex=yes l2mtu=1600 mac-address=00:0C:42:04:AC:F1 mtu=1500 name="ether2 WAN" speed=100Mbps
    set 2 arp=enabled auto-negotiation=yes comment="" disabled=no full-duplex=yes l2mtu=1600 mac-address=00:0C:42:04:AC:F2 mtu=1500 name="ether3 Serwer DHCP" speed=100Mbps
    /interface wireless security-profiles
    set default authentication-types="" eap-methods=passthrough group-ciphers="" group-key-update=5m interim-update=0s mode=none name=default radius-eap-accounting=no \
        radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none \
        static-algo-1=none static-algo-2=none static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" static-sta-private-algo=none \
        static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=MikroTik tls-certificate=none tls-mode=no-certificates unicast-ciphers="" \
        wpa-pre-shared-key="" wpa2-pre-shared-key=""
    /interface wireless
    set 0 ack-timeout=dynamic adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 antenna-mode=ant-a area="" arp=enabled band=2.4ghz-b/g basic-rates-a/g=6Mbps \




        basic-rates-b=1Mbps burst-time=disabled comment="" compression=no country=no_country_set default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 \
        default-forwarding=yes dfs-mode=none disable-running-check=no disabled=no disconnect-timeout=3s frame-lifetime=0 frequency=2412 frequency-mode=superchannel \
        hide-ssid=no hw-retries=4 mac-address=00:0E:8E:19:4F:15 max-station-count=2007 mode=ap-bridge mtu=1500 name=wlan1 noise-floor-threshold=default on-fail-retry-time=\
        100ms periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=000E8E194F15 rate-set=default \
        scan-list=default security-profile=default ssid=MikroTik station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=\
        6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps tx-power-mode=default update-stats-interval=disabled \
        wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wmm-support=disabled
    set 1 ack-timeout=dynamic adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 antenna-mode=ant-a area="" arp=enabled band=2.4ghz-b/g basic-rates-a/g=6Mbps \
        basic-rates-b=1Mbps burst-time=disabled comment="" compression=no country=no_country_set default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 \
        default-forwarding=yes dfs-mode=none disable-running-check=no disabled=no disconnect-timeout=3s frame-lifetime=0 frequency=2462 frequency-mode=manual-txpower \
        hide-ssid=no hw-retries=4 mac-address=00:0C:42:1F:59:53 max-station-count=2007 mode=ap-bridge mtu=1500 name=wlan2 noise-floor-threshold=default on-fail-retry-time=\
        100ms periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=000C421F5953 rate-set=default \
        scan-list=default security-profile=default ssid=MikroTik station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=\
        6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps tx-power-mode=default update-stats-interval=disabled \
        wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wmm-support=disabled
    /interface wireless manual-tx-power-table
    set wlan1 comment="" manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-1:0,HT20\
        -2:0,HT20-3:0,HT20-4:0,HT20-5:0,HT20-6:0,HT20-7:0,HT20-8:0,HT40-1:0,HT40-2:0,HT40-3:0,HT40-4:0,HT40-5:0,HT40-6:0,HT40-7:0,HT40-8:0"
    set wlan2 comment="" manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-1:0,HT20\
        -2:0,HT20-3:0,HT20-4:0,HT20-5:0,HT20-6:0,HT20-7:0,HT20-8:0,HT40-1:0,HT40-2:0,HT40-3:0,HT40-4:0,HT40-5:0,HT40-6:0,HT40-7:0,HT40-8:0"
    /interface wireless nstreme
    set wlan1 comment="" disable-csma=no enable-nstreme=no enable-polling=yes framer-limit=3200 framer-policy=none
    set wlan2 comment="" disable-csma=no enable-nstreme=no enable-polling=yes framer-limit=3200 framer-policy=none
    /ip ipsec proposal
    set default auth-algorithms=sha1 disabled=no enc-algorithms=3des lifetime=30m name=default pfs-group=modp1024
    /ip pool
    add name=dhcp_pool1 ranges=172.1.0.2-172.1.0.254
    add name=dhcp_pool2 ranges=172.1.0.2-172.1.0.254
    /ip dhcp-server
    add address-pool=dhcp_pool2 authoritative=after-2sec-delay bootp-support=static disabled=no interface="Bridge WLAN" lease-time=3d name=dhcp1
    /port
    set 0 baud-rate=auto data-bits=8 flow-control=hardware name=serial0 parity=none stop-bits=1
    /ppp profile
    set default change-tcp-mss=yes comment="" name=default only-one=default use-compression=default use-encryption=default use-vj-compression=default
    set default-encryption change-tcp-mss=yes comment="" name=default-encryption only-one=default use-compression=default use-encryption=yes use-vj-compression=default
    /queue type
    set default kind=pfifo name=default pfifo-limit=50
    set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
    set wireless-default kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
    set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
    set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
    set default-small kind=pfifo name=default-small pfifo-limit=10
    /routing bgp instance
    set default as=65530 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=default out-filter="" redistribute-connected=no \
        redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=0.0.0.0
    /routing ospf area
    set backbone area-id=0.0.0.0 authentication=none disabled=no name=backbone type=default
    /snmp
    set contact="" enabled=no engine-boots=0 engine-id="" location="" time-window=15 trap-sink=0.0.0.0 trap-version=1
    /snmp community
    set public address=0.0.0.0/0 authentication-password="" authentication-protocol=MD5 encryption-password="" encryption-protocol=DES name=public read-access=yes security=\
        none write-access=no
    /system logging action
    set memory memory-lines=100 memory-stop-on-full=no name=memory target=memory
    set disk disk-file-count=2 disk-file-name=log disk-lines-per-file=100 disk-stop-on-full=no name=disk target=disk
    set echo name=echo remember=yes target=echo
    set remote bsd-syslog=no name=remote remote=0.0.0.0:514 src-address=0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
    /system routerboard settings
    set baud-rate=115200 boot-delay=2s boot-device=nand-if-fail-then-ethernet boot-protocol=bootp cpu-frequency=330MHz cpu-mode=regular enable-jumper-reset=yes \
        enter-setup-on=any-key force-backup-booter=no
    set baud-rate=115200 boot-delay=2s boot-device=nand-if-fail-then-ethernet boot-protocol=bootp cpu-frequency=330MHz cpu-mode=regular enable-jumper-reset=yes \
        enter-setup-on=any-key force-backup-booter=no
    /user group
    add comment="" name=read policy=local,telnet,ssh,reboot,read,test,winbox,password,web,sniff,sensitive,!ftp,!write,!policy
    add comment="" name=write policy=local,telnet,ssh,reboot,read,write,test,winbox,password,web,sniff,sensitive,!ftp,!policy
    add comment="" name=full policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive
    /interface bridge port
    add bridge="Bridge WLAN" comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=wlan1 path-cost=10 point-to-point=auto priority=0x80
    add bridge="Bridge WLAN" comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=wlan2 path-cost=10 point-to-point=auto priority=0x80
    add bridge="Bridge ETHERNET 1 and 2" comment="" disabled=no edge=auto external-fdb=auto horizon=none interface="ether1 POE" path-cost=10 point-to-point=auto priority=\
        0x80
    add bridge="Bridge ETHERNET 1 and 2" comment="" disabled=no edge=auto external-fdb=auto horizon=none interface="ether2 WAN" path-cost=10 point-to-point=auto priority=\
        0x80
    /interface bridge settings
    set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no
    /interface ethernet mirror
    set
    /interface l2tp-server server
    set authentication=pap,chap,mschap1,mschap2 default-profile=default-encryption enabled=no max-mru=1460 max-mtu=1460 mrru=disabled
    /interface ovpn-server server
    set auth=sha1,md5 certificate=none cipher=blowfish128,aes128 default-profile=default enabled=no keepalive-timeout=60 mac-address=FE:80:3E:36:60:3C max-mtu=1500 mode=ip \
        netmask=24 port=1194 require-client-certificate=no
    /interface pptp-server server
    set authentication=mschap1,mschap2 default-profile=default-encryption enabled=no keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled
    /interface wireless align
    set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 frame-size=300 frames-per-second=25 receive-all=no \
        ssid-all=no
    /interface wireless sniffer
    set channel-time=200ms file-limit=10 file-name="" memory-limit=10 multiple-channels=no only-headers=no receive-errors=no streaming-enabled=no streaming-max-rate=0 \
        streaming-server=0.0.0.0
    /interface wireless snooper
    set channel-time=200ms multiple-channels=yes receive-errors=no
    /ip accounting
    set account-local-traffic=no enabled=no threshold=256
    /ip accounting web-access
    set accessible-via-web=no address=0.0.0.0/0
    /ip address
    add address=192.168.20.200/24 broadcast=192.168.20.255 comment="default configuration" disabled=no interface="Bridge ETHERNET 1 and 2" network=192.168.20.0
    add address=172.1.0.1/24 broadcast=172.1.0.255 comment="" disabled=no interface="Bridge WLAN" network=172.1.0.0
    /ip dhcp-server config
    set store-leases-disk=5m
    /ip dhcp-server network
    add address=172.1.0.0/24 comment="" gateway=172.1.0.1
    /ip dns
    set allow-remote-requests=no cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 primary-dns=194.204.159.1 secondary-dns=194.204.152.34
    /ip dns static
    add address=192.168.20.1 disabled=no name="Serwer DNS" ttl=1d
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=10s \
        tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface="Bridge ETHERNET 1 and 2"
    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667
    set h323 disabled=no
    set sip disabled=no ports=5060,5061
    set pptp disabled=no
    /ip neighbor discovery
    set "ether1 POE" discover=yes
    set "ether2 WAN" discover=yes
    set "ether3 Serwer DHCP" discover=yes
    set wlan1 discover=no
    set wlan2 discover=no
    set "Bridge WLAN" discover=yes
    set "Bridge ETHERNET 1 and 2" discover=yes
    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=no enabled=no max-cache-size=none max-client-connections=600 max-fresh-time=3d \
        max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=no src-address=0.0.0.0
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.20.1 scope=30 target-scope=10
    /ip service
    set telnet address=0.0.0.0/0 disabled=no port=23
    set ftp address=0.0.0.0/0 disabled=no port=21
    set www address=0.0.0.0/0 disabled=no port=80
    set ssh address=0.0.0.0/0 disabled=no port=22
    set www-ssl address=0.0.0.0/0 certificate=none disabled=yes port=443
    set api address=0.0.0.0/0 disabled=yes port=8728
    set winbox address=0.0.0.0/0 disabled=no port=8291
    /ip socks
    set connection-idle-timeout=2m enabled=no max-connections=200 port=1080
    /ip traffic-flow
    set active-flow-timeout=30m cache-entries=4k enabled=no inactive-flow-timeout=15s interfaces=all
    /ip upnp
    set allow-disable-external-interface=yes enabled=no show-dummy-rule=yes
    /ppp aaa
    set accounting=yes interim-update=0s use-radius=no
    /queue interface
    set "ether1 POE" queue=ethernet-default
    set "ether2 WAN" queue=ethernet-default
    set "ether3 Serwer DHCP" queue=ethernet-default
    set wlan1 queue=wireless-default
    set wlan2 queue=wireless-default
    set "Bridge WLAN" queue=default
    set "Bridge ETHERNET 1 and 2" queue=default
    /radius incoming
    set accept=no port=3799
    /routing mme
    set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m gateway-selection=no-gateway origination-interval=5s preferred-gateway=0.0.0.0 timeout=1m ttl=50
    /routing ospf
    set distribute-default=never metric-bgp=20 metric-connected=20 metric-default=1 metric-rip=20 metric-static=20 mpls-te-area=unspecified mpls-te-router-id=unspecified \
        redistribute-bgp=no redistribute-connected=no redistribute-rip=no redistribute-static=no router-id=0.0.0.0
    /routing rip
    set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 metric-default=1 metric-ospf=1 metric-static=1 redistribute-bgp=no redistribute-connected=\
        no redistribute-ospf=no redistribute-static=no timeout-timer=3m update-timer=30s
    /store
    add comment="" disabled=no disk=system name=web-proxy1 type=web-proxy
    /system clock
    set time-zone-name=manual
    /system clock manual
    set dst-delta=+00:00 dst-end="jan/01/1970 00:00:00" dst-start="jan/01/1970 00:00:00" time-zone=+00:00
    /system console
    add disabled=no port=serial0 term=vt102
    /system health
    set
    /system identity
    set name=MikroTik
    /system logging
    add action=memory disabled=no prefix="" topics=info
    add action=memory disabled=no prefix="" topics=error
    add action=memory disabled=no prefix="" topics=warning
    add action=echo disabled=no prefix="" topics=critical
    /system note
    set note="" show-at-login=yes
    /system ntp client
    set enabled=no mode=unicast primary-ntp=0.0.0.0 secondary-ntp=0.0.0.0
    /system ntp server
    set broadcast=no enabled=no manycast=yes multicast=no
    /system upgrade mirror
    set check-interval=1d enabled=no primary-server=0.0.0.0 secondary-server=0.0.0.0 user=""
    /system watchdog
    set auto-send-supout=no automatic-supout=yes no-ping-delay=5m watch-address=none watchdog-timer=yes
    /tool bandwidth-server
    set allocate-udp-ports-from=2000 authenticate=yes enabled=yes max-sessions=100
    /tool e-mail
    set from=<> password="" server=0.0.0.0:25 username=""
    /tool graphing
    set page-refresh=300 store-every=5min
    /tool mac-server
    add disabled=no interface=all
    /tool mac-server ping
    set enabled=yes
    /tool sms
    set allowed-number="" channel=0 keep-max-sms=0 receive-enabled=no secret=""
    /tool sniffer
    set file-limit=10 file-name="" filter-address1=0.0.0.0/0:0-65535 filter-address2=0.0.0.0/0:0-65535 filter-protocol=ip-only filter-stream=yes interface=all memory-limit=\
        10 only-headers=no streaming-enabled=no streaming-server=0.0.0.0
    /user aaa
    set accounting=yes default-group=read interim-update=0s use-radius=no
    [admin@MikroTik] >

    0 4
  • #2 08 Lis 2012 23:34
    Nickleodeon
    Poziom 11  

    Serwus kolego, można to zrobić tak:
    interfejs na którym działa dhcp, serwer DHCP i stacje robocze muszą być w takiej samej klasie adresowej (np. 192.168.0.0/24), natomiast apki (mikrotiki) w innej (różnej od poprzednio podanej) klasie adresowej, np. 192.168.99.0/24;
    winboxem można łączyć się z nimi po MAC-adresie (nie po IP)

    0
  • #3 04 Sty 2013 21:45
    gruszfil
    Poziom 11  

    Po MAC-u to jedna z możliwości i bardzo nie stabilne połączenie, więc możesz do jednego interfejsu przypisać kilka adresów IP z różnych podsieci i w ten sposób łączyć sie z dowolnymi AP. DHCP można uruchomić dla różnych podsieci na jednym interafece, jako kilka serwerów DHCP. Czytać manuala to wszystko wyjaśnia!!!

    0
  • #4 06 Sty 2013 18:32
    hubert2101
    Poziom 13  

    Sprawdzę i dam znać co i jak.

    -1
  • #5 24 Lip 2013 11:40
    hubert2101
    Poziom 13  

    Wszystko działa. Uważam za temat zamknięty.

    0