Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Bascom 8051 i AVT 3500 - Brak komunikacji komputera z plytka testowa

core2quad 10 Paź 2012 13:20 1140 4
  • #1 10 Paź 2012 13:20
    core2quad
    Poziom 15  

    Witam. Jak to poczatkujacy w tej dziedzinie napotkalem problem na samym poczatku. Uzywam programu Bascom 8051 demo i posiadam caly zestaw do kursu bascom college czyli:
    -Plytka testowa AVT 3500
    -Programator AVT 2502
    -Emulator procesorow AVT 2501

    W pierwszej czesci kursu opisane jest aby napisac kod w programie i skompilowac go a potem kliknac symuluj. Napisane pisze ze program powinien wyslac rozwniez kod to plytki testowej i wywolac ten sam efekt co na sumulatorze, lecz nic sie nie dzieje. Gdzie popelniam blad?

    System operacyjny Windows 7. Plytka testowa podlaczona jest pod port LPT i USB (tylko napiecie 5V). Jak wiemy kurs bascom college napisany zostal juz jakis czas temu i od tej pory wiele sie zmienilo. Jak zauwazylem, w kursie uzywaja innej plytki testowej. Prosze o pomoc i z gory dzieki.

    0 4
  • #2 10 Paź 2012 13:50
    Mundi1970
    Poziom 24  

    Coś mi tu nie pasuje, płytka testowa AVT 3500 wykorzystuje procesory AVR typu AT90(L)S2313 / ATTINY2313, a nie 8051.

    0
  • #3 10 Paź 2012 14:11
    core2quad
    Poziom 15  

    Ok juz widze swoj blad. Teraz pytanie czy duzo rozni sie kod wprowadzany do bascom avr i bascom 8051? Chodzi mi czy bedzie mozliwosc przetestowania kodu ktory napisze w 8051 i przetestowania go na avr?

    PS Zna moze ktos tutorial albo kurs oparty na kicie AVT 3500?

    0
  • #4 10 Paź 2012 16:23
    Mundi1970
    Poziom 24  

    Część składni będzie się zgadzać, ale na pewno będą różnice w poleceniach konfigurujących hardware (nazwy portów, timery).
    Różnice znajdziesz w helpach : BASCOM-AVR Help, BASCOM-8051 Help

    0
  • #5 11 Paź 2012 13:35
    core2quad
    Poziom 15  

    Dzieki bardzo za zainteresowanie, ale jak narazie mam ciagle problem z komunikacja plytki z programem. Probowalem na dwoch komputerach i ciagle ten sam blad. Sprawdzilem polaczenia na plytce, kazdy komponent, rezystory. Przeszukalem kilkadziesiat stron i ciagle nie moge znalezc rozwiazania. Zasilanie 5V pociagnalem z portu usb wiec chyba wystarczajace? Plytka dziala sprawnie. Po podlaczeniu zasilania plytka wyswietla program testowy oryginalnie wgrany do pamieci procesora.

    0