Elektroda.pl
Elektroda.pl
X

Search our partners

Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Dell latitude D800 bateria 7050mAh Sanyo Y0956 ciągle ładuje

bc211 23 Oct 2012 06:41 4410 1
  • #1
    bc211
    Level 30  
    Podłączyłem zasilacz PA-10, wtedy nie miałem jeszcze zielonego pojęcia o tym cwanym systemie DELL-PSID z epromem 1-wire.
    Bateria naładowała się dobrze po czym nie była w ogóle używana. Stan naładowania 100%.

    Zasilacz musiałem oddać, aż pewnego pięknego dnia podłączyłem zasilacz bez igły, kiedy to nieświadomy o systemie PSID, gdzie wydajność z 2,1GHz multipier x21 zmalała do 600MHz x6, skupiłem się na zielonej lampce zasilania, która zaczęła migać 4x pomarańczowo / 1x zielono w odstępie 1s i bateria przestała być widoczna.

    Podłączyłem PA-12, ale tester baterii w postaci 5 diod po naciśnięciu przycisku obok zapalił 3 diody 10101 sygnalizując jej uszkodzenie, wtedy też lampka zasilania w laptopie zapaliła się na pomarańczowo w sposób ciągły. Wróciła komunikacja 1-wire, bateria znów była widoczna, ale wydajność x6 nadal była na niskim poziomie.

    W instrukcjach serwisowych DELL wyczytałem, że gdy dedykowany zasilacz 90W zastąpi się zasilaczem 65W może to spowodować nieoczekiwane problemy z ładowaniem, więc podłączyłem z powrotem zasilacz PA-10, wróciła wydajność max. performance 2,1GHz x21, kupiłem czysty ee i przegrałem do niego zawartość z epromu znajdującego się w środku PA-12, po czym aby nie ryzykować uszkodzenia laptopa jak i zasilacza ten głupi scalak włożyłem do komputera, bo w kablu zasilającym sygnał ID jest zaekranowany plusem, który z kolei jest zaekranowany minusem, gdzie wystarczy przełamać kabel i gotowe uszkodzenie nie do zrobienia.

    Myślałem, że na tym skończą się problemy z DELL-em, ale bateria nadal sygnalizuje uszkodzenie.
    Odłączyłem zasilanie sterownika, podłączyłem z powrotem, przycisk test przestał reagować (dłuższe podtrzymanie również) aż do chwili włożenia baterii do komputera z powrotem, po czym nadal bateria sygnalizuje uszkodzenie. Wyjąłem pamięć i w międzyczasie puśiło połączenie na tym rezystorze

    Dell latitude D800 bateria 7050mAh Sanyo Y0956 ciągle ładuje

    Nie jestem w stanie powiedzieć kiedy odleciał, ale na pewno przy rozbieraniu, bo wcześniej napięcie Vcell działało dobrze.
    Doszedłem, że jest on fabrycznie zły, bo rozstaw pinów nie zgadza się z rozstawem pól lutowniczych na płycie.

    Po rozebraniu bateri stwierdziłem zadziałanie blokady FUSE, a ogniwa wcale nie była rozładowane. Do tranzystora od grzałki FUSE podłączyłem żarówkę, wyjąłem 24C01 (brak zasilania), wpisałem tam zawartość tej samej baterii z innym uszkodzeniem Link po czym baterię włożyłem do komputera, którego BIOS włączył z powrotem zasilanie 24C01, włączył wskaźnik naładowania (nadal 10101 uszkodzenie), po chwili wykrył baterie, po czym żarówka zapaliła się, wskaźnik naładowania baterii pokazał 0% przy napięciu ponad 19V, to dlatego bq8011 wystawił flagę o przepaleniu FUSE, a więc analizując też znalezioną na FO zawartość podobnej działającej Link znalazłem blokadę, wartość 8h w komórce $07, 0h odblokowane

    Dell latitude D800 bateria 7050mAh Sanyo Y0956 ciągle ładuje



    Wyzerowałem obie, sterownik baterii po odłączeniu od zasilania ruszył dopiero po rozładowaniu jej ogniw do ok. 9-10V, naładowałem do 75%
    Naprawiłem uszkodzenie Vcell, podłączyłem willema SDA, SCL bezpośrednio, bo było już zasilanie, wgrałem oryginalną zawartość z wyzerowaną blokadą

    Dell latitude D800 bateria 7050mAh Sanyo Y0956 ciągle ładuje

    ale żeby sterownik ruszył z nowymi nastawami trzeba było ponownie odłączyć zasilanie, bateria naładowana w 75% pokazała 0%, więc znów rozładowałem do 0 i teraz jest taki problem jeżeli ładuję od 0, to ładuje do 100% i tak się zatrzymuje

    Dell latitude D800 bateria 7050mAh Sanyo Y0956 ciągle ładuje

    Kiedy ładuje powiedzmy od 40%, to zatrzymuje się na 99% i wtedy zmienia się wartość

    Dell latitude D800 bateria 7050mAh Sanyo Y0956 ciągle ładuje

    tzn, CC ciągle rośnie, a FCC zwiększa się do stałej wartości ok. 31xxxx.
    To samo dzieje się, kiedy przy 100-110% wyjmę i włożę baterię, to wskaźnik zatrzymuje się na 99%.

    Czytam o tych bateriach, nie jestem w tym biegły, dlatego prosiłbym o wyrozumiałość, bo nadal nie mogę czegoś tu zrozumieć.
    Noty kat. innych sterowników, np. bq2040 Link mówią jasno i przejrzyście o mapie pamięci, a tu jest to jakieś tajne czy co ?

    Dodano po 39 [minuty]:

    Dodam jeszcze, że jak się zatrzyma tak, to lampka zasilania z ciągłego zielone zmienia się na na migające w odstępie 8s zielone,
    Charge Rate 4W/10W, gdzie w miarę upływu czasu ok. 20h maleje do 3W/10W... czy to drugi etap ładowanie stałym napięciem ?

    Sterownik bq8011. Bateria trzyma +/- 2.5h przy obciążeniu ok. 23W przez komputer. Wear level 61%.
    O co tu chodzi, czy to jest bezpieczne ? Komputer jest mi potrzebny może ktoś podpowie co dalej.
  • #2
    Wiesław Rzepka

    Level 32  
    Odpowiem ci z grubsza na twoje pytania. Po pierwsze bateria jest Sanyo. I to jest główny powód wszystkich problemów. Po drugie, nie można dosłownie nigdzie zdobyć datasheeta bq8011 ! Prosiłem znajomych chińczyków z XitongHan o rzeczony schemat i niestety oni również go nie mają. Po co on ? Ano po to aby w jakiś sposób rozpracować mapę pamięci dla tego kontrolera. Ponieważ mam Sanyo Tool, poradziłem sobie z problemem baterii na bq8011 ale też nie od razu. Otóż jeśli do eepromu zapiszesz więcej niż dwie linie wsadu, zakryjesz pewien fragment pamięci kontrolera i bateria nie będzie działać. Osobiście nie programuję eepromu żadnym programatorem, zapis robię w Sanyo tool. Baterie działają, chociaż sam fakt pomijania danych z pozostałych linii wsadu eepromu nie jest dla mnie do końca jasny. Z informacji, które otrzymałem z XitongHan wsad eepromu musi pokrywać się z częścią flasha i jedynie zmiany mogą dotyczyć FCC i CC. Jednak sprawdziłem, że w bateriach na bq80201 można zmienić DC, DV, oraz sterowanie np diodami led.