Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

dysk NAS z danymi nadpisany strukturą RAID1

rogerowaty 26 Paź 2012 23:15 1632 13
  • #1 26 Paź 2012 23:15
    rogerowaty
    Poziom 9  

    Taki oto przypadek się trafił, chronologia z relacji:
    - pojedynczy dysk (500gb) z urządzenia sieciowego NAS (linksys) miał być rozszerzony do raid1,
    - dołożony został na próbę 1T
    - nas wykrył jako nowy i umożliwił utworzenie raid1
    - no i użytkownik dał OK :/
    - nie mogę ustalić czy próbował wrócić do opcji osobnych dysków ale należy przypuszczać że wykonał również romontowanie utworzonego raid1

    ... tu zaczyna się historia ... wszystkie dane zostały utracone tzn. nie sę widoczne w prosty sposób (linux, różne app recovery)
    zawartość ok. 50% dysku plikami wszelakiej maści (kopie sieciowe)

    Ext2explore widzi na dysku pierwotnym (ale zmodyfikownym) taką strukturę:
    /dev/sda1
    katalogi: public i lost+found
    /dev/sda2
    katalogi: config, log, lost+found, samba, share, tmp, upgrade
    i trochę tekstowych plików konfiguracyjnych

    Na dysku dokładanym (1T) jest taka sama struktura ale nie ma żadnego pliku widocznego.

    narazie nie ingeruję zbyt w pierwotny dysk (500gb) ... jeżeli nie byłby potrzebny obraz dokładanego dysku mmogę zrobić na nim kopię tego mniejszego źródłowego ... zawsze to jakiś początek


    Proszę kolegów o sugestię czy taki przypadek da się odkręcić.


    Pozdrawiam all

    0 13
  • #2 27 Paź 2012 05:08
    465016
    Użytkownik usunął konto  
  • #3 27 Paź 2012 09:44
    rogerowaty
    Poziom 9  

    NAS-box to "Linksys NAS 200"

    Zabrałem dzisiaj rano pudełko od "szkodnika" i zerknełem na obecną konfiguracje dysków.
    Teraz jest ustawione: Separated-disk non-journaled
    Czyli jak się domyślam była próba powrotu do pierwotnych ustawień.

    z ssh był troche problem bo on nie obsługuje domyślnie takiego dostępu ale już ok

    plik /proc/mdstat jest pusty
    czytalne są tylko konfiguracje udziałów, użytkowników

    0
  • #4 27 Paź 2012 19:55
    465016
    Użytkownik usunął konto  
  • #5 27 Paź 2012 20:42
    rogerowaty
    Poziom 9  

    układ partycji:
    Device Boot Start End Blocks Id System
    /dev/sda1 63 976045139 488022538+ 83 Linux
    /dev/sda2 976045140 976527089 240975 83 Linux
    /dev/sda3 976527090 976768064 120487+ 82 Linux swap

    TestDisk to samo wykrywa.

    mdadm.conf nie istnieje a /proc/mdstat jest pusty ... ma wielkość 0 bajtów.

    Wygląda jakby config był usunięty po usunięciu struktury RAID.
    Narazie brak pomysłów. Próby skanowania czymkolwiek dogłębnie nie znajdują nic oprócz istniejącej widocznej struktury.

    Doszedłem że "szkodnik" robił to z panelu a nie z aplikacji ... tu są i ostrzeżenia o formatowaniu, synchronizacji itd .... ale na to nie wpadł :/

    jakiś helpik jeszcze ?

    0
  • #6 27 Paź 2012 21:25
    465016
    Użytkownik usunął konto  
  • #7 27 Paź 2012 22:42
    rogerowaty
    Poziom 9  

    walczyłem różnymi metodami i chyba się zaczynam poddawać, już uzupełniam:

    mdadm --examine --scan
    ARRAY /dev/md0 level=raid1 num-devices=2 UUID=285b4aa9:da4c8b8f:071261e2:ba19f72e
    spares=1
    ARRAY /dev/md1 level=raid1 num-devices=2 UUID=23806e03:1ca43228:a3f21f02:91f04566

    Disk /dev/sdb: 255 heads, 63 sectors, 121601 cylinders
    Units = sectors of 1 * 512 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 63 1952797139 976398538+ 83 Linux
    /dev/sdb2 1952797140 1953279089 240975 83 Linux
    /dev/sdb3 1953279090 1953520064 120487+ 82 Linux swap
    /dev/sda1 63 976045139 488022538+ 83 Linux
    /dev/sda2 976045140 976527089 240975 83 Linux
    /dev/sda3 976527090 976768064 120487+ 82 Linux swap

    troche zabawy z tym jest :/

    0
  • #8 27 Paź 2012 23:29
    465016
    Użytkownik usunął konto  
  • #9 28 Paź 2012 12:24
    rogerowaty
    Poziom 9  

    dzięki kolego ale pół nocy siedziałem nad tym badziewiem i się poddałem
    doszedłem jedynie do złożenia macierzy i odczytałem strukturę katalogów ale nie wszystkie były czytalne (poslimaczkowane nazwy)
    uparłem się na skanowanie dogłębne tej strukltury ale do rana nic ciekawego na masową skalę nie znalazło

    teraz "szkodnik" ma zajęcie na 2 dni żeby udziały ponownie poustawiać i zrobić backupy

    włączyłem teraz rebuid macierzy na NASboxie ... wow .... 1%=10minut
    demon to to jest :D

    dam mu narazie spokój niech sobie to odbuduje
    ciekawostka jest taka że dyski zamkniete w tym boxie rozgrzewają się do znacznej temperatury ... wg SMART do 60oC
    zdrowe to to chyba nie jest, no nie

    czy może ktoś ma doświadczenie z tym modelem NAS - Linksys NAS200, czego jeszcze można się po nim spoedziewać ?

    doczytałem jak to to stare jest i proc sięga czasów 486

    0
  • #10 28 Paź 2012 18:31
    465016
    Użytkownik usunął konto  
  • #11 29 Paź 2012 17:04
    rogerowaty
    Poziom 9  

    no wszystko fajnie ale aż taki wyga to nie jestem :D

    boxa osobiście zawiozłem i okazało się że tym "szkodnikiem" był pracownik, bardzo sympatyczna blondyneczka :) taki troche "parainformatyk" ... no i skutki na początku wątku, ale z prostrzymi pracami jakoś sobie radzi


    Czy da się tego RAID1 w tym boxie "stuningować" ? tj. zoptymalizować jego pracę przy tym cpu jaki tam jest a nie jest on niestety demonicznie wydajny.

    Zrobiłem sobie wjazd ssh ale teraz macierz jest aktywna i robi swoje zadanie na żywo i juz gromadzi dane.
    W razie czego mógłbym czasowo przegonić na pojedynczy dysk zasoby ale trochę to kłopotliwe bo trzeba wypinać dysk (albo gonić lanem a to tylko 100) a nie wiem czy coś się nie rozpadnie.

    Czy kolega coś mógłby pomóc w optymalizacji ? (o ile się coś tu da optymalizować)

    0
  • #12 30 Paź 2012 20:19
    465016
    Użytkownik usunął konto  
  • #13 30 Paź 2012 22:02
    rogerowaty
    Poziom 9  

    ssh niewiedziała jak zmontować na tym ustrojstwie :p

    teraz to niedokońca wiem jaki jest układ partycji po uruchomieniu ale nie chodzi tu o prędkość tylko pełny mirror,
    a na 2 dyskach to niewidziałem wynalazków raid10 ... no chyba ze na jakiś nowszych ale nie analizowałem ich możliwości

    będę przejazdem to zaczytam układ i format partycji a może coś da się tam jeszcze pogonić, sam soft (nakładka) nie pozwala na taki wynalazek ale to może tylko producent tak uprościł dla bezpieczeństwa chociaż z logicznie prędkość powinna być taka sama jak dla RAID1 tylko dysk mocniej będzie pracował

    a przypadkiem ten cpu to nie zasłaby jest ? .... później podam obecną konfigurację (sprzętowo dwa identyczne dyski 1T ... WD Blue, na nieszczęście zmienione z WD Enterprise)

    0
  • #14 31 Paź 2012 10:40
    465016
    Użytkownik usunął konto