Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przeróbka zasilacza impulsowego z 12V na 7,2V

matroxi 02 Lis 2012 21:07 4017 16
  • #1 02 Lis 2012 21:07
    matroxi
    Poziom 14  

    Posiadam zasilacz fabryczny 12V 1,6A (chyba od jakiegoś modemu)ma stabilizację po stronie wtórnej na TL431, i transoptorze PC817.
    W dzielniku TL431 są rezystory 20k (+) i 5,6k (-).
    Problem w tym, że nie mogę za pomocą dzielników zmniejszyć napięcia do 7,2V ponieważ LED podłączona na wyjściu zaczyna przygasać i słychać pykanie trafa.Stosując rezystory 20k i 7,5k osiągam ok 9V jeszcze stabilnego napięcia.
    Poniżej 9V czyli zamieniając rezystor 7,5k na 10k zaczyna się pykanie i przygasanie LED.
    Co może być przyczyną powyższego?

    0 16
  • #2 03 Lis 2012 16:29
    fotonn
    Poziom 28  

    Spróbuj może w drugą stronę - zostaw 5,6k, a zmniejszaj 20.

    Może być też, że prąd diody transoptora staje się za mały.
    Zmniejsz rezystor szeregowy, zasilający ją i/lub zwiększ równoległy - zależy czy i co tam w ogóle jest.

    Zobacz też, czy nie ma jakiegoś rezystora, o mocy kilku wat, stanowiącego wstępne obciążenie.
    Przy 0,6 napięcia znamionowego, wydzieli się na nim tylko 0,36 zakładanej mocy.
    I tyle razy powinieneś go zmniejszyć, aby zapewnić stabilne warunki pracy nieobciążonej przetwornicy.

    To tyle możesz pokombinować po stronie wtórnej, zanim zajmiesz się mniej bezpiecznym grzebaniem po pierwotnej.

    PS.: Zakładamy, że elektrolity filtrujące są sprawne.

    0
  • #3 03 Lis 2012 16:40
    Macosmail
    Poziom 32  

    Może też być tak (na 90% tak jest), że układ scalony przetwornicy jest zasilany z dodatkowego uzwojenia po stronie pierwotnej, a przy manipulacjach w sprzężeniu zwrotnym napięcie to ulega zmianom i może być po prostu na tyle niskie, że układ przestaje pracować.

    0
  • #4 03 Lis 2012 22:13
    matroxi
    Poziom 14  

    Zmieniając wartość opornika 20k efekt jest taki sam czyli pulsująca przetwornica.
    Zmniejszyłem wartość opornika szeregowego z diodą transoptora z 220Ω na 110Ω, również nie pomaga. Równolegle do diody transoptora jest opornik 1k ale go nie ruszałem.
    Zauważyłem, że ustawienie wyższego napięcia dzielnikiem np. 17V nie powoduje pulsacji przetwornicy, tylko obniżanie.

    Ten rezystor mocy o którym piszesz fotonn to jest po stronie wtórnej czy pierwotnej ,bo po wtórnej nie ma go.

    Kolego Macosmail nie wiem na jakim układzie jest zbudowana przetwornica, ma 6 nóżek. Dołączam fotki dla ogólnego zarysu sprawy
    Przeróbka zasilacza impulsowego z 12V na 7,2V Przeróbka zasilacza impulsowego z 12V na 7,2V

    0
  • #5 04 Lis 2012 00:02
    fotonn
    Poziom 28  

    Cytat:
    Dołączam fotki dla ogólnego zarysu sprawy

    I wszystko jasne - było tak od razu...

    Rezystora nie ma.

    Macosmail ma absolutnie rację, ale najgorsze, że niewiele możesz z tym zrobić.
    Przewijanie trafa raczej nie wchodzi w grę, a jeśli już, to najlepiej byłoby odwinąć z wtórnego kilka zwojów i wówczas kombinować z rezystorami wokół TL431.
    Inaczej pozostanie chyba obniżyć napięcie przetwornicy do ok. 10V tak, jak to obecnie robisz, a do dalszego jego zmniejszenia na wyjściu, zastosować stabilizator liniowy , np. LM317.

    0
  • #6 04 Lis 2012 13:51
    klamocik
    Poziom 22  

    Jeśli chcesz eksperymentować to ci podpowiem : wywal stabilizator wraz z jego elementami do plusa wyjscia podepnij opór regulowany 10KΩ drugi koniec na transoptor,sprawdz czy drugi koniec transoptora jest do minusa, przez żarówkę 25W po stronie pierwotnej włącz do sieci, stronę wtórną obciąż małą żarówką (aby było widać czy chodzi regulacja) jeśli regulacja chodzi to ustaw na ok 10V zlikwiduj żarówkę na stronie pierwotnej i kręć podkówką aż otrzymasz twoje 7V jeśli zasilacz nie będzie próbkował to zmierz napięcie na podkówce i wstaw za nią diodę zenera,może być z małym oporem do dokładnej regulacji.

    0
  • #7 04 Lis 2012 17:42
    matroxi
    Poziom 14  

    klamocik napisał:
    .. i wstaw za nią diodę zenera,może być z małym oporem do dokładnej regulacji.

    Możesz kolego wyjaśnić dokładniej gdzie tą zenerka i opornik wstawić i na jakie napięcie?

    0
  • #8 04 Lis 2012 18:54
    fotonn
    Poziom 28  

    Klamocik, podłączę się z pytaniem: - jak to usunie problem, o którym pisał Macosmail?

    0
  • #10 04 Lis 2012 20:51
    fotonn
    Poziom 28  

    Co się ma okazać?
    Napięcie wyjściowe, przy którym pętla sprzężenia zwrotnego na transoptorze ustali długość impulsu "ładującego" energią rdzeń transformatora, determinuje jednocześnie ilość energii przekazaną w cyklu kondensatorowi zasilania scalaka przetwornicy, a więc i napięcie na nim.
    Scalak natomiast, po fazie rozruchu pod niskim napięciem zasilania, które zapewniają rezystory R3 i R4, oczekuje wzrostu tego napięcia, co tutaj oznacza, że przetworka ruszyła.
    Jeśli ustali się ręcznie mniejsze napięcie wyjściowe, przy którym dioda transoptora zaczyna świecić, zmniejszy się również napięcie uzwojenia transformatora zasilającego scalak, a on sam się zablokuje i będzie próbkował, bo zgodnie z wbudowaną weń logiką, stwierdzi, że klucz MOSFET nie ruszył i nie pracuje poprawnie.

    Zauważył to Macosmail.

    I nie zmieni tego sposób, w jaki wywoła się po stornie wtórnej zasilacza świecenie transoptora, czy to zmieniając dzielnik przy TL-u, czy też wyrzucając jego samego.

    Należałoby zmienić przekładnię transformatora.

    Pewne manewry można by spróbować zrobić, bazując na nieidealnym sprzężeniu magnetycznym między uzwojeniami, ale obawiam się, ze "zjazd" aż o tyle wolt, to mimo wszystko za dużo, jak na możliwości takich kombinacji w układzie bez kontroli zaniku strumienia w rdzeniu, kiedy w dodatku o sterowniku wiadomo tylko, że ma 6 nóżek - ot taki krab.

    Można ewentualnie, delikatnie i na próbę, spróbować zmniejszyć rezystory R3 i R4, powiedzmy z 200 do 180k (w sumie), 0,5W (każdy) i zobaczyć, czy w ogóle obniży to próg napięcia, przy którym zaczyna się próbkowanie (czy da się osiągnąć mniej, niż owe 9V).
    Jeżeli zmniejszy i wyraźnie zbliży do oczekiwanych 7,2V , w ostateczności można jeszcze spróbować zejść na 160k, ale absolutnie nie mniej, bo w końcu okaże się, że scalak zacznie sterować kluczem MOSFET bez żadnej kontroli efektów tego sterowania, czyli nie będzie autotestu poprawnego rozruchu.

    Dla zabezpieczenia generatora podczas tych prób, warto równolegle do tego małego elektrolita tuż obok scalaka, wstawić zenerkę.
    Dobrać ją na napięcie troszkę wyższe niż panuje na zasilaniu scalaka (tj. na tym elektrolicie) w warunkach normalnej pracy - przy 12V na wyjściu.
    Sprawdzić to napięcie ( na układzie) zarówno w stanie jałowym, jak i przy pełnym obciążeniu wyjścia zasilacza.

    Trochę zwiększone zasilanie sterownikowi nie zaszkodzi - sprawdziłeś to już wymuszając 17V na wyjściu.

    Jeżeli by pomogło, trzeba na koniec sprawdzić, czy ww. kontrola rozruchowa jeszcze działa.
    W tym celu dzielnik przy TL431 można zmienić, jak dla obliczeniowych np. 6V.
    Przetwornica powinna próbkować, jak to robi obecnie poniżej 9V.
    Jeżeli nie, to z powrotem, stopniowo zwiększaj R3 i R4, aż do sukcesu.

    O "lewej ręce w kieszeni", "izolowanych laczkach" i trzykrotnym sprawdzeniu wszystkiego przed każdym włączeniem wtyczki do sieci, przypominać chyba nie trzeba.

    Żarówka - powiedzmy max 60W - w szeregu z przetworką, to też niegłupi pomysł.

    Aaa, te rezystory zamiast R3 i R4 mają być w ilości sztuk większej niż jeden, np. 2x91k lub 2x82k. Pojedyńczą sztukę 325V może przebić.

    0
  • #11 05 Lis 2012 11:05
    matroxi
    Poziom 14  

    fotonn napisał:
    Można ewentualnie, delikatnie i na próbę, spróbować zmniejszyć rezystory R3 i R4, powiedzmy z 200 do 180k (w sumie), 0,5W (każdy) i zobaczyć, czy w ogóle obniży to próg napięcia, przy którym zaczyna się próbkowanie (czy da się osiągnąć mniej, niż owe 9V).


    Kolego fotonn napisałeś, że rezystory mają 200kΩ ale przecież widać że mają po 1MΩ (na zdjęciu).
    Czy mam je zmniejszyć do np 750kΩ

    0
  • #12 06 Lis 2012 00:10
    fotonn
    Poziom 28  

    Nie wiem co mnie zamroczyło, że uparłem się czytać je jako 10 do potęgi 5 - przepraszam.
    Oczywiście, mają po 1M, ale to znaczy, że prąd startowy ograniczają do zaledwie ok. 160 uA.
    Prąd zaś pobierany przez sterownik w czasie pracy jest znacznie większy, stąd zmniejszenie tych rezystorów - w rozsądnych granicach - chyba nic nie da
    (jeśli jednak uprzesz się, aby spróbować - może nie od razu tak radykalnie).

    Kurcze, nie mam innego "pomysła", co mógłbyś jeszcze zrobić.
    Pozostanie chyba ograniczenie napięcia z wytraceniem mocy na stabilizatorze liniowym, ewentualnie - jeśli nie jest potrzebna aż tak duża wydajność prądowa - na zwykłym rezystorze.
    A że spytam: - to ładowarka ma być?

    0
  • #13 06 Lis 2012 17:48
    matroxi
    Poziom 14  

    Tak kolego fotonn, to ma być ładowarka do akumulatora do samochodzika dziecięcego.
    Akumulator w nim jest 6v/4,5Ah. Oryginalna ładowarka dostarczała 7,2-7,4V i 1A prądu i też taką próbuję zrobić z tego zasilacza.

    Czy są jakieś pomysły?
    Czy próbować:

    klamocik napisał:
    Jeśli chcesz eksperymentować to ci podpowiem : wywal stabilizator wraz z jego elementami do plusa wyjscia podepnij opór regulowany 10KΩ drugi koniec na transoptor,sprawdz czy drugi koniec transoptora jest do minusa, przez żarówkę 25W po stronie pierwotnej włącz do sieci, stronę wtórną obciąż małą żarówką (aby było widać czy chodzi regulacja) jeśli regulacja chodzi to ustaw na ok 10V zlikwiduj żarówkę na stronie pierwotnej i kręć podkówką aż otrzymasz twoje 7V jeśli zasilacz nie będzie próbkował to zmierz napięcie na podkówce i wstaw za nią diodę zenera,może być z małym oporem do dokładnej regulacji.
    .

    0
  • #14 07 Lis 2012 12:08
    matroxi
    Poziom 14  

    Zastosowałem sie do wskazówek klamocika czyli potencjometr, niestety to samo poniżej 9V pulsacja.
    Zmniejszyłem również R4 i R5 do 750kΩ, nic nie pomogło.

    Co jeszcze mógłbym zrobić, aby osiągnąć upragnione 7,2V i nie ruszając trafa, które jest dość mocno i solidnie sklejone?

    0
  • #15 07 Lis 2012 12:31
    andy127
    Poziom 30  

    matroxi napisał:
    Co jeszcze mógłbym zrobić, aby osiągnąć upragnione 7,2V i nie ruszając trafa, które jest dość mocno i solidnie sklejone?

    Macosmail napisał:
    Może też być tak (na 90% tak jest), że układ scalony przetwornicy jest zasilany z dodatkowego uzwojenia po stronie pierwotnej, a przy manipulacjach w sprzężeniu zwrotnym napięcie to ulega zmianom i może być po prostu na tyle niskie, że układ przestaje pracować.

    Czytając wpis Macosmail nasunął mi się pewien "wariacki" pomysł. Jeśli to napięcie z uzwojenia pomocniczego jest za niskie gdy zjedziesz regulacją napięcia wyjściowego do 7,2V to może napięcie z tego pomocniczego uzwojenia na stronie pierwotnej zamiast prostować jednopołówkowo (a tak prawdopodobnie jest), wyprostować w podwajaczu napięcia i uzyskaną nadwyżkę zmniejszyć przy pomocy dzielnika. Tak aby przy 7,2V na wyjściu mieć na zasilaniu scalaka tyle ile było w jego normalnym układzie pracy, czyli przy 12V na wyjściu.
    Mam nadzieję, że nadmiernie nie skomplikowałem swojej wypowiedzi i że pomysł jest bardziej genialny niż wariacki. Ale niech się wypowiedzą znawcy tematu.
    Też jestem ciekawy co z tego wyjdzie.
    Andrzej

    0
  • #16 07 Lis 2012 14:05
    matroxi
    Poziom 14  

    Myślałem też o powielaczu..
    Zauważyłem, że scalak jest zasilany z dodatkowego uzwojenia (jak sugerowali koledzy), przez diodę prostowniczą i kondek 10µF/50V bez żadnego dodatkowego stabilizatora (prawdopodobnie jest zenerka wbudowana w scalak).
    Zasilacz pracuje prawidłowo gdy jest napięcie 13,4V na scalaku, poniżej 13V są pulsacje.
    Zwiększając pojemność kondka na 100µF pulsacje były ale bardzo wolno natomiast zmniejszając kondka na 4,7µF występowały szybkie pulsacje.
    Wpadłem na pomysł podłączenia zewnętrznego zasilacza ustawionego na 13,4V. podłączonego równolegle z owym kondkiem, rezultat.
    Pulsacje ustały ale napięcie na wyjściu maleje w ciągu 10sek. aż do zgaśnięcia podłączonej LEDki.
    Zastanawia mnie czy powielacz coś by zdziałał?

    0
  • #17 07 Lis 2012 17:35
    xixin
    Poziom 14  

    Po co kombinujesz z przetwornicą. Skup się raczej na obniżeniu napięcia wyjściowego.
    Zasilacze impulsowe nie są łatwe w modernizacji jak miałeś miejsce się o tym przekonać.

    Moja propozycje:
    1. Ustaw za pomocą dzielnków TL-ka napięcie najniższe jakie osiągasz przy stabilej pracy przetwornicy np. 9V czy pewniej 9,1-9,2V.
    2. Zasilacz jak napisałeś ma 1,6A więc na wyjściu daj 3szt. diod prostowniczych połączonych szeregowo, aby zbić napięcie.
    Diody zastosuj najlepiej na min. 3A tak, aby się nie grzały moga to być np. 1N5408.
    Każda dioda ma spadek napięcia ok.0,6V-0,7V więc x3 = 1,8V. Teoretycznie na wyjściu osiągniesz 9,1-1,8= 7,3V (w przybliżeniu).
    3. Korektę do wartości 7,2V zrób dzielnikami na TL

    1
TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo