Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Atmega16 i wyświetlacz jm162a + kurs

pentel 03 Lis 2012 22:51 1632 9
  • #1 03 Lis 2012 22:51
    pentel
    Poziom 13  

    Witam, chce uruchomićzakupiony wyświetlacz jm162a na atmega16a. Postępuje zgodnie z http://hobby.abxyz.bplaced.net/index.php?pid=4&aid=8 tym turtorialem, jednak wyświetlacz nie odpowiada, świeci się tylko podświetlenie. Wszystko jest podłączone tak jak w linku, łącznie z programami które skopiowałem. Czy ktoś starałsię obsłużyć ten wyświetlacz ? Datasheet - http://stalmp3box.sourceforge.net/JM162ASPEC.pdf

    prosze o pomoc.

    Pozdrawiam

    0 9
  • #2 03 Lis 2012 22:57
    excray
    Poziom 39  

    Wyświetlacz jest zgodny z HD44780 i dowolny program do obsługi tego sterownika powinien działać. Czy mógłbyś w związku z tym udostępnić swój kod oraz schemat połączeń?

    0
  • #3 03 Lis 2012 23:05
    pentel
    Poziom 13  

    Witaj, kod i schemat połączeń zastosowałem ze strony, myślę że szybciej będzie Ci zerknąć tu Kurs AVR, w załączniku masz schemat połączenia skopiowany z podanej strony . kompletnie nie mam pojęcia co jest nie tak.
    P.S. Przepraszam, z małą różnicą że zamiast potencjometru wpiąłem rezystor 3,3K. Atmega16 i wyświetlacz jm162a + kurs

    0
  • #4 03 Lis 2012 23:18
    excray
    Poziom 39  

    Częstotliwość pracy też masz 1MHz?

    0
  • #5 03 Lis 2012 23:21
    pentel
    Poziom 13  

    próbowałem z# define F_CPU 1000000UL i bez tej lini

    0
  • #6 03 Lis 2012 23:54
    wojekkk
    Poziom 17  

    A kreciles kontrastem? Moze masz na 0 i dlatego nic nie widac?

    0
  • #7 03 Lis 2012 23:57
    pentel
    Poziom 13  

    Nie, nie kręciłem. Edytowałem później post, nie mam potencjometru więc zastąpiłem go rez 3.3K i tak próbowałem dodawać rez.

    0
  • #8 04 Lis 2012 00:01
    wojekkk
    Poziom 17  

    Ale zauwaz ze tam potencjometr jest w ukladzie dzielnika, spróbuj dac 2 rezystory jeden do 5v i 3 nogi a drugi do 3 nogi i do masy na poczatek o takich samych wartosciach. O tak Link

    0
  • #9 04 Lis 2012 00:17
    piotrva
    Moderator na urlopie...

    Spróbuj odpiąć wszystkie nogi sterujące od procesora i podpiąć Vo (3 pin LCD) do masy bez rezystora. Jeśli wtedy na wyświetlaczu pokażą się w pierwszym wierszu (po podłączeniu i odłączeniu zasilania) czarne kwadraty to znaczy że LCD na 90% sprawny, tylko masz źle ustawiony kontrast.
    Po tym teście (jak wynik wyjdzie pozytywny) kombinuj jak mówi Kolega wojekkk, ale nigdy nie zejdź z wartością sumy obu rezystancji (R+R1) poniżej 1kOhm - jeśli zejdziesz możesz tym uszkodzić przez nieuwagę zasilanie układu.
    ---
    Poza ty jak obecnie ten rezystor podpinałeś, przecież on ma tylko 2 piny, więc gdzie podpiąłeś pierwszy a gdzie drugi?

    0
  • #10 04 Lis 2012 00:34
    pentel
    Poziom 13  

    Witam, późna pora już jest a pentel kombinuje. Źle wytłumaczyłem jeżeli chodzi o potencjometr, zastosowałem dzielnik napięcia. Sprawdziłem wyświetlacz tak jak mówiłeś i jest padnięty, sprawdziłem jeszcze raz dla pewności podłączenia i wszystko się zgadza, czeka mnie w takim razie reklamacja.

    Dziękuje wszystkim za pomoc.

    0