Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Wzmacniacz audio - brzęczenia

DJ.TRoX 11 Nov 2012 22:58 1146 7
  • #1
    DJ.TRoX
    Level 17  
    Witam, potrzebuję porady,
    Buduje sobie wzmacniacz - chyba już z 10 lat:) a może i dłużej,
    W zeszłym roku postanowiłem zamknąć temat no i właśnie zamykam...

    Konstrukcja jest taka, że są 4 bloki
    - końcówka mocy (2xTDA7294)
    - regulacja barwy dźwięku (TL074 - żywcem z noty texasinstrument)
    - selektor kanałów - to osobna bajka i jeszcze nie odpalałem jej
    - przetwornik d/a (CS8415 + CS4334 + PCM2906)
    no i zasilacz oczywiście,
    Każdy blok jest osobną płytką,
    Nie brnąć w szczegóły idea była taka, żeby wszystkie bloki miały separowane zasilania i były połączone między sobą przewodami z zachowaniem ciągłości ekranu,
    Zasilanie selektora i korektora są stabilizowane LM7824
    Wszystkie stabilizatory, mostki prostownicze itd. są na płytce zasilacza
    Jak to zwykle bywa wszystkie bloki osobno działają świetnie, no prawie bo końcówka mocy ma za duże wzmocnienie, za krótki softstart itd. ale to wszystko się ogarnie,
    Nie przypiąłem również do masy potencjometrów za to przykręciłem do obudowy
    Na razie je przylutowałem do masy korektora a płytka leży na stole obok
    Teraz obudowa - jest stalowa, wycinana laserem, poskręcana aluminiowymi kątownikami i prętami, boki będą drewniane - bo jeszcze ich nie ma,



    Rezultat jest marny ogólnie mówiąc,
    Słychać przydźwięk sieci, świerszczenie itd,
    Po wyjęciu płytki korektora i po przylutowaniu do masy potencjometrów jest znacznie lepiej - ale nadal nie tak
    Pytanie co zrobić z zaciskiem PE zasilania sieciowego?
    Z jednej strony obudowa jest metalowa, więc trzeba uziemić, z drugiej strony podwójna izolacja jest prawie spełniona - prawie bo gniazdko USB się z nią styka ale ten blok jest odseparowany galwanicznie od całej reszty (ADMU1201)

    Gdzie i jak podłączyć masę wzmacaniacza do obudowy?
    Przez kondensator? na sztywno?
    No i gdzie skoro masy bloków połączone są wyłącznie ekranami?
    Wszystkie występują na płytce zasilacza ale się tam nie stykają,

    Proszę o radę, może ktoś coś wymyśli
    Z góry dzięki.
  • #2
    jdubowski
    Tube devices specialist
    DJ.TRoX wrote:
    Rezultat jest marny ogólnie mówiąc,
    Słychać przydźwięk sieci, świerszczenie itd,


    Dobre połączenie mas to jeszcze nie całość sukcesu - zwróć uwagę na ekranowanie bloków. Świerszczenie to jasny objaw wzbudzenia nadakustycznego.

    DJ.TRoX wrote:
    Pytanie co zrobić z zaciskiem PE zasilania sieciowego?


    Połączyć z masą strony pierwotnej zasilacza (rdzeń transformatora, środek filtru sieciowego), masą zasilacza i z masą zasilacza wzmacniacza mocy.
  • #4
    jdubowski
    Tube devices specialist
    DJ.TRoX wrote:
    Czyli co, nie zważając na separację, pospinać masy wszystkich zasilań (z np. w zasilaczu)


    Nie.

    DJ.TRoX wrote:
    Ale co wtedy z ciągłością ekranów?


    Ciągłość twoich ekranów będzie tworzyła szynę masy wzmacniacza, na końcu (w zasilaczu stopnia końcowego) połączoną z obudową i PE.
  • #6
    jdubowski
    Tube devices specialist
    Pamiętaj że rownież dla szyny masy powstałej z ekranów owa szyna musi mieć odpowiednio duży przekrój - alternatywnie mozesz ową szynę wykonać z drutu o przekroju co najmniej 1,5mm2 a ekrany łaczyć z ta szyną jednostronnie.
  • #7
    DJ.TRoX
    Level 17  
    Wiem o tym, i trzeba było zrobić wspólną masę w zasilaczu i ekrany tak jak piszesz łączyć jednostronnie,
    Chciałem zrobić lepiej i przekombinowałem,
    Podepnę masę zasilania mocy do obudowy razem z PE,
    Jeśli to nie pomoże to zasilacz zrobię od nowa...
    Jak po raz kolejny pokazuje praktyka, lepsze jest wrogiem dobrego
  • #8
    DJ.TRoX
    Level 17  
    Spiąłem PE+masę zasilacza mocy do obudowy,
    Zrobiłem dodatkowy mostek frontu z tyłem,
    Nie powiem jest lepiej, świerszczenie znikło,

    Końcówka mocy niestety nadal brzęczy nawet po zwarciu wejść do masy,
    Brzęczy minimalnie ale na 4R głośniku da się usłyszeć przydźwięk sieci,
    Co do schematu to praktycznie 1:1 nota aplikacyjna LM7294
    Na każdym biegunie są po 2 kondensatory 1000u/50 nisko imp. + po 2 100nMKT

    Zasilacz to trafo 200W 2x24V
    Później na PCB jest mostek i na każdy biegun 15mF + 2x220uF nisko imp. + 2x100nMKT + 3.3uF MKT

    Połączenie jest przewodami 1,5mm2 o długości około 40cm, niestety blisko trafa

    Jakim prawem to bzyczy?