Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - ile mam różnych komórek?

02 Lut 2005 20:15 6957 6
  • Poziom 22  
    Witam!
    Myślę nad tym już tydzień i stwierdziłem że na moją apstynencką główkę to chyba za trudne ;)
    Otóż mam taką serię danych w kolumnie:
    Cytat:
    KO00VE
    KO00XE
    KO10AN
    KO00VF
    KO00UN
    KO00UN

    I zamarzyło mi się coby Excel wyliczył mi ile jest tutaj różnych lokatorów. Na przykład w tym wypadku byłoby to 5.
    Szukałem, próbowałem... i nic :|

    Drugi mój problemik polega na tym że mam wpisaną w komórce wartość np. 15 i chcę żeby wyświetlane to było jako liczba trzycyfrowa uzupełniona z przodu przez zera, czyli w tym przypadku 015.
  • Pomocny post
    Poziom 35  
    apstynent napisał:

    Drugi mój problemik polega na tym że mam wpisaną w komórce wartość np. 15 i chcę żeby wyświetlane to było jako liczba trzycyfrowa uzupełniona z przodu przez zera, czyli w tym przypadku 015.

    Zaznaczasz komórkę(lub rząd albo kolumne), klikasz prawym przyciskiem myszy wybierasz "formatuj komórki". W zakładce "Liczby" wybierasz "niestandardowe" i w polu "typ" piszesz 00#
  • Poziom 17  
    co do pierwszego problemu na obrazku w załączeniu jest Twój przykład i w komórce B1 formuła na to liczenie wynik jest dobry także na większej ilości powinno również zadziałać (oczywiście odpowiednio zmieniając zakres komórek). więcej na temat tej komendy znajdziesz w pomocy excla
  • Poziom 28  
    Ani w pierwszym ani w drugim podanym przez kolegów przykladzie, wyniki funkcji nie są prawdziwe, zakladajac ze wartosci podane w komorkach sa danymi. W pierwszym kolega ma sześć elementów a w wyniku działania funkcji dostaje 5 , w drugim podobnie 5 elementów a w wyniku 4. Problem tkwi w niewłascie podanych argumentach funkcji. Aby prawidłowo działała, należy podać etykiete kolumny, komórka A1 ( zawierajaca przykładową wartosć ) jest traktowana jako etykieta.
    Pozdrawiam
  • Pomocny post
    Poziom 17  
    Sorry że tak wyszło ale wyszedł zbieg okoliczności i wynik był dobry. dzięki Bobo za zwrócenie uwagi.
    Jednak znalazłem coś innego co chyba będzie działało przynajmniej ja sprawdziłem na tym prostym przykładzie zapoczątkowanym przez Ciebie Apstynent.
    Oto Info z pomocy excela
    Zliczanie wystąpień unikatowych wpisów

    1. Zaznacz kolumnę zawierającą listę.

    2. W menu Dane kliknij polecenie Raport tabeli przestawnej i wykresu przestawnego.

    3. Kliknij przycisk Zakończ.

    4. Przeciągnij etykietę kolumny z obszaru Lista pól tabeli przestawnej do obszaru Upuść pola wierszy tutaj.

    5. Przeciągnij etykietę tej samej kolumny z obszaru Lista pól tabeli przestawnej do obszaru Upuść elementy danych tutaj.

    Ważne tutaj jest abyś w pierwszą komórkę czyli A1 wpisał jakąś etykietę zamiast danych do liczenia i tą właśnie etykietę będziesz przeciągał.
    a robisz to tak. po 3 kroku otworzy Ci się nowy arkusz i na środku małe dodatkowe okienko gdzie będzie ta etykieta i praciągasz ją tak jak w punkcie 4 i 5 jest to napisane. i powinno być ok
  • Poziom 2  
    Post wprawdzie sprzed 14 lat, ale może komuś się przyda, bo sam miałem taką potrzebę i nie znalazłem odpowiedzi.

    ROZWIĄZANIE

    Przykładowy zakres do sprawdzenia: A2:A9999
    Formuła:
    =SUMA(JEŻELI(CZĘSTOŚĆ(JEŻELI(DŁ(A2:A9999)>0;PODAJ.POZYCJĘ(A2:A9999;A2:A9999);"");JEŻELI(DŁ(A2:A9999)>0;PODAJ.POZYCJĘ(A2:A9999;A2:A9999;0);""))>0;1))

    ! TA FORMUŁA DZIAŁA TYLKO JAKO FUNKCJA !
    ..czyli..
    ..po wpisaniu / wklejeniu powyższej formuły i zmianie zakresu z przykładowego tutaj A2:A9999 na wymagany, w listwie formuły, w trybie edycji/wpisywania formuły należy wyjść z komórki używając kombinacji klawiszy CTRL+SHIFT+ENTER.

    Podglądając teraz zawartość naszej komórki z formułą zobaczymy dodane przez Excel na początku i końcu formuły klamry:

    {=SUMA(JEŻELI(CZĘSTOŚĆ(JEŻELI(DŁ(A2:A9999)>0;PODAJ.POZYCJĘ(A2:A9999;A2:A9999;0);"");JEŻELI(DŁ(A2:A9999)>0;PODAJ.POZYCJĘ(A2:A9999;A2:A9999;0);""))>0;1))}

    I będzie działać. Czysto i bez tabel przestawnych.

    ! Formuła / funkcja sprawdza zarówno duplikaty wartości liczbowych jak i tekstowych, ignorując puste komórki w zadanym zakresie.