Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sony vpl-ps10 - nie działająca prawidłowo klawiatura,szybko znikające OSD

krzkomar 18 Lis 2012 19:38 933 0
  • #1
    krzkomar
    Poziom 25  
    Witam

    Mam projektor taki jak w temacie. Jak go dostałem to obraz był prawie niewidoczny i nie dało się go wyłączyć. Problem z obrazem wynika z braku sterowania sygnałami RGB przez układ M52749 na płytce C (przedwzmacniacz sygnału wideo z wbudowanymi regulacjami i DAC-em do sterowania). Obraz jest poprostu ściemniony maksymalnie i nie ma ustawionego kontrastu. Aby cokolwiek zobaczyć podałem mu zewnętrznie napięcie pomijając wbudowanego DAC-a na nogę 34. Obraz się pojawił (o małym kontraście) dzięki czemu zobaczyłem czemu projektor nie chce się wyłączyć.

    Po naciśnięciu przycisku Power na moment (ponizej 1s) pojawia się OSD na ekranie aby potwierdzić wyłączenie. Jak się przycisk przytrzyma na dłużej to OSD pojawia się i znika nieregularnie. Czasami uda się w ten sposób projektor wyłaczyć. Pozostałe przyciski klawiatury nie działają, tzn czasami jak się długo przyciska dany przycisk to sie funkcja pojawi momentalnie znikając tak jak ma to miejsce w przypadku przycisku zasilania.

    Nie działanie M52749 być może jest spowodowane brakiem komunikacji z CPU, bądź bzdurnych nastaw obrazu, ale tak długo jak nie mogę wejść do menu to nie mam jak tego sprawdzić.

    Pilota do niego nie mam. Program obsługi przez USB pozwala tylko na podgląd stanu projektora i właczenie MUTE obrazu/dźwięku.

    W trybie stand-by udało mi się zresetować licznik lampy z klawiatury, więc jak nie jest właczony to klawiatura działa.

    Odczyt klawiatury jest analogowy (rezystory na przyciskach), linie do CPU sprawdzone, napięcie zasilania procka wygląda prawidłowo.

    Wersja softu CPU to MAIN 1.03 (soft niedostępny w sieci aby przeprogramować).

    Czyżby uszkodzenie CPU ? A jeśli tak to może ktoś posiada płytkę BB, albo sam proc z niej (HD64F2633)? Być może też ew uszkodzenie M52749 (IC302) powoduje takie dziwne zachowanie CPU ?

    To pierwszy projektor jaki mi wpadł w ręce i chciałbym go uruchomić na własne potrzeby.

    Z góry dziękuję za podpowiedzi co z tym robić.


    Sprawdziłem układ M52749 sterując go z zewnątrz przez I2C. Można w ten sposób ustawić parametry obrazu, więc zakładam że jest on sprawny. Pozostaje więc chyba już tylko "Main CPU" i obstawiam na soft. Na sieci znalazłem jeszcze notę serwisową o zmianie softu kontrolera na "MAIN 1.06" więc pewnie było to dystrybuowane po serwisach. Pliku nigdzie nie idzie znaleźć.

    PS

    Widzę, że chyba czeka mnie przeróbka, przez wywalenie oryginalnego proca i wstawienie własnego sterowania, choć wolałbym tego uniknąć.