Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Czy to jest błędne działanie bramek logicznych?

24 Lis 2012 13:18 936 5
  • Poziom 12  
    Witam,
    Ostatnio wziąłem się za budowę sumatora 4 bitowego na bramkach logicznych (74LS08; DM74LS32; DM74LS86). Układ nie działał poprawnie więc zacząłem sprawdzać elementy czy są dobre i za uwarzyłem, że bramki logiczne dobrze wykonują operacje logiczne tylko że same dają sobie na wejścia napięcie około 2V czyli stan logiczny 1. Żeby uzyskać na wejściu stan logiczny 0 to muszę zwierać wejście z masą. I tu moje pytanie czy tak ma być czy te scalaki są jakieś dziwne, bo z tego co wyczytałem to nie powinno tak być?

    Jeśli umieściłem temat w złym miejscu to proszę o przeniesienie,a nie usuwać go do razu :D
  • Pomocny post
    Poziom 35  
    Daj jakiś schemat. Wejścia przypadkiem nie "wiszą w powietrzu"?
  • Pomocny post
    Specjalista - HDD i odzyskiwanie danych
    2V to raczej stan zabroniony a nie 1 logiczne(nie wiadomo co będzie na wyjściu przy takim napięciu wejściowym), jeżeli wszystko przy sprawdzaniu bramek było ok to sprawdź jakie stany względem masy były podawane na wejścia gdy było to 2V na wyjściu, czy przypadkiem gdzieś ci coś nie łączy i mamy wiszącą końcówkę w powietrzu i właśnie taki skutek.
  • Pomocny post
    Poziom 32  
    memo1111 napisał:
    Witam,
    Ostatnio wziąłem się za budowę sumatora 4 bitowego na bramkach logicznych (74LS08; DM74LS32; DM74LS86). Układ nie działał poprawnie więc zacząłem sprawdzać elementy czy są dobre i za uwarzyłem, że bramki logiczne dobrze wykonują operacje logiczne tylko że same dają sobie na wejścia napięcie około 2V czyli stan logiczny 1. Żeby uzyskać na wejściu stan logiczny 0 to muszę zwierać wejście z masą. I tu moje pytanie czy tak ma być czy te scalaki są jakieś dziwne, bo z tego co wyczytałem to nie powinno tak być?

    Jeśli umieściłem temat w złym miejscu to proszę o przeniesienie,a nie usuwać go do razu :D


    Źle wyczytałeś.
    Układy są dobre, standard TTL mówi, że wejście niepodłączone traktowane jest jako H. Fizycznie napięcie na takim pinie to ok 2V. Z tego też powodu wyjście TTL daje niewielki prąd w stanie H (bo nie potrzebuje specjanie sterować wejśc skoro same z siebie dają H), natomiast w stanie L jest w stanie znacznie większy prąd wpuścić na masę.
  • Poziom 12  
    Problem był w tym że w sterowniku masa byłą puszczona przez opornik 10k co nie przy, każdej bramce pozwalało na podanie zera logicznego. Dziękuję wszystkim za pomoc :P