Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

at2313+WG12864B - Co jeszcze jest źle?

mikmas 24 Lis 2012 16:42 909 9
  • #1 24 Lis 2012 16:42
    mikmas
    Poziom 18  

    Temat jest właściwie kontynuacją tego tematu. Uwzględniłem uwagi tam zawarte, dodatkowo potężnie googlowałem, zrobiłem układ, milion razy po sprawdzałem i... RIP. Wyświetlacz spalony. Sprawdzałem później od tyłka strony podłączenie - na podstawie układu robiłem rysunek podłączenia, a następnie porównałem ze schematem i wszystko wygląda na ok. Potrzebuję waszej pomocy, bo już drugi wyświetlacz spaliłem :/.

    Do rzeczy - bazowałem dodatkowo na tym schemacie. Podłączyłem identycznie (no tylko procek inny, ale to jeden pies) z wyjątkiem tych oporników 1k. Domyślam się, że są tam, aby zabezpieczyć procek przed nadmiernym poborem prądu przez wyświetlacz? Pozwoliłem sobie je wywalić. Czy to mogło go spalić? Czym jest ten "zakreskowany" prostokąt na podłączeniu idącym do potencjometra na samej górze schematu?

    0 9
  • #2 24 Lis 2012 17:01
    Mol
    Poziom 30  

    Na jakiej podstawie twierdzisz że wyświetlacz jest spalony ?

    0
  • #3 24 Lis 2012 17:15
    mikmas
    Poziom 18  

    Mocno grzeje się środkowy układ (w ciągu kilku sekund dochodzi do temperatury, że zaczyna parzyć). Podobnie stabilizator dosyć ciepły jest (na początku też robił się gorący). Niemożliwe, żeby sprawny wyświetlacz miał taki pobór prądu, że stab się grzeje

    0
  • #4 26 Lis 2012 13:02
    Garth
    Poziom 9  

    mikmas napisał:
    Czym jest ten "zakreskowany" prostokąt na podłączeniu idącym do potencjometra na samej górze schematu?


    ekran...?

    0
  • #5 26 Lis 2012 13:06
    mikmas
    Poziom 18  

    Heheheh :D

    Bałem się, że ktoś właśnie coś tak napisze. Chodzi mi o to na SAMEJ górze, co jest na podłączeniu idącym od monitorka (pin 18) przez górę schematu do potencjometra.

    0
  • #6 26 Lis 2012 16:57
    Mol
    Poziom 30  

    Czyli kondensator przed stabilizatorem też jest ekranowany ? Tak to sobie ktoś narysował tylko.Co do wyświetlacza to jesteś pewny że mu zasilania nie podłączyłeś na odwrót ?

    0
  • #7 26 Lis 2012 18:15
    mikmas
    Poziom 18  

    W ogóle nie dałem kondensatora - nie daję na płytkach prototypowych. Zasilanie sprawdzałem milion jeden razy, bo też to dla mnie najbardziej prawdopodobne było.

    Ciekawe zjawisko - jeżeli pod wyświetlacz jest podłączone jedynie zasilanie (wyjmę mikrokontroler) to układy na wyświetlaczu się nie grzeją. Jak tylko wepnę do gniazda - grzeje się środkowy procesor. Napięcia są ok, więc podejrzewam, że może przyczyną jest to, że wyświetlacz został uszkodzony na skutek <<czegoś>> i teraz grzeje się z byle powodu.

    Już naprawdę nie mam pomysłu, a boję się wpinać sprawny wyświetlacz, póki nie odkryłem, co było przyczyną spalenia aktualnego. Nie mam już na niego siły...

    EDIT!
    Teoriatycznie mogę zrobić następujący myk - jako, że mam na składzie PIC16F876 to mógłbym zrobić toćka w toćkę takie samo podłączenie, jak jest na schemacie, włącznie z użytym procesorem. Wyprowadzić z takiego modułu tylko 4 kabelki (+,-,data,clock) i wydawać komendy typu "rysuj prostokąt od A do B", "rysuj znak". Jednak zwiększyłoby to dosyć znacznie koszt układu, oraz ogólny poziom skomplikowania. Skrajny efekt desperacji

    0
  • Pomocny post
    #8 26 Lis 2012 19:16
    wiere
    Poziom 10  

    Witam.
    Jesteś pewny co do symbolu wyświetlacza. Może masz o symbolu WG12864B1? Wtedy zmienione jest wyprowadzenie poszczególnych pinów?

    0
  • #10 26 Lis 2012 20:15
    mikmas
    Poziom 18  

    @wiere
    O.O
    Jestem debilem. Jak ja mogłem tego nie zauważyć. Tak, tam jest ta magiczna "1" na końcu i jak patrzę na wyjścia to się nie dziwię, że chłopaka przysmażyłem

    0