Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Dysk przez adapter sata - partycja RAW

kisage 29 Nov 2012 12:10 1950 2
  • #1
    kisage
    Level 2  
    Nowy HDD, narzędzia testujące dyski nie wykazują błędów, testy powierzchni wykonywane - OK.
    OS: Windows 7 Pro - Lenovo preinstalled, w BIOS AHCI.
    System z tego dysku pracuje prawidłowo, problem pojawia się przy podłączeniu tego dysku przez adapter sata/ata na USB.
    Po podłączeniu w/w HDD do drugiego PC (ten sam system - obraz) przez adapter SATA dysk jest wykrywany z 1 partycją RAW. Podłączenie tego samego dysku bezpośrednio do płyty gł. do portu SATA (start systemu z HDA, omawiany dysk to HDB ) - dysk HDB jest wykryty, w trybie offline (wykrył zdublowane identyfikatory dysków), przełączenie na online - układ partycji poprawny.
    Adapter sprawny - setki innych dysków sa wykrywane poprawnie.
    Podsumowując układ partycji jest poprawnie wykrywany przez bezpośredni port SATA, przez adapter SATA (sprawny, dla pewności sprawdzałem na 2 adapterach) - wykrywany układ partycji RAW.



    Nie potrzebuje nic odzyskiwać tj wcześniej pisałem sam system jest sprawny, potrzebuje wiedzieć co jest powodem i jak zaradzić aby układ partycji był poprawnie wykrywany przez adapter SATA.

    Załączam screeny z DMDE Dysk przez adapter sata - partycja RAW Dysk przez adapter sata - partycja RAW
  • #2
    Manam
    Level 11  
    Obawiam się, że może to być wina, albo dysku, albo adaptera SATA/ATA to USB. Zaraz powiem skąd to "albo... albo". Właśnie wczoraj miałem taki sam problem. Dysk Seagate 1TB był sformatowany jako NTFS na obcym komputerze (Windows Vista) a potem podłączony do mojego komputera (też LENOVO - Windows 7 Prof) przez SATA na płycie gł. i dział prawidłowo - było widać partycję NTFS. Potem ten sam dysk podłączyłem przez adapter SATA/ATA 3,5"/2,5" to USB i dysk został wykryty, ale partycja była typu RAW (i system chciał ją formatować!). Ponieważ dane z partycji nie były mi potrzebne, to sformatowałem ją jako NTFS i wrzuciłem na nią nowe dane. Po podłączeniu dysku do trzeciego komputera (Windows XP) przez ten sam adapter SATA to USB - partycja NTFS była normalnie widoczna. Podłączenie dysku bezpośrednio do SATA na płycie gł. obcego (pierwszego) komputera i partycja znowu widoczna jako RAW. Potem dysk do tego obcego komputera został podłączony przez inny model adaptera SATA to USB (kieszeń) i nadal był widoczny jako RAW - więc podejrzenie padło na mój adapter SATA/ATA to USB. Z drugiej strony przez ten mój adapter podłączane były różne dyski nawet 2TB i nie było problemu, więc może jednak dyski Seagate źle współpracują z konwerterem? Ciężko powiedzieć.
    Jedyne co mogę poradzić, to spróbować z innym adapterem SATA to USB.
    Podobny problem był już tutaj
  • #3
    kisage
    Level 2  
    tj pisałem sprawdzane było na 2 różnych firm adapterach sata/usb

    Również wychodzi mi na problem po stronie adapterów sata/usb (pewnie większość działa na podobnych układach) nieprawidłowo współpracuje z pewnymi dyskami.
    Nie zmienia to faktu, że tworzy mi to problem i nie wiem (jeszcze) jak go obejść...głównie chodzi o backup danych użytkownika :)