Elektroda.pl
Elektroda.pl
X
IGE-XAO
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

MJoy16-pytania odnośnie PCB

majtas85 18 Gru 2012 19:49 13344 70
  • #31
    majtas85
    Poziom 17  
    O to chodzi,że tak mam i nie łapie sygnału z programatora,w windzie pokazuje nie rozpoznano urządzenia usb(mam siódemkę)
    w ponyprog programator przechodzi test na opcji parrarel i DT-006 I/O
  • IGE-XAO
  • #32
    blue_17
    Poziom 32  
    Sądzę że masz problemy z programatorem to że wykrywa Ci coś jako nierozpoznane urządzenie to się nie przejmuj bo przecież jeszcze nie zaprogramowałeś procesora

    tu masz opis

    https://sites.google.com/site/mjoy16/programator

    dodatkowo musisz zmieć stan bitu JTAGEN aby wszystko działo

    Pozdrawiam
  • IGE-XAO
  • #33
    majtas85
    Poziom 17  
    To mogę programować przez ten DT-006 I/O?
    Bo tylko ta opcja przechodzi pomyślnie test w pony progu.
    Chyba że znasz jakiś lepszy program łatwy w obsłudze dla takiego laika jak ja.
    Na podstawie właśnie tej strony zrobiłem programator,bez rezystorów,bo mam już je na pcb.

    Dodano po 14 [minuty]:

    Jest jakiś postęp!
    Kiedyś wyłączyłem LPT,bo mi nie był potrzebny. Teraz go włączyłem i ustawiłem na 278 i ECP.(tam miałem bodajże 378,3E... coś tam nie pamiętam co i 278) mam MSI K9 Neo-V v1.0 mobo
    W ponyprog-u teraz wyświetla unknown device or missing device(-24).

    Dałem ignore,po chwili pojawiło się okienko read succesful, na obszarze roboczym pojawił się ciąg myślników i liter
    Czy teraz mogę wgrywać plik eep? Czy teraz jest ok,czy coś trzeba robić?
  • #34
    blue_17
    Poziom 32  
    musisz ustawić na 378 bo to standard a później ustawić na pasku AVR i dać read jeśli pojawia Ci się okienka możesz programować
  • #35
    majtas85
    Poziom 17  
    Dalej jest to samo czyli device missnig .....
    Próbowałem odwrócić Atmegę i też nic.
    Niby zasilanie do procka ciągnie ścieżką z usb.
    Ustawiłem na 378 i też nic,jest ustawione 378,ECP,DMA3
  • #37
    majtas85
    Poziom 17  
    Odpowiem Ci dopiero po lekcjach tak koło 16.30(tak długo dzisiaj mam).
    Wczoraj zdążyłem tylko polutować piny na wtyczce LPT.
  • #38
    majtas85
    Poziom 17  
    Płytkę z Twojego linku wykonałeś sam czy zamawiałeś?
    Moja ma przerwania i muszę robić pcb od nowa.
    To dopiero po świętach,jeśli nie po Nowym Roku.
  • #39
    blue_17
    Poziom 32  
    Płytkę zamawiałem ale to było dla znajomego więc on płacił
  • #40
    majtas85
    Poziom 17  
    Zrobiłem płytkę(trochę inną,(podobną do płytki Sundowner'a),jutro wytrawiam.
    Mam pytanie:czy mogę użyć tych diod do przycisków ze starej kierownicy? Mam ich około 18.
    MJoy16-pytania odnośnie PCB MJoy16-pytania odnośnie PCB Dorzucam zdjęcie tychże diod,prosiłbym o raczej szybką odpowiedź z racji tego,że jutro z rana jadę do miasta i przy okazji mogę je dokupić(jeśli będą dobre to ok,jeśli nie to kupię wymagane).
    Elektronikę powinienem zrobić bez większych problemów,wrazie czego brat mi pomoże.
    Dziękuję z góry.

    A tak poza trochę spóźnione ale: Szczęśliwego Nowego Roku.....
  • #41
    blue_17
    Poziom 32  
    Diody to groszowe sprawy a dodatkowo mogą tak samo wyglądać diody zenera lub inne jak kupujesz to lepiej kup wszystkie nowe bo to groszowe sprawy i Ci nerwów zaoszczędzi
  • #42
    majtas85
    Poziom 17  
    Teraz mam problem,mianowicie wlutowałem 37 diod(tyle było w sklepie),procek i całą resztę.
    Ponyprog wykrył programator,nie robił żadnych problemów z odczytem czy zapisem do pamięci Atmegi.
    Odpiąłem programator,usb i wpiąłem usb z powrotem wg instrukcji. Dalej nie wykrywa jako urządzenie HID tylko nie rozpoznano urządzenia usb.....
    Co znowu jest nie tak?
  • #43
    blue_17
    Poziom 32  
    Pokaż schemat podejrzewam że na na wejściu (na liniach sygnałów D+ i D-) zamiast diod zenera są zwykłe diody prostownicze.

    Pokaż schemat z jakiego to robisz bo może też być PCB nie poprawne

    Jak już masz połączenie poprzez programator to wgraj pliki hex i eep które są w paczce bo powinien pojawić kontroler gier

    http://www.blue17.elektroda.eu/projekty/1502
  • #44
    majtas85
    Poziom 17  
    Tu jest zdjęcie schematu i elementów na płytce. Diody przy usb to BZX7-C3V3,takie jakie były na liście wymaganych podzespołów w pliku pdf ze strony archiwum mindaugas.com.
    Wszystko wgrało się normalnie,za każdym razem było "succesful" a poodłączeniu nie chcę działać.


    MJoy16-pytania odnośnie PCB
  • #45
    blue_17
    Poziom 32  
    Schemat ideowy chciałbym zobaczyć czyli ten z symbolami elementów i połączeniami a nie montażowy :)

    A jak masz fuse bity ustawione chodzi o o wartości w hex-ie ??
  • #46
    majtas85
    Poziom 17  
    Schemat ideowy jest ale tylko do wcześniejszej wersji(ta co była pierwsza),a do tej co teraz mam to niestety nie ma. Jeśli chcesz mogę dodać

    Fusebity mam tam Sut0,BOOTSZ1,BOOTSZ0, JTAGEN odznaczony.
    MJoy16-pytania odnośnie PCB
  • #49
    blue_17
    Poziom 32  
    Jeszcze zaznacz JTAGEN reszta wygląda ok spróbuj wgrać pliki z mojej paczki
  • #50
    majtas85
    Poziom 17  
    Ciągle jest nie rozpoznano.... po wgraniu plików z paczki.
    Ustawiłem na JTAGEN i dalej to samo.
    Czyżby pcb,albo Atmega jest zła?
  • #51
    blue_17
    Poziom 32  
    Wlutuj kwarc i sprawdź czy jest tak samo, czy komputer wykryje użądzenie
  • #52
    majtas85
    Poziom 17  
    Wylutowałem i dalej jest to samo,czyli nie rozpoznano....
  • #53
    blue_17
    Poziom 32  
    To wygląda że PCB jest niepoprawne a jak odczytujesz fuse bity to masz takie same wartości jak przedtem tzn czy na pewno zapisałeś wartości fusebitów ?
  • #54
    majtas85
    Poziom 17  
    Tak jest to samo,trochę niedobrze,drugi laminat poszedł na nic...
  • #55
    blue_17
    Poziom 32  
    Mogę Cię zapewnić że projekt w moim opracowaniu działa o dziwo zadziałał zadziałał mi od kopa tzn wykrył go system itd tylko musiałem przestawić bit JTAGEN i wszystko śmiga tak jak ma śmigać :)
  • #56
    majtas85
    Poziom 17  
    Gratuluję,chyba dam sobie spokój,albo jutro popatrzę ścieżki.
    A czy można posprawdzać jakoś,czy ścieżki idą tam gdzie trzeba be schematu ideowego? Jeśli nie to spróbuję zrobić
  • #57
    majtas85
    Poziom 17  
    Czy pęknięta dioda zabezpieczająca USB może być powodem nie działania całości?
    Dzisiaj pod światłem zobaczyłem pęknięcie, biegnie przez całą szerokość,ok połowa średnicy walca.
  • #59
    majtas85
    Poziom 17  
    Czy mógłbyś mi napisać na pw listę potrzebnych elementów?
    Zbuduję Twoją wersję,nie chce mi się bawić w złe płytki itp
  • #60
    blue_17
    Poziom 32  
    Ze schematu najlepiej sobie spisz albo wykonaj boom w eaglu

    Wystarczy eagla zainstalować :)