Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - masowe przypisywanie wartości?

t-naw 03 Gru 2012 17:05 1389 6
  • #1 03 Gru 2012 17:05
    t-naw
    Poziom 14  

    Posiadam taką przykładową tabelkę w excelu

    kolumna A | kolumna B
    1 99
    99
    99
    99

    2 98
    98
    98

    Teraz chciał bym przypisać każdej komórce w kolumnie b z wartością 99 przypisać 1, a z wartością 98 przypisać 2 mniej więcej żeby to wyglądało tak:

    kolumna A | kolumna B
    1 99
    1 99
    1 99
    1 99

    2 98
    2 98
    2 98

    Problem polega na tym że jest to arkusz w którym jest baaardzo dużo danych ok 3 mega i rozciąganie tegop myszką zajmie mi 2 dni.

    Czy jest jakaś możliwość aby zrobić to automatycznie?

    0 6
  • #2 03 Gru 2012 18:13
    marek003
    Poziom 40  

    Wrzuć kawałek w excelu (jak 2007 to spakuj zipem) będzie prościej.
    Nie wiem jak jednoznacznie odczytać twoje dane wyjściowe. Sam spójżna nie. Czy w kolumnie A jest 1,99,99,99,99,pysta,2,98,98,98 a kolumnie B 99, pusta,pusta,pusta,pusta 98 pusta itd

    czy może inaczej. Załącz przykłąd tego pliku.

    0
  • #3 03 Gru 2012 18:19
    dylus1
    Poziom 16  

    Jeżeli zrozumiałem Ciebie dobrze to sprawa jest w miarę prosta i wystarczy formuła w komórce B2 =WYSZUKAJ.PIONOWO(Arkusz1!A1;Arkusz2!A$1:B$5;2;FAŁSZ)

    W "arkuszu2" robimy tablicę z której wyszukuje dostępne opcje:
    np:
    A B
    97 5
    98 1
    99 2
    100 3
    101 4

    obejrzyj załącznik...

    0
  • #4 03 Gru 2012 18:27
    t-naw
    Poziom 14  

    Dylus1 Coś w ten deseń tylko ja nie do końca to rozumiem:/

    Niżej jest mój plik, wyciąłem niepotrzebne dane żeby ,mnie ważył, pierwsze 337 wierszy jest już wypełnione.

    Ah nie zauważyłem, że nie dodało, spakowałem rarem *.xlsx jest nie dozwolone

    0
  • Pomocny post
    #5 03 Gru 2012 19:01
    dylus1
    Poziom 16  

    Czyli chodziło o uzupełnienie kolumny A ?
    Jeżeli tak, to najpierw zrobiłem tabelę pomocniczą w arkuszu3 z wartościami unikalnymi.(filtrem)
    Wg niej funkcja uzupełniła brakujące puste pola.

    0
  • Pomocny post
    #6 03 Gru 2012 19:13
    marek003
    Poziom 40  

    Ale można szybciej.
    w komórce C2 wpisać = jeżeli(A2="";C1;A2)
    zatwierdzić enterem ponownie "stanąć" na komórce C2 i nacisnąć kopiuj.
    zjechać prawym paskiem przewijania na sam dół (ważne by tam była cały czas zaznaczona komórka C2)
    Przytrzymać klawisz Shift wskazać myszką ostatniąprzy danych komórkę w kolumnie C (zaznaczy się cała kolumna)
    Prawoklik na ciemnyym polu i wklej.

    Następnie zaznaczyć całą kolumnę C i skopiować
    zaznaczyć całą kolumnę A prawoklik "wklej.specjalnie .... wartości i ok.
    Usunąć kolumnę C

    Wszystko

    edit:
    poprawiłem formułę.

    0
  • #7 03 Gru 2012 19:49
    t-naw
    Poziom 14  

    Dzięki panowie za pomoc :)

    0
  Szukaj w 5mln produktów