Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Termostat na Pt 100 - dziwne pomiary w czujniku

John5MM 15 Dec 2012 11:38 1980 6
  • #1
    John5MM
    Level 19  
    Buduję termostat z tej strony (zadał bym pytanie autorowi lecz nie odpisuje), http://warmar2.w.interia.pl/art/termostat.html

    Tranzystor 2N5087 (bipolarny PNP, 20V 0.2A 0.2W) , zastąpiłem tranzystorem BC559B dane:
    Polaryzacja: PNP.
    Prąd max.: 0,1A.
    Napięcie max.: 30V.
    Moc: 0,5W.

    Rzecz jasna, podłączony prawidłowo (odwrotnie niż 2N5087 ponieważ ten miał odwrotne wprowadzenia).

    Autor jako R4 zastosował 107ohm, dla prądu 6,5 mA, ja dla 108,4ohm uzyskałem na punktach dla czujnika 4,70V i 5,98mA , co dawało przekłamania dla czujnika (za wielka temperatura). Zamiast R4 dałem potencjometr i posługując się miernikiem z termoparą którą przyłożyłem obok czujnika (wskazywał 21C) skalibrowałem czujnik dokładnie na taką samą temperaturę. Kłopot polega na tym że w temperaturze 21C wyniki pomiaru punktów czujki wynoszą 4,68V i 5,39mA co jest jednak za dużym wynikiem (mA) dla czujnika bo pracownik firmy napisał mi że maksymalny prąd pomiarowy dla czujnika wynosi 5mA, w innej dokumentacji wyczytałem że ten czujnik (rezystor cienkowarstwowy) Pt100 może mieć jedynie 0,3 – 1mA, możecie mi powiedzieć co i jak ?

    Dane czujnika (kupiłem w portalu aukcyjnym) zdjęcie i opis :
    Termostat na Pt 100 - dziwne pomiary w czujniku
    REZYSTOR CIENKOWARSTWOWY TERMOMETRYCZNY
    PT100.KL:B.wg:PN-EN60751=A2.
    TEMPERATURA POMIAROWA TO -50 'C 500'C


    Druga sprawa ustawiłem fusebity dla atmega8A (program był zapewne pisany dla atmega8-16PU, wspominam i tym bo gdy na panelu wciskam przycisk esc bądź exit nic się nie dzieje).

    Fusy ustawiałem w pony prog i zaznaczyłem "ptaszkiem";, "Checked items means programmed (bit 0)" następujące fusy : CKOPT, BOOTSZ1, BOOTSZ0, SUTO czy tak jest analogicznie z programem ISP Programmer ? (poniżej fusy przesłane kiedyś przez autora projektu ISP Programmer)
    Termostat na Pt 100 - dziwne pomiary w czujniku
  • #2
    jarek_lnx
    Level 43  
    Zastosowany układ źródła prądowego z tranzystorem nie nadaje się do układów pomiarowych, jest zbyt mało dokładny i ma duży współczynnik temperaturowy - ogrzewając układ pomiarowy zmiana wskazania będzie prawie tak duża jak przy ogrzewaniu czujnika.
  • #4
    jarek_lnx
    Level 43  
    Zbudować źródło prądowe na wzmacniaczu operacyjnym i źródle napięcia odniesienia i dodać wzmacniacz, nie będzie problemu przy pracy z małymi prądami, ani z dokładnością i będzie można ustawić prąd i czułość oddzielnie.

    przykład
    Link

    W uproszczonym rozwiązaniu jako źródło prądowe można zastosować LM334 z diodą dającą kompensację temperaturową.
  • #5
    John5MM
    Level 19  
    Jak rozumiem, pisząc o najbardziej uproszczonym lm334 chodziło ci o takie coś np. http://ep.com.pl/files/8778.pdf , pisałeś o diodą dającą kompensację temperaturową , możesz jaśniej ?
  • #6
    jarek_lnx
    Level 43  
    Sam LM334 taż ma prad zależny od temperatury ale można go poprawić patrz rys 7 Link
  • #7
    John5MM
    Level 19  
    No tak rozumiem tylko ciekawi mnie skąd wezmę taką diode do lm334 , ale skąd jest tak że mimo iż na pinach czujnika było od 1,3-5 mA a dopiero przy 5,39 mA czujnik dał się skalibrowac do poprawnej temperatury ?