Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

sterownik kominka kratki msk glass - kłopoty z zasilaniem

adamszendzielorz 16 Gru 2012 16:53 3336 1
  • #1 16 Gru 2012 16:53
    adamszendzielorz
    Poziom 12  

    Witajcie!

    Mam problem ze sterownikiem MSK GLASS.

    Sterownik steruje przede wszystkim przepustnicą powietrza, za pomocą popularnego wśród modelarzy serwa HITEC HS-311. Od pewnego czasu (a mam go 3 lata) zaczęły się z nim dziać cuda - tj. zaczął zachowywać się nieprzewidywalnie, np. przełączał losowo opcje menu (wydając przy każdej zmianie piknięcie, co jest najbardziej denerwujące ;)

    Po wzięciu go "na warsztat" zauważyłem, że ta magia zaczyna się dziać w momencie kiedy sterownik zmienia położenie przepustnicy. Przy tym wyświetlacz (mały LED) lekko przygasał na ułamek sekundy. Przy okazji wyszło ze serwo wogóle nie zmienia położenia, czyli przepustnica tak naprawdę nie działa. Po odłączeniu przepustnicy - problemy jak ręką odjął. Kupiłem więc nowe serwo myśląc, że stare się zatarło. Po podłączeniu - działa prawie dobrze - niby przestawia przepustnice ale strasznie nierówno (z "drgawkami"), przy tych drgawkach wyświetlacz LED dalej przygasał (w rytm drgawek).

    Mniemam więc, że problem dotyczy zbyt słabej wydajności prądowej zasilania tego sterownika. Podłączyłem na testy do serwa zewnętrzne zasilanie i wszystko zaczęło działać poprawnie - przepustnica działa płynnie, wyświetlacz nie przygasa, wszystko działa jak należy!

    Rozebrałem sterownik - niestety wysiadł mi aparat którym mógłbym zrobić jakieś szczegółowe foto. Elektronik ze mnie taki sobie - tj. amator, poradzę sobię z wymianą dowolnego elementu ale nie mam pomysłu którego ;) Wszystkie elementy wyglądają jak nowe, kondensatory nie są spuchnięte, nic nie jest przypalone etc. Przy przestawianiu przepustnicy spada napięcie zasilania serwa (normalnie jest tam 5V - nie wiem czy nie powinno być 6V, przy przestawianiu spada do ~3V (nie mam oscyloskopu, a mój miernik jest trochę za wolny żeby to zmierzyć dokładniej).

    Napiszę może kilka najważniejszych elementów jakie są w układzie zasilania i może któryś z bardziej doświadczonych szanownych kolegów powie "o - ten element często pada - sprawdź go" :)

    Więc pokolei -> najpierw jakaś cewka, potem transformator BV EI 305 2050 (TAKI), kilka diód SMD B1100, regulator napięcia L5970D (TAKI), kondensator 1000uF 6,3V, dość duża bateryjka NI-MH (pewnie do podtrzymania ustawień sterownika), no i już bardzo blisko zasilania sterownika -> tranzystor BCP53 (TAKI). Jest jeszcze w okolicy regulatora napięcia taki ośmiokątny scalak z podkreślonym dużym napisem "330" - a może to kondensator SMD?).

    I to wszystko - oprócz tego kilkanaście rezystorków SMD i parę elementów po stronie pierwotnej (optotriaki etc) ale to mnie nie interesuje bo to do sterowania pomp - to wszystko działa poprawnie!

    Który z tych elementów mógł się zestarzeć, przez co spadła wydajność prądowa układu zasilania ?

    //EDIT: Trochę się pospieszyłem z tym że po podłączeniu do serwa zewnętrznego zasilania jest OK. Nie jest OK :( Tj. samo serwo działa poprawnie i płynnie ale sterownik po paru minutach (czas zupełnie losowy) i tak zaczyna szaleć - wyłącza się, resetuje. Po odłączeniu tego dodatkowego zasilania (czyli odpięciu + i - z serwa) sterownik zachowuje się poprawnie i jest stabilny. Masy dodatkowego zasilania i sterownika mam oczywiście połączone ze sobą. Nie wiem o co chodzi.

    1 1
  • #2 27 Sty 2014 23:00
    mc1100
    Poziom 9  

    Witam, rozbierałeś może tą przepustnicę aby dostać się do tego serwomechanizmu??
    Mój uległ uszkodzeniu i zastanawiam się czy to da się jakoś podmienić bez większych ingerencji, ale z tego co tu widzę trzeba to chyba po prostu rozwalić:)))

    0