Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ATmega8, ATtiny2313 - problem z programowaniem

minister15331 30 Gru 2012 09:52 1308 8
  • #1 30 Gru 2012 09:52
    minister15331
    Poziom 11  

    Witam, mój problem wygląda następująco:
    Mam programator stk200, który na początku programował attiny2313. Po krótkiej przerwie w programowaniu (ok. 2 tygodnie) przestał programować.
    W końcu kupiłem ATmega8 i o dziwo zaprogramował się. Program był tylko do sprawdzenia, co sekundę miał się zmieniać stan jednej końcówki na przeciwny, a tam ciągle jest stan wysoki.


    Co może być powodem tych usterek?

    0 8
  • #3 30 Gru 2012 10:26
    minister15331
    Poziom 11  

    używam ponyproga do programowania i bascom avr do pisania programu. Wrzucę wszystko póżniej, bo chwilowo nie mogę

    0
  • #4 30 Gru 2012 10:36
    dondu
    Moderator Mikrokontrolery Projektowanie

    Skoro PonyProg, to czy wykonałeś kalibrację (szukaj w menu Setup)?

    0
  • #5 30 Gru 2012 10:55
    mirekk36
    Poziom 42  

    minister15331 napisał:
    używam ponyproga do programowania i bascom avr do pisania programu. Wrzucę wszystko póżniej, bo chwilowo nie mogę


    Masz dwa fajne procki, które w 100% będą obsługiwane w programie MkAvrCalculator za FREE. Po co się męczyć z tym PonyProgiem, robić jakieś kalibracje i czary-mary? a potem sobie jeszcze niechcący np zablokować procka złym przestawieniem fusebitów. Sprawdź jak mówię ten program, obsługuje on także stk200 i sam zobaczysz. Masz nawet filmik i cały opis do tego tutaj: LINK

    0
  • #6 30 Gru 2012 11:05
    yokoon
    Poziom 28  

    Witam.

    Skoro piszesz w Bascomie to dlaczego też nie programujesz w Bascomie ?

    0
  • #7 30 Gru 2012 13:13
    minister15331
    Poziom 11  

    Przez bascom avr nie mogłem programować od początku. W ponyprogu zrobiłem kalibrację. Póżniej sprawdzę MkAvrkalkulator i dam znać co się dzieje

    0
  • #9 30 Gru 2012 19:07
    minister15331
    Poziom 11  

    Przez ten program nie mogę programować nawet megi, wyskakuje błąd :"polecenie wykonane nieprawidłowo". Gdy sprawdzam podłączenie AVR wyskakuje:"błąd avrdude"

    [/code]
    $regfile = "m8def.dat"
    $crystal = 1000000


    Config Portb = Output



    Do

    Set Portb.1
    Waitms 250
    Reset Portb.1
    Waitms 250
    Loop
    End

    wrzuciłem ten program na megę, przez chwilę działa dobrze, a po chwili przyspiesza i w końcu ustala się stan nieustalony

    0
  Szukaj w 5mln produktów