Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

LTspice - własny model, jak go zrobić i uruchomić

OldSkull 31 Gru 2012 12:39 1320 0
  • #1
    OldSkull
    Poziom 27  
    Witam, chciałbym zrobić własny model kilku elementów, na pierwszy ogień poszedł akumulator LiIon. Miałem na studiach na zajęciach ten temat ładnie wyjaśniony, ale w tej chwili nei mogę znaleźć notatek. W każdym razie: model, któy do schematu wklejamy jako symbol, do którego portów wyjściowych jedynie podpinamy różne rzeczy, a w oknie wywoływanym drugim kliknięciem modyfikujemy parametry wewnętrzne. Wiem, że jest to możliwe, bo już to robiłem, ale nie pamiętam dokładnie jak. Model sam w sobie jest poprawny (bo samodzielnei działa jako symulacja), ale nie daje się podpiąć.

    W przypadku podłączenia Vbat do masy i Vbat+ to napięcia:
    Cytat:
    Circuit: * C:\Program Files\LTC\LTspiceIV\Draft8.asc

    Error on line 2 : u1 n003 n001 n004 n002 0
    Unable to find definition of model "n002"
    WARNING: Node N004 is floating.
    WARNING: Node U1#HI3 is floating.

    WARNING: Less than two connections to node N002. This node is used by V1.
    Fatal Error: U1#rhi3: Resistance must not be zero.

    Co ciekawe V1 nie wisi, podobnie N004. HI3 w ogóle nie mogę znaleźć. Co ciekawe N002 w ogóle nie jest połączony z V1. Podejrzewam, że jest jakiś problem z synchronizację pomiedzy plikami - ale nie wiem jak to rozwiązać.
    Dopisanie:
    C={2}
    w dowolnej linii Spice Line lub Value powoduje pojawienie się dodatkowo błędu:
    Cytat:
    * Unknown parameter "c"


    Mam nadzieję, że jest ktoś kto zna się w temacie. Do tematu załączam pliki modelu i symulacji.
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.