Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Gateway MT6839b - Nie ładuje baterii po wymianie gniazda ładowania

hotdog 17 Sty 2013 13:25 3891 17
  • #1 17 Sty 2013 13:25
    hotdog
    Poziom 26  

    Witam.

    Laptop przywieziony z Anglii, teraz w posiadaniu mojej mamy.

    Z czasem powstał problem z ładowaniem, poruszanie kablem pomogło, raz próbowałem lutownicą luty poprawić, ale to nie pomogło, więc postanowiłem je wymienić.

    No i właśnie wylutowałem gniazdo Hot Aire'em i teraz wiem że to mógł być duży błąd. Już w trakcie lutowania widziałem jak mocno i długo trzeba grzać w miejscu gdzie jest gniazdo (luty PB free). Wiem że podgrzanie tego miejsca mogło doprowadzić do uszkodzenia PCB. Poprawiłem też kilka lutów na PCB zaznaczone czerwonymi kółkami. Ten przy bezpieczniku cały oblutowałem z lewej i prawej strony, a zdjęcie jest zrobione przez poprawianiem (widać przerwy z lewej i prawej strony). Od drugiej strony PCB (niewidocznej na zdjęciach) pod gniazdem są 2 kondensatory (pewnie koło 100nf) i rezystor 10k miedzy + a GND z zsilacza, pewnie pulldown 10k dla logiki.

    Objawy:
    - przy wyłączonym komputerze bateria się nie ładuje, kontrolka ładowania nie zapala się na żaden kolor
    - laptop nie startuje z baterii (ale jest ona kompletnie rozładowana, więc możliwe że to nie jest problem, żadna lampka nawet nie mrugnie, brak reakcji na power)
    - laptop nie startuje przy podłączonej baterii i zasilaniu (znowu, jest to chyba możliwe dlatego że bateria jest kompletnie rozładowana, żadna lampka nawet nie mrugnie, brak reakcji na power)
    - bez baterii na zasilaczu komputer chodzi bez problemu, po podłączeniu baterii w trakcie pracy kontrolka ładowania pali się na czerwono (błąd) a w Windowsie jest info "podłączony do zasilania, nie ładuje".

    Schematu niestety do tego komputera nie znalazłem. Jak ktoś ma schemat do tego lub podobnego modelu, to będę zobowiązany.

    Prosiłbym o porady z waszych doświadczeń, czy to przerwa gdzieś na PCB, czy poprawianie tych lutów (osobiście wątpię), jeżeli przerwa to od czego do czego (pulldown do któregoś mosfeta?).

    Pozdrawiam
    Gateway MT6839b - Nie ładuje baterii po wymianie gniazda ładowania Gateway MT6839b - Nie ładuje baterii po wymianie gniazda ładowania

    0 17
  • #2 17 Sty 2013 13:42
    miecho18
    Spec od komputerów

    Podaj oznaczenie kodowe płyty.

    0
  • #3 17 Sty 2013 22:58
    hotdog
    Poziom 26  

    z tego co widzę płyta ma ogólne oznaczenia MA7 (kilka laptopów na różne rynki na tej płycie), moja płyta na naklejce na gniazdach na RAM ma 31MA7B0000.

    Z tego co wyszukałem jest kilka innych oznaczeń 4006174R, 4006126R, 31MA7MB00A0.

    Płyta była używana w różnych laptopach: ML6228, ML6703, MT6705, MT6707, MT6709, NX570S.

    Dzisiaj zawyżyłem jeszcze 2 rzeczy:
    1. Laptop bez baterii uruchamia się dzisiaj i zamiast po oknie z informacją jak wejść do biosu się uruchomić uruchamiał się ponownie (BIOS, ciemny ekran, BIOS, ciemny ekran...) dopóki nie włożyłem baterii. Jak włożyłem to uruchomił się Windows. Później już uruchamiał się normalnie bez baterii, później znowu się nie uruchamiał.
    2. Przestało działać kilka klawiszy, miedzy innymi "6","y",",". Wiem że możliwości są 2 - uszkodzenie PCB, lub klawiatury (taśmy, lub folii). Chcąc wyeliminować możliwość uszkodzenia PCB, próbowałem zwierając poszczególne piny wywołać któryś z tych niedziałających klawiszy w notatniku, ale to mi się niestety nie udało.

    Pozdrawiam

    Dodano po 57 [minuty]:

    Znalazłem schemat tej części zasilania:
    Gateway MT6839b - Nie ładuje baterii po wymianie gniazda ładowania

    Ładowarka jest na MAX8724.

    0
  • #4 17 Sty 2013 23:06
    Adamstar1
    Poziom 25  

    Pierwsze pytanie, czy bateria jest sprawna? Bo jeżeli jest uszkodzona to po co grzebać płytę?

    0
  • #5 17 Sty 2013 23:07
    hotdog
    Poziom 26  

    Jest sprawna, uszkodzenie powstało po wymianie DC jack

    0
  • #6 17 Sty 2013 23:20
    Adamstar1
    Poziom 25  

    hotdog napisał:
    Jest sprawna, uszkodzenie powstało po wymianie DC jack

    Nie pytałem kiedy powstało uszkodzenie, tylko czy bateria jest sprawna. Rozumiem że po podłączeniu do innego laptopa normalnie się ładuje? Jakie informacje podaje BatteryMon?

    0
  • #7 17 Sty 2013 23:30
    hotdog
    Poziom 26  

    Jeżeli próbujesz pomóc, to dzięki, ale szukasz dziury tam gdzie jej nie ma.

    Napisałem wcześniej bateria przed wymianą jacka działała normalnie (TAK, ładowała się).

    Problem jest sprzętowy, jak komputer jest wyłączony bateria też się nie ładuje.

    Znalazłem pełny schemat płyty, w załączniku. Na str 37 jest schemat ładowarki.

    Gdzie szukać problemu?

    0
  • #8 18 Sty 2013 08:10
    Adamstar1
    Poziom 25  

    Więc zakładamy że bateria jest OK ;)
    Po wpięciu baterii jakie jest na niej napięcie, a jakie po późniejszym wpięciu zasilacza? Czy bateria komunikuje się z KBC?

    0
  • #9 20 Sty 2013 21:17
    hotdog
    Poziom 26  

    Na wyjściu na baterię jest napięcie ładowania, czyli +12,6V, jeden pin ma 3V i dwa inne piny 3.3V.

    Pomiary bez podłączonej baterii.

    Pozdrawiam

    0
  • Pomocny post
    #10 20 Sty 2013 22:58
    Adamstar1
    Poziom 25  

    hotdog napisał:
    Na wyjściu na baterię jest napięcie ładowania, czyli +12,6V, jeden pin ma 3V i dwa inne piny 3.3V.

    Pomiary bez podłączonej baterii.

    Pozdrawiam

    Bez podłączonej baterii nie powinieneś mieć tam 12,6V. Zbadaj sygnały i napięcia w obrębie kontrolera ładowania. Który pina ma ile, bo opisywanie że jeden, czy drugi jest dość nieprecyzyjne.

    0
  • #11 25 Kwi 2013 18:43
    hotdog
    Poziom 26  

    Na tą chwilę zdecydowałem o wymianie PC87541V.

    Najpierw zająłem się niesprawną klawiaturą, okazało się że ścieżki od klawiatury są całe, a zwarcia na 3 liniach X z wyprowadzeniami Y nie powodowały wyświetlania klawiszy.

    Ciężko było znaleźć ten układ, jest pod PCMCIA i pod naklejką. Układ jest na 100% uszkodzony, bo po podłączeniu zasilania, po kilku sekundach jest bardzo gorący (na granicy parzenia).

    Wobec tego 2 pytania:
    1. Czy dowolny układ typu "PC87541V" będzie działał? Ja mam firmy Winbond. Czy te układy trzeba jakoś zaprogramować?
    2. Czy ten układ też spełnia jakieś funkcje zarządzenia energią i to on może powodować, że na wyjściu baterii jest cały czas 12,6?

    0
  • #12 25 Kwi 2013 20:34
    adamadi33
    Poziom 43  

    hotdog napisał:
    1. Czy dowolny układ typu "PC87541V" będzie działał? Ja mam firmy Winbond. Czy te układy trzeba jakoś zaprogramować?
    2. Czy ten układ też spełnia jakieś funkcje zarządzenia energią i to on może powodować, że na wyjściu baterii jest cały czas 12,6?

    Poczytaj o Super I/O.

    0
  • #13 25 Kwi 2013 23:44
    hotdog
    Poziom 26  

    adamadi33 napisał:
    Poczytaj o Super I/O.


    Dzięki za odpowiedź, ale niestety dalej więcej wątpliwości niż wyjaśnień.

    1. Otóż układ (PC87541V) jest o kupienia różnych firm na allegro, czasami z jakimiś dodatkowymi oznaczeniami. Poza tym, wydaje mi się na tyle specjalizowany, że wolę się upewnić że firma nie ma znaczenia i układy się nie programuje.
    2. No o ile rozumiem jak ten układ będzie wysyłał info o statusie baterii, zasilania itp, to nie jestem pewien, czy ma wpływ na to, że bateria nie ładuje się przy wyłączonym komputerze. Chciałbym uniknąć studiowania datasheeta, układ i tak wymienię chciałem tylko wiedzieć, czy to on może być źródłem wszystkich problemów, czy szukać dalej.

    0
  • #14 26 Kwi 2013 10:40
    adamadi33
    Poziom 43  

    Wymieniłeś gniazdo od zasilania?

    0
  • #16 26 Kwi 2013 11:25
    a_jablon
    Poziom 18  

    Przepraszam, jeżeli pytanie wyda się głupie i pozornie nie na temat: czy gniazdo zasilania w tym laptopie ma 2 czy 3 pola styku z zasilaczem?

    Do czego dążę: w konstrukcji Masa + zasilanie (2 styki) ta kwestia wogóle nie ma znaczenia. W konstrukcji 3-pinowej trzeci pin pełni rolę kontrolno-identyfikacyjną. Jeżeli pojawia się na nim przerwa, laptop nie rozpoznaje zasilacza. Najczęściej notebook wówczas się uruchamia, ale NIE ŁADUJE BATERII. Może, jeżeli tam jest konstrukcja Masa + zasilanie + bolec kontrolny, to właśnie tu jest problem?

    0
  • #17 26 Kwi 2013 11:30
    hotdog
    Poziom 26  

    a_jablon napisał:
    Przepraszam, jeżeli pytanie wyda się głupie i pozornie nie na temat: czy gniazdo zasilania w tym laptopie ma 2 czy 3 pola styku z zasilaczem?

    Do czego dążę: w konstrukcji Masa + zasilanie (2 styki) ta kwestia wogóle nie ma znaczenia. W konstrukcji 3-pinowej trzeci pin pełni rolę kontrolno-identyfikacyjną. Jeżeli pojawia się na nim przerwa, laptop nie rozpoznaje zasilacza. Najczęściej notebook wówczas się uruchamia, ale NIE ŁADUJE BATERII. Może, jeżeli tam jest konstrukcja Masa + zasilanie + bolec kontrolny, to właśnie tu jest problem?


    Dzięki za odzew, problem jest grubszy. Na schemacie wszystko widać. Nie ma 3 pinu. Nie wiem czy tak jak piszesz się postępuje w praktyce, bo podłączenie wtyczki do zasilacza nie oznacza że jest na nim napięcie (może być odłączony od prądu), więc i tak trzeba mierzyć napięcie.

    0
  • #18 17 Cze 2013 22:38
    hotdog
    Poziom 26  

    po wymianie PC87541V wszystko wróciło do normy (układ kupiłem innej firmy niż miałem w diolucie za około 40PLN).

    Wymiana układu ciężka bo ma prawie 150 nóżek LQFP (raster 0,3mm z tego co pamiętam). Demontaż jest szczególnie trudny. Ja wymontowałem hotem i na szczęście płyta główna nie ucierpiała. Montaż to już z górki. Na układzie było widać lekkie pęknięcie na środku. Grzał się też dosyć znacznie, ale jest pod złączem PCIMCIA (i jeszcze naklejką), więc wcześniej tego nie widziałem.

    Dziwny zbieg okoliczności, że akurat w momencie wymiany DC JACK układ się uwalił.

    1