Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel, dni.robocze.niestandardowe - wybrane dni

17 Sty 2013 13:42 3249 11
  • Poziom 9  
    witam,
    Wiem że excel moze zliczyc mi dzni robocze, ja w moim przypadku mam jeszcze potrzebe żeby odjął mi inne dni wybrane przezemnie ( nie ma reguły).
    Probowałem polecenia dni.robocze.niestandardowe, ale w ten sposob jak znaznacze wybrany dzien w weekend to odejmuje mi go dwa razy.

    Przykład w załączniku
  • Poziom 9  
    ?? jakos nie dopatrzylem sie rozwiązania.
    Jak moge poprosic to przerob moj plik tak by działał
  • Poziom 14  
    Kolego, a jak dasz standardową funkcję dni robocze i odejmiesz funkcję licz jeżeli
    W twoim przypadku :
    =DNI.ROBOCZE(B2;B3)-LICZ.JEŻELI(H2:H32;"X").
    Nie wiem czy dokładnie o to ci chodzi .. PS -> format komórki wyjściowej jako liczba
  • Poziom 9  
    nic, to nie daje.
  • Poziom 29  
    majdan01 napisał:
    ?? jakos nie dopatrzylem sie rozwiązania.


    Czy ja napisałem że jest rozwiązanie?

    Pozdrówka
  • Poziom 14  
    majdan01 napisał:
    nic, to nie daje.


    Co masz na myśli ?
    Funkcja =DNI.ROBOCZE(B2;B3) zwraca wartość dni roboczych występujących między podanymi datami.
    Funkcja LICZ.JEŻELI(H2:H32;"X"). zwraca wartość występujących X występujących w tym zakresie.
    =DNI.ROBOCZE(B2;B3)-LICZ.JEŻELI(H2:H32;"X").
    Powiązanie obu funkcji wylicza ilość dni roboczych oraz pomniejsza je o te zaznaczone "X".
    Chyba że chcesz coś innego wyliczyć ?
  • Poziom 40  
    nunak napisał:
    Powiązanie obu funkcji wylicza ilość dni roboczych oraz pomniejsza je o te zaznaczone "X".
    Chyba że chcesz coś innego wyliczyć ?


    Ja tylko tak wtrące:
    Zwróć uwagę co "gnębi" autora:
    majdan01 napisał:
    ... w ten sposob jak znaznacze wybrany dzien w weekend to odejmuje mi go dwa razy.
  • Poziom 9  
    dzięki marek003 że zechciałeś przeczytać to i wyjaśnić, bo mi już było głupio powtarzać samego siebie.
  • Pomocny post
    Poziom 14  
    Fakt, moje niedopatrzenie, nie przeczytałem ze zrozumieniem.
    Szybkie rozwiązanie problemu -> zastosowanie funkcji suma warunków. Dni robocze -> raczej problemu nie ma -> dni robocze zaznaczone -> dopisujesz sobie "1"pomocniczą do kolumny "E" w każdy wiersz.
    później =SUMA.WARUNKÓW(E2:E32;F2:F32;"sobota";H2:H32;"X") i ewentualnie dla niedzieli lub powiązanie sobota i niedziela.
    Wtedy zwróci wartość zaznaczonych sobót i niedziel ->
    Ilość całkowitych dni zaznaczonych -> funkcja =LICZ.JEŻELI(H2:H32;"x")

    Trochę zamotane -> na spokojnie przeanalizuję i zobaczę co można uprościć
  • Pomocny post
    Poziom 40  
    Przyjżałem się dokładnie i już myślałem że excel 2010 ma błąd a to autor wprowadza wszystkich nieuważnie patrzących w błąd. :) Taki test na inteligentną spostrzegawczośc. :)

    Wszystko działą dobrze i liczy dobrze (pierwsza formuła autora) tylko że 01-01-2012 to niedziela nie wtorek i wszystko się wyjaśnia.

    Na przyszłość formatuj datę niestandardowo na "dddd" i będziesz miał pewność jaki to dzień