Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Cisco 800A - Modem i Router Cisco - brak sieci na laptopie

26 Sty 2013 20:32 2661 4
  • Poziom 13  
    Witam,
    Spalił mi się router od starego dostawcy.
    Jako, że pół roku temu robiłem CISCO to kupiłem modem serii 800A.
    Skonfigurowałem wczoraj, ale nie mogę dojść do tego dla czego nie mam sieci na komputerze, więc zamiast komputera podłączyłem router WiFi. Dalej nie działa.
    Nie pinguje. Podejrzewam, że mam coś źle z ustawieniami na routingu, ADSL działa, a przynajmniej 'debug' pokazuje, że wszystko się łączy.

    Jakie informacje potrzebujecie, żeby to zweryfikować?
    Obecnie mam to podłączone tak:

    Linia telefoniczna -> modem Cisco 800A (kablem z linii telefonicznej)
    Cisco 800A -> kabel Ethernet -> port 1 -> do laptopa (lub routera WiFi)

    Cisco 800A ma IP 192.168.1.40/24 na Ethernet 1
    Komputer ma adres 192.168.1.50/24

    Code:
                                                                         
    
                                                                         
                                                                         
                                                 
    Cisco#sh running-config
    Building configuration...

    Current configuration : 1690 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Cisco
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    !
    !
    !
    !
    ip cef
    !
    multilink bundle-name authenticated
    vpdn enable
    !
    vpdn-group pppoe
     request-dialin
      protocol pppoe
     l2tp tunnel receive-window 128
    !
    !
    !
    !
    !
    !
    !
    !
    bba-group pppoe global
    !
    !
    interface Ethernet0
     no ip address
     shutdown
     hold-queue 100 out
    !
    interface Ethernet2
     ip address 192.168.1.44 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     hold-queue 100 out
    !
    interface ATM0
     no ip address
     no atm ilmi-keepalive
     bundle-enable
     dsl operating-mode auto
     hold-queue 224 in
    !
    interface ATM0.1 point-to-point
     no snmp trap link-status
     pvc 8/35
      pppoe-client dial-pool-number 1
     !
    !
    interface FastEthernet1
     duplex auto
     speed auto
    !
    interface FastEthernet2
     duplex auto
     speed auto
    !
    interface FastEthernet3
     duplex auto
     speed auto
    !
    interface FastEthernet4
     duplex auto
     speed auto
    !
    interface Dialer0
     ip address negotiated
     ip mtu 1492
     ip nat outside
     ip virtual-reassembly
     encapsulation ppp
     dialer pool 1
     ppp authentication chap callin
     ppp chap hostname vodafone(malpa)vodafone.ie
     ppp chap password 0 broadband
    !
    interface Dialer1
     no ip address
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    ip http server
    no ip http secure-server
    !
    ip nat inside source list 1 interface Dialer1 overload
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    !
    control-plane
    !
    !
    line con 0
     logging synchronous
     no modem enable
    line aux 0
    line vty 0 4
     password cisco
     logging synchronous
     login
    !
    scheduler max-task-time 5000
    end


    Code:
                                                                         
    
                                                                         
                                                                         
                                                 
    Cisco#sh version
    Cisco IOS Software, C837 Software (C837-K9O3SY6-M), Version 12.4(11)T, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by Cisco Systems, Inc.
    Compiled Sun 19-Nov-06 03:36 by prod_rel_team

    ROM: System Bootstrap, Version 12.2(11r)YV6, RELEASE SOFTWARE (fc1)

    Cisco uptime is 4 minutes
    System returned to ROM by power-on
    System image file is "flash:c837-k9o3sy6-mz.124-11.T.bin"


    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    export(malpa)cisco.com.

    Cisco C837 (MPC857DSL) processor (revision 0x600) with 58983K/6553K bytes of memory.
    Processor board ID FOC10523ME3 (68772302), with hardware revision 5512
    Chassis serial number FCZ11041088
    CPU rev number 7
    2 Ethernet interfaces
    4 FastEthernet interfaces
    1 ATM interface
    128K bytes of NVRAM.
    12288K bytes of processor board System flash (Read/Write)
    2048K bytes of processor board Web flash (Read/Write)

    Configuration register is 0x2102


    Code:
                                                                         
    
                                                                         
                                                                         
                                                 
    Cisco#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    C    192.168.1.0/24 is directly connected, Ethernet2
    S*   0.0.0.0/0 is directly connected, Dialer0
  • Poziom 15  
    adnet.ag napisał:

    Skonfigurowałem wczoraj

    Hmm, jak konfigurowałeś? Przez konsolę? Jeśli tak (wszak zrobiłeś CISCO - cokolwiek to oznacza) to wiesz, że z poziomu konsoli powinieneś móc "spingować" najbliższy zewnętrzny węzeł sieci (czyli gateway dostawcy internetu).
    Jeśli to działa spróbuj coś dalej - np. jakiś dobrze Ci znany serwer. Jeśli to wszystko działa najprawdopodobniej Twój modem rzeczywiście zestawił poprawnie połączenie via DSL/ADSL. Dalej to rzeczywiście kwestia routingu.
    Z tabeli routingu wynika, że bramą (gateway) jest 0.0.0.0 i jest to trasa statyczna.
    Natomiast na porcie Ethernet 2 (nie FastEthernet) podpięta jest sieć lokalna z puli adresów prywatnych o adresie 192.168.1.0/24 - i pewnie tu jest pies pogrzebany bo piszesz
    Cytat:

    Obecnie mam to podłączone tak:

    Linia telefoniczna -> modem Cisco 800A (kablem z linii telefonicznej)
    Cisco 800A -> kabel Ethernet -> port 1 -> do laptopa (lub routera WiFi)

    Cisco 800A ma IP 192.168.1.40/24 na Ethernet 1
    Komputer ma adres 192.168.1.50/24

    A z załączonych logów wynika, że sieć 192.168.1.0 jest ustawiona na interfejsie Ethernet 2.

    Spróbuj przepiąć się do tego portu kabelkiem.

    Swoją drogą trochę dziwne jest, że jest interfejs Ethernet0 i Ethernet2 a brak Ethernet1.
    No i są cztery porty FastEthernet.
    Szkoda, że nie zechciałeś podać konkretnego modelu który kupiłeś. Cóż dostajesz tyle ile sam z siebie dajesz.

    Pozdrawiam

    Jarek
  • Poziom 13  
    SP2UKP napisał:
    Szkoda, że nie zechciałeś podać konkretnego modelu który kupiłeś. Cóż dostajesz tyle ile sam z siebie dajesz.

    Podałem wczoraj 'sh version' gdzie w 2 linii jest model
    Cytat:
    Cisco IOS Software, C837 Software (C837-K9O3SY6-M), Version 12.4(11)T, RELEASE SOFTWARE (fc2)


    Hmm, jak konfigurowałeś? Przez konsolę? Jeśli tak (wszak zrobiłeś CISCO - cokolwiek to oznacza) to wiesz, że z poziomu konsoli powinieneś móc "spingować" najbliższy zewnętrzny węzeł sieci (czyli gateway dostawcy internetu).
    Jeśli to działa spróbuj coś dalej - np. jakiś dobrze Ci znany serwer. Jeśli to wszystko działa najprawdopodobniej Twój modem rzeczywiście zestawił poprawnie połączenie via DSL/ADSL. Dalej to rzeczywiście kwestia routingu.
    Cytat:

    Cisco#ping 109.78.246.155

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 109.78.246.155, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 48/50/52 ms

    Cisco#ping 192.168.1.40

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.40, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms


    Cisco#ping 8.8.4.4

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 8.8.4.4, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 24/27/32 ms


    Cisco#ping 8.8.8.8

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 24/27/32 ms
    Cisco#


    Tak! Tu wszystko działa.

    SP2UKP napisał:

    Z tabeli routingu wynika, że bramą (gateway) jest 0.0.0.0 i jest to trasa statyczna.
    Natomiast na porcie Ethernet 2 (nie FastEthernet) podpięta jest sieć lokalna z puli adresów prywatnych o adresie 192.168.1.0/24 - i pewnie tu jest pies pogrzebany

    Swoją drogą trochę dziwne jest, że jest interfejs Ethernet0 i Ethernet2 a brak Ethernet1.
    No i są cztery porty FastEthernet.


    Jarek


    Wyjaśniam - w tym modelu urządzenia CISCO nie można skonfigurować Layer3 dla FastEthernet, więc trzeba to zrobić na interf Ethernet 0-2.
    Porty FastEthernet 1-4 są tylko jako switchport.
    Doszedłem wczoraj do wniosku, że port Ethernet0 może być uszkodzony więc postawiłem Ethernet2 - Tak, przepiołem kabel jak widać pinguje mojego PC i z mojego PC mogę pingować Ethernet2 ale już nie Google DNS (8.8.8.8 , 8.8.4.4)
    Code:
    C:\Users\Dom>ping 192.168.1.44
    

    Badanie 192.168.1.44 z 32 bajtami danych:
    Odpowiedü z 192.168.1.44: bajtÛw=32 czas=2ms TTL=255
    Odpowiedü z 192.168.1.44: bajtÛw=32 czas=6ms TTL=255
    Odpowiedü z 192.168.1.44: bajtÛw=32 czas=1ms TTL=255
    Odpowiedü z 192.168.1.44: bajtÛw=32 czas=1ms TTL=255

    Statystyka badania ping dla 192.168.1.44:
        Pakiety: Wys≥ane = 4, Odebrane = 4, Utracone = 0 (0% straty),
    Szacunkowy czas b≥πdzenia pakietÛw w millisekundach:
        Minimum = 1 ms, Maksimum = 6 ms, Czas úredni = 2 ms

    C:\Users\Dom>ping 8.8.8.8

    Badanie 8.8.8.8 z 32 bajtami danych:
    Odpowiedü z 192.168.1.44: Host docelowy jest nieosiπgalny.
    Odpowiedü z 192.168.1.44: Host docelowy jest nieosiπgalny.
    Odpowiedü z 192.168.1.44: Host docelowy jest nieosiπgalny.
    Odpowiedü z 192.168.1.44: Host docelowy jest nieosiπgalny.

    Statystyka badania ping dla 8.8.8.8:
        Pakiety: Wys≥ane = 4, Odebrane = 4, Utracone = 0 (0% straty),

    C:\Users\Dom>ping 8.8.4.4

    Badanie 8.8.4.4 z 32 bajtami danych:
    Up≥ynπ≥ limit czasu øπdania.
    Odpowiedü z 192.168.1.44: Host docelowy jest nieosiπgalny.
    Odpowiedü z 192.168.1.44: Host docelowy jest nieosiπgalny.
    Odpowiedü z 192.168.1.44: Host docelowy jest nieosiπgalny.

    Statystyka badania ping dla 8.8.4.4:
        Pakiety: Wys≥ane = 4, Odebrane = 3, Utracone = 1 (25% straty)


    Ponawiam pytanie: proszę o pomoc jak skonfigurować poprawnie "static route" żeby na PC był dostępny internet.
    Może jakieś 'debug' trzeba włączyć, żeby to sprawdzić ?

    Jakie jeszcze inne informacje będą przydatne?
    Dziękuję za poprzednią odpowiedź.

    Adam.
  • Pomocny post
    Poziom 15  
    Podejrzewam, że problem już rozwiązałeś. Ale ...
    Nadal nie wiadomo z jakim routerem masz do czynienia - polecam stronę http://www.cisco.com/en/US/products/hw/routers/ps380/index.html
    może to wyjaśni problem czytelników.
    Wyraźne i jednoznaczne określenie sprzętu leży po stronie pytającego - odpowiadający i tak musi "na sucho" rozwiązywać zagadkę więc warto zrobić co się da by nie było wątpliwości i nie trzeba było szukać w pytaniu podstawowych informacji.
    Treść zapytania -jego długość jest zniechęcająca. Podawaj tylko istotne informacje - zalew informacji jest chyba nawet gorszy niż ich brak.
    Po dłuższym poszukiwaniu w sieci (czy ja powinienem to robić?) dochodzę do wniosku że masz Cisco 837 Router.
    Sprawdź czy o ten sprzęt chodzi (http://www.cisco.com/en/US/docs/routers/access/800/837/hardware/installation/guide/837HIG.pdf).
    Pozdrawiam
  • Poziom 13  
    @SP2UKP
    Przecież jest napisane w 2giej linii
    Cytat:
    Cisco#sh version
    Cisco IOS Software, C837 Software (C837-K9O3SY6-M), Version 12.4(11)T, RELEASE SOFTWARE (fc2)

    Dziękuję za słowa krytyki