Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Rozdzielacz audio - 2 sygnały wejściowe 1 wyjściowy

psicho 04 Lut 2013 18:27 4179 19
  • #1 04 Lut 2013 18:27
    psicho
    Poziom 11  

    Witam,

    potrzebuję zbudować układ, który będzie miał dwa wejścia audio jack i jedno wyjście audio jack. Układ ma działać w taki sposób, na wyjściu ma być utrzymywany sygnał z pierwszego wejścia, aż do momentu podania sygnału na wejście drugie. Po wpięciu jacka do wejścia drugiego układ ma automatycznie wysterować na wyjście sygnał z wejścia drugiego. Po wypięciu jacka z wejścia drugiego, układ ma znów podawać na wyjście sygnał z wejścia pierwszego.

    Czyli tak:

    x, y - sygnały

    Przypadek 1.

    wejście1 = x
    wejscie2 = odłączone
    wyjście = x

    Przypadek 2.

    wejście1 = x
    wejście2 = y
    wyjście = y


    Czy mogą koledzy polecić jakiegoś scalaka do multipleksowania tych sygnałów? 74hct4066 nada się? Jakieś wskazówki?

    Z góry dziękuję i pozdrawiam.

    0 19
  • Relpol
  • Pomocny post
    #2 04 Lut 2013 19:20
    Dawid WAT
    Poziom 14  

    Witam

    można go zastosować choć moim zdaniem będzie zniekształcał sygnał wyjściowy.
    dlatego że rezystancją włączonego kanały zmienia się w zależności od sygnału wejściowego, od 50R do 75R.

    Ja bym polecił zastosowanie zwykłego przekaźnika do przełączania wyjść
    np taki:Przekaźnik
    Pozdrawiam Dawid

    0
  • #4 05 Lut 2013 23:20
    psicho
    Poziom 11  

    Dziękuję za odpowiedzi. Źle przedstawiłem problem przez co pomysł Zbyszka nie będzie działać. Otóż układ ma sterować sygnałem wyjściowym poprzez podanie (lub nie) sygnałów na wejścia. Wcześniej napisałem, że poprzez wpięcie jack'ów do wejść- mój błąd. Oba jacki wejściowe mają być wpięte na stałe. Jednakże dobrze by było zbudować układ tak, aby brak któregoś lub obu jacków wejściowych nie wpływał na wyjście jakimiś szumami czy charczeniem.

    Co do sposobu z przekaźnikiem, to czy przełączanie przekaźnika nie będzie powodować jakichś trzasków na sygnale wyjściowym?

    Znalazłem schemat rozdzielacza audio w EdW 10/2005, zbudowany w oparciu o układ HCF4052BE. Chcę pominąć bramki NOR.

    Rozdzielacz audio - 2 sygnały wejściowe 1 wyjściowy

    Mam pytanie w takim razie. Pewnie banalne i wstyd, że je zadaję ale proszę wybaczyć. Otóż jaki muszę dać rezystor przy kolektorze tranzystorów npn pełniących role klucza aby wysterować piny A i B układu HCF4052BE. I jeśli można prosić o 2 zdania objaśnienia jak to się liczy (tzn które parametry z noty katalogowej wykorzystać) to byłbym bardzo wdzięczny. Sygnał logiczny ma być wyprowadzony właśnie od kolektora i przy tranzystorze zatkanym ma być stan wysoki a przy tranzystorze w stanie nasycenia stan niski.

    I jeszcze jedno. Sygnał audio ma zmienną amplitudę. Czy tak dobrane elementy wzmacniacza pozwolą na spokojne wysterowanie baz tranzystorów przy podaniu jakiegokolwiek sygnału na wejście 1 lub wejście 2?

    Dziękuję i pozdrawiam.

    0
  • #5 06 Lut 2013 00:46
    Marian B
    Poziom 35  

    Po pojawieniu się sygnału na wejściu 2 powinien ten sygnał pojawić się na wyjściu, pomimo tego, że sygnał na wejściu 1 w dalszym ciągu istnieje, a po zaniku sygnału na wejściu 2 jest na wyjściu sugnał z wejścia 1. Takie przełączanie można zrobić za pomocą detektora/prostownika zamieniającego sygnał m.cz (zmienny) z wejścia 2 na napięcie stałe, czyli jedynkę logiczną, ktora przełączy odpowiednio tory. Po zaniku sygnału z wejścia 2, znika stałe /wyprostowane napięcie i na wyjściu sygnał z wejścia 1.
    W taki sposób są przełączane wejścia monitorowe w telewizorach starszej daty.

    0
  • #6 06 Lut 2013 11:18
    psicho
    Poziom 11  

    Potrzebuję zbudować klucz tranzystorowy do wysterowania logicznego 0 gdy na wejściu nie ma sygnału i logicznej 1 gdy na wejściu sygnał się pojawi. Sterowanie napięciem około 2-2.5 V (wyjście/a wzmacniacza operacyjnego). Sygnał logiczny ma służyć do sterowania układem HCF4052. Z resztą powinienem sobie poradzić. Układ HCF4052 ładnie steruje dźwiękiem z obu kanałów gdy wejścia S1 i S2 zmieniam na sztywno poprzez zwieranie do masy lub Vcc, także problem tylko z wysterowaniem tych poziomów automatycznie.

    -----------------

    Dalsza relacja z placu boju. Otóż układ działa już jak należy. Sygnał z jednego wejścia idzie bezpośrednio na układ HCF4052, sygnał z drugiego idzie dodatkowo na wzmacniacz operacyjny i steruje kluczem.

    Otóż problem jest teraz taki, że jeśli wejście które idzie dodatkowo na wzmacniacz "wisi" to zbiera zakłócenia, które są wzmacniane przez wzmacniacz i powoduje to załączanie klucza - wysterowanie szumów na wyjście. Próbowałem dorzucić filtr RC na wejście wzmacniacza i problem częściowo się rozwiązuje. Częściowo gdyż szumy są filtrowane i klucz się nie załącza, ale filtruje się niestety także sygnał wejściowy i dźwięk leci nadal z wejścia pierwszego :-) Jakieś sugestie?

    Z góry dziękuję i pozdrawiam

    0
  • Relpol
  • #7 06 Lut 2013 19:44
    Dawid WAT
    Poziom 14  

    Witam
    spróbuj tak to rozwiązać
    Rozdzielacz audio - 2 sygnały wejściowe 1 wyjściowy

    potencjometrem P2 regulujesz sygnał wejściowy ,tak aby na wejściu nieodwracającym komparatora przy małym sygnale wejściowym (najmniejszy jaki chcesz aby powodował przełączenie wejścia) było około 2-3V
    a potencjometrem P5 ustaw trochę mniejsze napięcie niż ustawiłeś na P2 wtedy na wyjściu komparatora dostaniesz stan wysoki

    Pozdrawiam Dawid

    0
  • #8 07 Lut 2013 10:59
    psicho
    Poziom 11  

    Witaj,

    dziękuję za podpowiedź. Komparator to dobre rozwiązanie bo rzeczywiście jak ustawię napięcie porównawcze powyżej tego co dają zakłócenia przy wypiętym jacku to można odciąć wysterowanie klucza. Jednak przy podłączeniu np telefonu komórkowego do wejścia, dopiero przy połowie ustawionej głośności podaje on napięcie nieco wyższe niż dają zakłócenia przy wypiętym jacku. A więc jak ustawię potencjometr porównawczy komparatora na ograniczenie zakłóceń to ograniczam również sygnały które pojawią się na wejściu gdy telefon jest ustawiony powiedzmy poi połowę głośności. Zakłócenia za wzmacniaczem osiągają poziom 0.8V, sygnał połowy głośności muzyki z telefonu którego używam (Samsung S5830) daje sygnał około 1V. Potencjometr P2 w takim razie pominąłem. Da się jakoś to poprawić? Myślałem nad zastosowaniem tego gniazda które podał Zbyszek, tak aby działało w ten sposób, że gdy jack jest odpięty to na wzmacniacz podaję masę, a gdy wpięty to sygnał. Ale problem w tym, że urządzenie ma działać zarówno w sytuacji gdy z gniazda jest wypięty jack, wpięty jack z podłączonym pod drugiej stronie kabla jakimś np telefonem, jak i w sytuacji gdy do gniazda jest wpięty jack i po drugiej stronie kabla jack wisi.

    Z góry dziękuję za podpowiedzi i pozdrawiam.

    0
  • #9 07 Lut 2013 20:35
    psicho
    Poziom 11  

    Problem jest nadal. Nie wiem jakim cudem układ przez moment działał jak wyżej napisałem, ale już nie działa. Problem w tym, że przy odpiętym jacku wejściowym (tym który daje sygnał na wzmacniacz), na wyjściu wzmacniacza jest około 3.5V a nie 0.8V. Sygnał dźwiękowy daje amplitudę w granicach 1-3V. Czyli zakłócenia dają większe napięcie jak sam sygnał. Niby można na komparatorze przepuszczać sygnały np niższe niż 3V co nie pozwoli na wysterowanie szmerów a przepuści czysty dźwięk, ale gdy dam pauzę w odtwarzaczu muzyki to wtedy poziom spada do 0V i to 0V jest wysterowywane na wyjście jack gdyż warunek logiczny komparatora również się zgadza. A przy pauzie na odtwarzaczu powinien od wysterować sygnał z wejścia pierwszego (tego idącego bezpośrednio na scalak 4052.

    Niby jest jakieś rozwiązanie... Takie aby użyć gniazda jack'a z wyłącznikiem które polecił Zbyszek. Wtedy wyciągnięty jack będzie zwierał wejście wzmacniacza do masy, a włożony jack z muzyką wysteruje tą właśnie muzykę na wyjście. Problem jest gdy do wejścia wepniemy dwustronny kabel jack i na drugiej stronie kabla nie podepniemy nic. Wtedy gniazdo już nie będzie zwierać do masy, a sam jack będzie anteną zbierającą zakłócenia które będą powodować szmery na wyjściu. A tak niestety nie może być :(

    Można zastosować 2 komparatory - jeden będzie sprawdzał czy sygnał jest mniejszy aniżeli 3V (napięcie 3.5V pojawia się przy odpiętym jack'u) a drugi będzie sprawdzał czy sygnał jest większy od 0V (jack wpięty ale włączana np pauza). Dobrze myślę? Jeśli tak to jak łatwo wymnożyć te wyjścia komparatorów aby uniknąć dorzucenie kolejnego scalaka?

    0
  • #10 07 Lut 2013 23:56
    Dawid WAT
    Poziom 14  

    Witam
    spróbuj dodać na wejście rezystor (tak z 10K) między sygnałem a masą zaraz przy jacku
    jak to nie pomoże to zacznij od nowa bo na pewno masz jakiś błąd albo któryś układ jest spalony

    aha pomocne by było gdybyś dodał kilka zdjęć tego co polutowałeś

    0
  • #11 08 Lut 2013 00:50
    psicho
    Poziom 11  

    Raczej nie jest to błąd jakiegoś układu bo jak mierzę napięcie na jacku między jednym kanałem a jego masą to jest około 3 mV (przy wypiętym jacku). Po wzmocnieniu daje 3.5V a wzmocnienie wysterowane jest na 1000 (rezystory 1M i 1K). Sygnał z telefonu daje napięcie 1-2mV bez wzmocnienia. Z rezystorem spróbuję jutro. Układ jest na pająku i są pewnie z tego powodu jakieś zakłócenia ale rozkładałem i składałem go już kilka razy i w napływie różnych pomysłów i nadal to samo. Dla mnie to dobra lekcja analogówki w której kuleję albo wręcz pełzam, ale czas goni i pasuje abym to zrobił jak najszybciej, dlatego wszelkie rady są dla mnie bardzo cenne.

    Pozdrawiam

    0
  • #12 08 Lut 2013 19:04
    Dawid WAT
    Poziom 14  

    Zaraz zaraz a jak Ty mierzysz ten sygnał że wychodzi 2mV??

    zbuduj detektor amplitudy z diody kondensatora i rezystora (ze schematu który zamieściłem) zmierz napięcie na kondensatorze i podaj wyniki. zobaczysz że na pewno jest większy

    i przypuszczam że wina tkwi w twoim wzmacniaczy ze wzmocnieniem 1000 razy
    spróbuj zmienić wzmocnienie na 3-5

    ale bez żadnego schematu twojego urządzenia nic więcej nie pomogę

    Pozdrawiam

    0
  • #13 10 Lut 2013 12:05
    psicho
    Poziom 11  

    Teraz zestawiłem układ wg schematu który podesłałeś. Mam kilka pytań. Chodzi o napięcie na kondensatorze C2 czy C3? Mogę je zmierzyć zwykłym multimetrem? Ustawienia miernika ACV czy DCV?

    Zmierzyłem napięcie DCV za diodą prostowniczą i wyszło tak:

    - Brak sygnału z telefonu - 20mV
    - 1/2 głośności na telefonie - 20mV
    - 3/4 głośności na telefonie - 20mV
    - 1/1 głośności na telefonie - 30-45 mV
    - Jack wypięty - 22mV

    Ale chyba w ten sposób mierzyć napięcia wyprostowanego nie mogę?

    Napięcie ACV przed diodą prostowniczą i wyszło tak:

    - Brak sygnału z telefonu - 0 mV
    - 1/2 głośności na telefonie - 20mV
    - 3/4 głośności na telefonie - 40mV
    - 1/1 głośności na telefonie - 200 mV
    - Jack wypięty - 1,2V

    0
  • #14 10 Lut 2013 21:45
    psicho
    Poziom 11  

    Potrzebuję jakoś sensownie ustabilizować sygnał przy odpiętym jacku jednocześnie nie tłumiąc sygnału wejściowego i uzyskać różne napięcia tych obu. Najlepiej sygnał przy odpiętym jacku ustalić bliskim zera lub Vcc. Wtedy można zrobić podwójny komparator na wzmacniaczu i wymnożyć logicznie wyniki wysterowując 1 lub 0 logiczne, lub na jakimś mikrokontrolerze załatwić sprawę sterowania. Napisałem prosty program na ATMege8 wykorzystujący przetwornik ADC aby ustalić zakres "przepuszczania" sygnału czyli wysterowania 1 logicznej. Ale niestety pomysł legł w gruzach gdyż przy podłączeniu drugiego jacka do płytki poziom napięć przy wypiętym jacku zaczął pulsować. Mikrokontroler postanowiłem wykorzystać gdyż po sygnał "szumów" po wzmocnieniu uzyskiwał mocne około 3.5V, sygnał dźwięku 0.5-2.5V a pauza 0V. Jednak po podpięciu drugiego jacka, jak już wspomniałem, sygnał szumów zaczął pulsować 0-3.5V, przez co ustalenie warunków logicznych jest niemożliwe. Przy tych pomiarach układ był zmontowany według schematu z EdW który przedstawiłem wcześniej. Wzmocnienie wzmacniacza ustawione na 50 i napięcie mierzone było z wyjścia tego wzmacniacza. Nie mam już pomysłów :(

    0
  • #15 11 Lut 2013 20:56
    Dawid WAT
    Poziom 14  

    psicho napisał:
    Teraz zestawiłem układ wg schematu który podesłałeś. Mam kilka pytań. Chodzi o napięcie na kondensatorze C2 czy C3? Mogę je zmierzyć zwykłym multimetrem? Ustawienia miernika ACV czy DCV?

    Zmierzyłem napięcie DCV za diodą prostowniczą i wyszło tak:

    - Brak sygnału z telefonu - 20mV
    - 1/2 głośności na telefonie - 20mV
    - 3/4 głośności na telefonie - 20mV
    - 1/1 głośności na telefonie - 30-45 mV
    - Jack wypięty - 22mV

    Ale chyba w ten sposób mierzyć napięcia wyprostowanego nie mogę?


    chodzi o napięcie na C2, możesz je zmierzyć zwykłym multimetrem ustawiając na DCV, a spróbuj jeszcze zewrzeć kondensator C3 i zrobić jeszcze raz pomiary

    jak możesz to zmierz napięcie także na wyjściu wzmacniacza IC1A

    co do napięcia 1,2V przy wypiętym jacku, to sprawdź czy masz wszędzie dobrze masę połączoną, możesz tak że upewnić się czy dobrze podłączasz sygnał z telefonu

    pozdrawiam Dawid

    0
  • #16 15 Lut 2013 18:53
    psicho
    Poziom 11  

    Największy problem w układzie stanowił sam wzmacniacz, który przy wiszącym wejściu, miał na nim stosunkowo duże napięcia. Różnie.. od kilkuset mV to kilku V. Zrezygnowałem z wzmacniacza, sygnał podaję poprzez tranzystor na wejście przetwornika ADC ATMega8. Tam już procesor na podstawie pomiarów steruje układem 4052. Na wyjściu układu dorzuciłem kondensatory ceramiczne 100nF w celu odseparowania składowej stałej. Układ działa bez zarzutów.

    Zastanawiam się, tak na przyszłość, czy jakaś filtracja zasilania wzmacniacza poprzez dławik poprawiła by sytuację. Samo podciągnięcie Vcc do masy poprzez kondensator 100nF nie poprawiło sytuacji.

    Pozdrawiam

    0
  • #17 15 Lut 2013 21:35
    Dawid WAT
    Poziom 14  

    Witam
    z mojego doświadczenia wiem że jak nie podasz napięcia na wzmacniacz (nieodwracający) i jeśli dasz jeszcze rezystor podciągający wejście do masy to na wyjściu masz równiutko 0V.
    Wydaje mi się że miałeś coś źle zaprojektowane albo uszkodzony któryś element.

    Pozdrawiam Dawid

    0
  • #18 15 Lut 2013 23:04
    psicho
    Poziom 11  

    Rezystor podciągający do masy na wejściu dawał 0V oczywiście, ale sygnał również sprowadzał do zera. Za słaby sygnał?

    0
  • #19 15 Lut 2013 23:50
    Dawid WAT
    Poziom 14  

    A jakiej wartości rezystor dałeś??
    ja bym dał tak około 470K

    Pozdrawiam Dawid

    0
  • #20 16 Lut 2013 00:20
    psicho
    Poziom 11  

    Już nie pamiętam, ale chyba 100k. No nic, jeśli ktoś ma jeszcze jakieś sugestie to proszę pisać. Jeśli nie to jutro zamknę temat. Dziękuję za wszystkie podpowiedzi.

    Pozdrawiam
    Adrian

    0
  Szukaj w 5mln produktów